NB.SI.ENS (NB.SI.ENS, fonction)

Cet article décrit la syntaxe de formule et l’utilisation de la fonction (fonction : formule pré-écrite qui prend une ou plusieurs valeurs, exécute une opération, puis renvoie une ou plusieurs valeurs. Utilisez des fonctions pour simplifier et raccourcir des formules sur une feuille de calcul, notamment celles qui effectuent des calculs longs et complexes.)NB.SI.ENS dans Microsoft Excel.

Description

Applique les critères aux cellules de plusieurs plages et compte le nombre de fois où tous les critères sont remplis.

Syntaxe

NB.SI.ENS(plage_critères1; critère1; [plage_critères2; critères2]…)

La syntaxe de la fonction NB.SI.ENS contient les arguments (argument : valeur qui fournit des informations à une action, un événement, une méthode, une propriété, une fonction ou une procédure.)suivants :

  • plage_critères1    Requis. La première plage dans laquelle évaluer les critères associés.
  • critère1    Requis. Critères, sous forme de nombre, d’expression, de référence de cellule ou de texte, qui déterminent les cellules à compter. Par exemple, les critères peuvent être les suivants :32, ">32", B4, "pommes" ou"32".
  • plage_critères1, plage_critères2, …    Facultatif. Plages supplémentaires et leurs critères associés. Jusqu’à 127 paires plage/critères sont autorisées.

 Important   Chaque plage supplémentaire doit avoir le même nombre de lignes et de colonnes en tant qu’argument plage_critères1 . Les plages ne doivent pas nécessairement être adjacentes.

Remarques

  • Chaque critère de plage est appliqué une cellule à la fois. Si toutes les premières cellules répondent à leurs critères associés, le nombre augmente de 1. Si toutes les deuxièmes cellules répondent à leurs critères associés, le nombre augmente de 1 à nouveau, et ainsi de suite jusqu’à ce que toutes les cellules soient évaluées.
  • Si l’argument critère est une référence à une cellule vide, la fonction NB.SI.ENS traite la cellule vide comme une valeur 0.
  • Vous pouvez utiliser les caractères génériques [le point d’interrogation (?) et l’astérisque (*)] dans l’argument critère. Le point d’interrogation correspond à un caractère quelconque et l’astérisque à une séquence de caractères. Si vous recherchez un point d’interrogation ou un astérisque, tapez un tilde (~) devant ce caractère. 

Exemples

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Vendeur Quota T1 dépassé Quota T2 dépassé Quota T3 dépassé
Davidoski Oui Non Non
Duerr Oui Oui Non
Sundaram Oui Oui Oui
Levitan Non Oui Oui
Formule Description Résultat
=NB.SI.ENS(B2:D2;"=Oui") Compte le nombre de fois que Davidoski a dépassé un quota de ventes pour les périodes T1, T2 et T3 (seulement durant T1). 1
=NB.SI.ENS(B2:B5;"=Oui";C2:C5;"=Oui") Compte le nombre de commerciaux qui ont dépassé leurs quotas T1 et T2. (Burke et Sundaram). 2
=NB.SI.ENS(B5:D5;"=Oui";B3:D3;"=Oui") Compte le nombre de fois que Levitan et Burke ont dépassé le même quota pour les périodes T1, T2 et T3 (seulement durant T2). 1

Exemple 2

Données  
1 5/1/2011
2 5/2/2011
3 5/3/2011
4 5/4/2011
5 5/5/2011
6 5/6/2011
Formule Description Résultat
=NB.SI.ENS(A2:A7;"<6";A2:A7;">1") Compte combien de nombres compris entre 1 et 6 (1 et 6 exclus) sont contenus dans les cellules A2 à A7. 4
=NB.SI.ENS(A2:A7; "<5";B2:B7;"<5/3/2011") Compte combien de lignes contiennent des nombres inférieurs à 5 dans les cellules A2 à A7 et des dates antérieures à 5/3/2011 dans les cellules B2 à B7. 0
=NB.SI.ENS(A2:A7; "<" & A6;B2:B7;"<" & B4) Description identique à l’exemple précédent, mais avec des références de cellules au lieu de constantes dans les critères. 2
 
 
S'applique à :