NB.SI

Compte le nombre de cellules à l'intérieur d'une plage qui répondent à un critère donné.

Syntaxe

NB.SI(plage;critère)

plage     représente la plage de cellules dans laquelle vous voulez compter les cellules.

critère     représente le critère, exprimé sous forme de nombre, d'expression, de référence de cellule ou de texte, qui détermine les cellules à compter. Par exemple, l'argument critère peut être exprimé sous une des formes suivantes : 32, « 32 », « >32 », « pommes » ou B4.

Remarques

Microsoft Excel offre des fonctions supplémentaires que vous pouvez utiliser pour analyser des données sur la base d'une condition.

  • Pour effectuer une addition basée sur une chaîne de texte ou sur un nombre à l'intérieur d'une plage, utilisez la fonction de feuille de calcul SOMME.SI.
  • Pour faire en sorte qu'une formule renvoie une ou deux valeur(s) basée(s) sur une condition telle qu'une prime à la vente basée sur un certain chiffre de vente, utilisez la fonction de feuille de calcul SI.
  • Pour compter les cellules qui sont vides ou qui ne le sont pas, utilisez les fonctions NBVAL et NB.VIDE.

Exemple 1 : formules NB.SI courantes

Vous comprendrez mieux l'exemple si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules qui renvoient les résultats, appuyez sur CTRL+` (accent grave) ou, dans le menu Outils, pointez sur Audit de formules, puis cliquez sur Mode Audit de formules.
 
1
2
3
4
5
A B
Données Données
pommes 32
oranges 54
pêches 75
pommes 86
Formule Description (résultat)
=NB.SI(A2:A5;"pommes") Nombre de cellules contenant pommes dans la première colonne ci-dessus (2)
=NB.SI(A2:A5;A4) Nombre de cellules contenant pêches dans la première colonne ci-dessus (2)
=NB.SI(A2:A5;A3)+NB.SI(A2:A5;A2) Nombre de cellules contenant oranges et pommes dans la première colonne ci-dessus (3)
=NB.SI(B2:B5;">55") Nombre de cellules dont la valeur est supérieure à 55 dans la deuxième colonne ci-dessus (2)
=NB.SI(B2:B5;"<>"&B4) Nombre de cellules dont la valeur n'est pas égale à 75 dans la deuxième colonne ci-dessus (2)
=NB.SI(B2:B5;">=32")-NB.SI(B2:B5;">85") Nombre de cellules dont la valeur est supérieure ou égale à 32 et inférieure ou égale à 85 dans la deuxième colonne ci-dessus (3)

Exemple 2 : formules NB.SI utilisant des caractères génériques et gérant des valeurs vides

Vous comprendrez mieux l'exemple si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple dans la rubrique d'aide. Ne sélectionnez pas les en-têtes de ligne ou de colonne.

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1, puis appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules qui renvoient les résultats, appuyez sur CTRL+` (accent grave) ou, dans le menu Outils, pointez sur Audit de formules, puis cliquez sur Mode Audit de formules.
 
1
2
3
4
5
6
7
A B
Données Données
pommes Oui
   
oranges NON
pêches Non
   
pommes OuI
Formule Description (résultat)
=NB.SI(A2:A7;"*es") Nombre de cellules se terminant par « es » dans la première colonne ci-dessus (4)
=NB.SI(A2:A7;"????es") Nombre de cellules se terminant par « es » et contenant exactement 6 lettres dans la première colonne ci-dessus (3)
=NB.SI(A2:A7;"*") Nombre de cellules contenant du texte dans la première colonne ci-dessus (4)
=NB.SI(A2:A7;"<>"&"*") Nombre de cellules ne contenant pas de texte dans la première colonne ci-dessus (2)
=NB.SI(B2:B7;"Non") / LIGNES(B2:B7) Nombre moyen de votes Non, cellules vides comprises, dans la seconde colonne ci-dessus au format pourcentage sans valeur décimale (33%)
=NB.SI(B2:B7;"Oui") / (LIGNES(B2:B7) -NB.SI(B2:B7; "<>"&"*")) Nombre moyen de votes Oui, cellules vides non comprises, dans la seconde colonne ci-dessus au format pourcentage sans valeur décimale (50%)

 Remarque    Pour afficher le nombre sous forme d'un pourcentage, sélectionnez la cellule et cliquez sur Cellule dans le menu Format. Cliquez sur l'onglet Nombre, puis cliquez sur Pourcentage, dans la zone Catégorie.

 
 
S'applique à :
Excel 2003