Méthodes pour additionner des valeurs dans une feuille de calcul

Compter ou additionner ?

Additionner (calculer la somme de valeurs) fait partie intégrante de l’analyse des données, qu’il s’agisse de calculer le sous-total des ventes dans la région du Nord-Ouest ou le total cumulé des recettes hebdomadaires. Excel vous offre différentes techniques pour calculer la somme de données.

Pour vous permettre de sélectionner la méthode la plus appropriée à vos besoins, cet article présente une synthèse complète des différentes méthodes, ainsi que des informations de support pour vous aider à décider rapidement quelle technique utiliser et des liens vers des articles plus approfondis.

Il ne faut pas confondre additionner le contenu de plusieurs cellules et compter le nombre de cellules. Pour plus d’informations sur la procédure à suivre pour compter le nombre de cellules, de colonnes ou de lignes de données, voir Fonction NB.SI.

Dans cet article


Addition et soustraction simples

Vous pouvez additionner et soustraire des nombres à l’aide d’une formule simple, en cliquant sur un bouton ou à l’aide d’une fonction de feuille de calcul.

Additionner les valeurs d’une cellule à l’aide d’une formule simple

Si vous souhaitez simplement obtenir rapidement un résultat, vous pouvez utiliser Excel comme une calculatrice de poche. Pour cela, utilisez l’opérateur arithmétique + (signe plus).

Formule Description Résultat
=5+10 Utilise l’opérateur + (signe plus) pour additionner deux ou plusieurs valeurs. 15
=A2+B2 Additionne les valeurs de deux ou plusieurs cellules. Dans ce cas, supposons que A2=5 et B2=10. 15
=A2+B2+20 Ajoute les valeurs de deux cellules à un nombre entré directement dans la formule. Dans ce cas, supposons que A2=5 et B2=10. 35

Haut de la page Haut de la page

Soustraire les valeurs d’une cellule à l’aide d’une formule simple

Pour cela, utilisez l’opérateur arithmétique - (signe moins). Par exemple, la formule =12-9 donne 3 comme résultat.

Pour plus d’informations sur l’utilisation d’opérateurs arithmétiques dans une formule, consultez l’article Utiliser Excel comme une calculatrice.

Haut de la page Haut de la page

Additionner les valeurs d’une colonne ou d’une ligne à l’aide d’un bouton

Vous pouvez utiliser le bouton SommeAuto pour additionner rapidement une plage de nombres dans une colonne ou une ligne. Cliquez sur une cellule vide en dessous d’une colonne de nombres ou à droite d’une ligne de nombres, puis cliquez sur SommeAuto. Excel sélectionne la plage la plus probable de données à additionner. Cliquez à nouveau sur SommeAuto pour accepter la plage sélectionnée par Excel ou sélectionnez votre propre plage, puis cliquez sur SommeAuto.

Utilisation du bouton SommeAuto pour additionner rapidement une ligne de données

Pour plus d’informations sur l’utilisation de SommeAuto, voir l’article Utiliser Excel comme une calculatrice .

Haut de la page Haut de la page

Additionner les valeurs d’une plage à l’aide d’une fonction

La fonction SOMME est utile lorsqu’il s’agit d’additionner ou de soustraire des valeurs de plages différentes ou de combiner des valeurs numériques avec des plages de nombres., Utilisez la fonction SOMME pour additionner tous les arguments (argument : valeurs utilisées par une fonction pour effectuer des opérations ou des calculs. Le type d’argument utilisé par une fonction lui est spécifique. Les arguments courants utilisés dans les fonctions comprennent les valeurs numériques, les valeurs de texte, les références de cellule et les noms.) que vous spécifiez entre les parenthèses. Chaque argument peut être une plage, une référence de cellule ou une valeur numérique positive ou négative.

Pour entrer une valeur simple, tapez =SOMME dans une cellule, suivi d’une parenthèse ouverte. Ensuite, tapez un ou plusieurs nombres, références de cellules ou plages de cellules, séparés par des virgules. Tapez une parenthèse fermée, puis appuyez sur ENTRÉE pour afficher le résultat. Vous pouvez également utiliser votre souris pour sélectionner les cellules contenant les données que vous souhaitez additionner.

 
1
2
3
A
Présence
4823
12335

Par exemple, en utilisant les données du tableau ci-dessus, toutes les formules suivantes utilisent la fonction SOMME pour obtenir la même valeur (17 158) :

  • =SOMME(4823,12335)
  • =SOMME(A2,A3)
  • =SOMME(A2:A3)
  • =SOMME(A2,12335)

La figure suivante illustre la formule qui utilise la fonction SOMME pour additionner la valeur de la cellule A2 et 12 335. En dessous de la formule, une info-bulle offre des conseils d’utilisation de la fonction SOMME.

Utilisation de la fonction SOMME pour additionner une cellule et une valeur

 Remarques 

  • Il n’existe pas de fonction SOUSTRAIRE dans Excel. Pour soustraire des valeurs à l’aide d’une fonction, utilisez les valeurs négatives avec la fonction SOMME. Par exemple, la formule =SOMME(30,A3,-15,-B6) ajoute 30 à la valeur de la cellule A3, soustrait 15, puis soustrait la valeur de la cellule B6.
  • Vous pouvez inclure jusqu’à 255 valeurs numériques ou références de cellules ou de plages, dans n’importe quelle combinaison, comme arguments de la fonction SOMME.

Pour plus d’informations, voir l’article Fonction SOMME.

Haut de la page Haut de la page

Soustraire les valeurs d’une plage à l’aide d’une fonction

Utilisez la fonction SOMME pour soustraire des nombres en entrant les nombres à soustraire en tant que nombres négatifs dans la formule.

 
1
2
3
A
Présence
29072
12335

Par exemple, en utilisant les données du tableau ci-dessus, toutes les formules suivantes utilisent la fonction SOMME pour obtenir la même valeur (16 737) :

  • =SOMME(29072;-12335)
  • =SOMME(A2:A3)
  • =SOMME(A2,-12335)
  • =SOMME(A2,(-1*(A3)))

Haut de la page Haut de la page

Calculer la somme de données par regroupement ou glissement

Vous pouvez utiliser un plan ou un rapport de tableau croisé dynamique pour regrouper et synthétiser vos données.

Additionner les valeurs d’une colonne à l’aide d’un plan

Si vos données sont organisées normalement (c’est-à-dire en lignes et colonnes) et que vous pouvez les regrouper de façon logique par valeurs de colonnes, vous pouvez regrouper et synthétiser vos données en créant un plan. La création d’un plan vous permet de synthétiser les données en insérant des sous-totaux et des totaux généraux. Supposons que vous avez les montants de ventes suivants, présentés par région et par mois.

 
1
2
3
4
5
6
7
A B C
Région Mois Ventes
Est Jan 18 000 €
Est Fév 23 000 €
Est Mar 19 000 €
Ouest Jan 17 000 €
Ouest Fév 27 000 €
Ouest Mar 21 000 €

L’illustration suivante présente un plan affichant les sous-totaux, regroupés par région, ainsi qu’un total général.

Plan avec sous-totaux et un total général

Utilisez la commande Sous-total (onglet Données, groupe Plan) pour créer un plan, des sous-totaux et un total général.

Les données source comprenaient trois lignes de données de la région Est, et trois de la région Ouest (lignes 2 à 7). Notez que l’opération de sous-total a inséré le Total Est dans la ligne 5, entre la dernière ligne de données pour la région Est et la première ligne de données pour la région Ouest.

Si vous cliquez sur la cellule A4, puis sur la commande Sous-total, Excel crée un plan, insère des lignes pour Total Est, Total Ouest et Total général et affiche ces totaux dans les cellules de la colonne Ventes.

Pour plus d’informations, voir les articles suivants :

Haut de la page Haut de la page

Additionner les valeurs d’une liste ou d’une colonne de tableau Excel à l’aide d’une fonction

Si vous avez besoin de plus de flexibilité, plutôt que d’utiliser la commande Sous-total, vous pouvez faire appel à la fonction SOUS.TOTAL pour calculer des sous-totaux et des totaux généraux dans des listes ou des tableaux Excel contenant des lignes ou des colonnes masquées. La fonction SOUS.TOTAL vous permet de spécifier un argument pour inclure ou non les valeurs masquées.

 Remarque   La fonction SOUS.TOTAL contrôle si les lignes masquées seront ou non incluses dans les résultats et ignore toujours les lignes qui ont été filtrées.

Par exemple, supposons que vous voulez calculer des sous-totaux et un total général des données des cellules C2 à C7, mais sans tenir compte des données masquées des lignes 3 et 6. La fonction que vous utilisez ressemble à ce qui suit :

=SOUS.TOTAL(109,C2:C7)

Le premier argument (109) spécifie que vous souhaitez additionner les valeurs de cette plage et ignorer les valeurs masquées. Pour inclure les valeurs masquées, utilisez 9 comme premier argument.

Pour plus d’informations, voir l’article Fonction SOUS.TOTAL.

Haut de la page Haut de la page

Calculer la somme de données et l’analyser sous plusieurs perspectives

Lorsqu’une feuille de calcul comprend des centaines, voire même des milliers de lignes de données similaires, il peut être difficile de tirer un sens de tous ces chiffres. Vous pouvez créer un rapport de tableau croisé dynamique dans Excel à partir de ces données pour afficher des sous-totaux et des totaux généraux, et vous pouvez synthétiser les données en fonction de catégories que vous spécifiez.

Pour créer rapidement un tableau croisé dynamique, sélectionnez une cellule dans une plage de données ou un tableau Excel, puis, sous l’onglet Insertion, dans le groupe Tables, cliquez sur Tableau croisé dynamique.

Pour démontrer la puissance d’un tableau croisé dynamique, notez que dans l’exemple suivant, les données des ventes comprennent de nombreuses lignes (il y a en fait 40 lignes de données, mais le graphique n’en affiche qu’une partie). En outre, les données ne sont pas synthétisées et aucun sous-total ou total général n’a été calculé.

Données utilisées dans un rapport de tableau croisé dynamique

Un rapport de tableau croisé dynamique basé sur ces mêmes données affiche des sous-totaux, des totaux généraux et présente une synthèse concise des données en un coup d’œil.

Données synthétisées et totalisées dans un rapport de tableau croisé dynamique

La création et l’utilisation de tableaux croisés dynamiques peut nécessiter une préparation initiale de vos données, ainsi que la maîtrise de certains concepts. Pour plus d’informations pour vous aider à démarrer, consultez les articles suivants :

Haut de la page Haut de la page

Calculer la somme de données en fonction d’une ou plusieurs conditions

En utilisant des fonctions de feuille de calcul, vous pouvez appliquer des conditions (également appelées critères) de façon à additionner uniquement les données remplissant les conditions que vous spécifiez.

Additionner les valeurs d’une plage en fonction d’une seule condition à l’aide d’une seule fonction ou d’une combinaison de fonctions

Utilisez la fonction SOMME.SI ou imbriquez la fonction SOMME dans la fonction SI.

Vous pouvez additionner des nombres selon un seul critère à l’aide de la fonction SOMME.SI ou en utilisant une combinaison des fonctions SOMME et SI.

Par exemple, la formule =SOMME.SI(A2:A6,">20") additionne uniquement les nombres supérieurs à 20 de la plage A2 à A6.

 Remarque   Les informations suivantes sont légèrement techniques, mais bonnes à savoir.

Si la fonction SOMME.SI n’existait pas, vous pourriez obtenir le même résultat en combinant les fonctions SI et SOMME. Combiner des fonctions de cette manière s’appelle également « imbriquer » des fonctions car une fonction est utilisée dans une autre.

Pour créer une formule qui reproduit la fonction SOMME.SI, vous entrez une formule qui traite la plage de A2 à A6 comme matrice, ce qui signifie que cette plage est considérée comme une seule entité comportant cinq cellules.

Votre formule ressemble à ceci : {=SOMME(SI(A2:A6>20,A2:A6))}. Les accolades entourant la formule indiquent qu’il s’agit d’une formule matricielle. Ce type de formule nécessite un traitement spécial. Plutôt que de taper les accolades vous-même, vous devez appuyer sur CTRL+MAJ+ENTRÉE  — Excel entoure alors la formule =SOMME(SI(A2:A6>20,A2:A6)) d’accolades. Si vous les tapez vous-même, vous ne créerez pas de formule matricielle.

Essayez ceci !    

Copiez les données du tableau suivant dans une feuille de calcul à la cellule A1. Après avoir collé les données, vous remarquerez que la cellule A10 contient une erreur #VALEUR!. Ceci signifie que vous devez convertir la cellule A10 en une formule matricielle. Pour cela, appuyez sur F2, puis sur CTRL+MAJ+ENTRÉE. Excel affiche le résultat (65) dans les cellules A8 et A10.

 
1
2
3
4
5
6
7
8
9
10
A
Épaisseur
18
29
36
11
16
En utilisant la fonction SOMME.SI
=SOMME.SI(A2:A6,">20")
En utilisant les fonctions SOMME et SI
=SOMME(SI(A2:A6>20,A2:A6))

Pour plus d’informations, voir l’article Fonction SOMME.SI et la rubrique « Additionner des nombres en fonction d’une condition » de l’article Additionner des nombres.

En outre, l’article Quand utiliser SUM(IF()) au lieu de COUNTBLANK() dans Excelde la Base de connaissances Microsoft offre des conseils supplémentaires sur l’utilisation de la fonction SOMME.SI.

Haut de la page Haut de la page

Additionner les valeurs d’une colonne en fonction d’une ou de plusieurs conditions à l’aide d’une fonction

Utilisez la fonction BDSOMME pour additionner les nombres d’un champ (colonne) d’enregistrements d’une liste ou d’une base de données répondant à des conditions (ou critères) que vous spécifiez.

Vous pouvez également utiliser la fonction BDSOMME lorsque vous avez une liste de colonnes et qu’il vous est plus facile de définir vos conditions dans une plage de cellules distincte plutôt que d’utiliser une fonction imbriquée.

Pour plus d’informations, voir l’article Fonction BDSOMME.

Vous pouvez également consulter la rubrique « Additionner des nombres en fonction de conditions stockées dans une plage distincte » de l’article Additionner des nombres pour obtenir des informations supplémentaires.

Haut de la page Haut de la page

Additionner les valeurs d’une plage en fonction de plusieurs conditions à l’aide d’une seule fonction ou d’une combinaison de fonctions

Utilisez la fonction SOMME.SI.ENS. Entrez la plage à additionner, une plage contenant des conditions, ainsi que les conditions appliquées à la plage de conditions. Vous pouvez également imbriquer les fonctions SOMME et SI.

Pour plus d’informations, voir l’article Fonction SOMME.SI.ENS.

Consultez la rubrique « Additionner des nombres en fonction de plusieurs conditions » de l’article Additionner des nombres pour plus d’informations sur l’utilisation des fonctions SOMME et SI combinées.

Pour plus d’informations, consultez également les articles suivants de la Base de connaissances Microsoft :

Haut de la page Haut de la page

Calculer la somme de coefficients de détermination et de valeurs matricielles

Vous pouvez utiliser des fonctions de feuille de calcul pour additionner des valeurs de deux ou plusieurs colonnes correspondantes. Il peut s’agir d’une opération simple telle que le calcul d’une mesure pondérée (voir l’exemple suivant qui calcule une moyenne cumulative) ou d’un calcul complexe en statistique ou en ingénierie.

Additionner le produit de valeurs correspondantes dans une ou plusieurs matrices

Utilisez la fonction SOMMEPROD. Par exemple, vous pouvez calculer la moyenne cumulative d’un étudiant à l’aide de la fonction SOMMEPROD et diviser ce résultat par le nombre de crédits, comme illustré dans la figure suivante.

Multiplication des valeurs correspondantes de deux matrices

La formule =SOMMEPROD(A2:A6,B2:B6)/SOMME(B2:B6) multiplie la note obtenue pour chaque classe par le nombre de crédits correspondants, additionne ces produits (61,3), divise cette somme par le nombre total de crédits (18) et détermine la moyenne cumulative (3,41). Ce type de calcul est aussi connu sous le nom de mesure pondérée.

Vous pouvez également utiliser la fonction SOMMEPROD dans des opérations mathématiques plus complexes en multipliant plusieurs matrices (matrice : permet de créer des formules uniques permettant d’obtenir plusieurs résultats et qui agissent sur un groupe d’arguments répartis dans des lignes et des colonnes. Une plage matricielle partage une même formule tandis qu’une constante matricielle est un groupe de constantes qui sert d’argument.).

La fonction SOMMEPROD est facile à utiliser avec des matrices de dimensions égales, mais vous pouvez également utiliser la fonction SOMME dans une formule matricielle (formule matricielle : formule qui effectue plusieurs calculs sur un ou plusieurs ensembles de valeurs et qui renvoie un ou plusieurs résultats. Les formules matricielles sont placées entre accolades { } et sont entrées en appuyant sur Ctrl+Maj+Entrée.) si vous avez besoin de plus de flexibilité.

Pour plus d’informations, voir l’article Fonction SOMMEPROD.

Les quatre fonctions ci-dessous sont généralement utilisées uniquement dans des applications statistiques ou mathématiques complexes et seule une brève description est donc présentée dans le cadre de cet article. Pour plus d’informations, cliquez sur le nom de la fonction pour accéder directement à la rubrique de référence correspondante.

  • Fonction SOMME.CARRES Renvoie la somme des carrés d’une liste de nombres ou de valeurs d’une plage. Par exemple, SOMME.CARRES(2,3) renvoie le résultat 13.
  • Fonction SOMME.X2PY2 Additionne la somme des carrés des valeurs correspondantes dans deux matrices.
  • Fonction SOMME.X2MY2  Renvoie la somme de la différence des carrés de valeurs correspondantes dans deux matrices.
  • Fonction SOMME.XMY2 Renvoie la somme des carrés des différences de valeurs correspondantes dans deux matrices.

Haut de la page Haut de la page

Cas particuliers (total cumulé, valeurs uniques)

Vous pouvez utiliser des fonctions de feuille de calcul pour créer des totaux qui sont mis à jour automatiquement lorsque vous ajoutez des données à une plage ou un tableau, ou pour additionner uniquement les valeurs uniques d’une plage ou d’un tableau.

Créer un total cumulé à l’aide d’une fonction

Utilisez la fonction SOMME. Par exemple, créez des en-têtes de colonnes dans une feuille de calcul appelés Dépôts, Retraits et Solde.

  1. Dans la première cellule de la colonne Solde, entrez votre solde initial.
  2. Dans la cellule directement en dessous de votre solde (dans notre cas, C3), entrez une formule qui ajoute la valeur de la colonne Dépôts sur la même ligne et soustrait la valeur de la colonne Retraits (=SOMME(C2,A3,-B3).
  3. Faites glisser cette formule vers toutes les nouvelles lignes que vous ajoutez. Dans l’exemple suivant, la formule est déplacée vers la ligne 4.
 
1
2
3
4
A B C
Dépôts Retraits Solde
500
1000 625 =SOMME(C2,A3,-B3)
1000 740 =SOMME(C3,A4,-B4)

Vous pouvez utiliser un solde courant (cumulé) comme vous utiliseriez un livre des chèques, pour voir la valeur des éléments des cellules augmenter ou diminuer au fur et à mesure que vous entrez de nouveaux éléments et de nouvelles valeurs.

Pour plus d’informations, voir l’article Calculer un solde en cours.

Haut de la page Haut de la page

Additionner les valeurs uniques d’une plage à l’aide d’une formule composée

Dans une colonne, entrez une liste de valeurs contenant des doublons, puis utilisez une combinaison des fonctions SOMME, SI et FREQUENCE pour additionner uniquement les valeurs uniques situées dans cette plage.

Pour plus d’informations sur la procédure à suivre, consultez la rubrique « Ajouter des valeurs uniques » de l’article Additionner des nombres.

Haut de la page Haut de la page

Inclure des valeurs d’autres feuilles de calcul ou classeurs dans une formule

Vous pouvez ajouter ou soustraire des cellules ou des plages de données d’autres feuilles de calcul ou classeurs dans une formule en incluant une référence à ces cellules ou plages de données. Pour faire référence à une cellule ou une plage située dans une autre feuille de calcul ou un autre classeur, appliquez les instructions présentées dans le tableau suivant.

Pour faire référence à Entrez ceci Exemples
Une cellule ou une plage d’une autre feuille de calcul du même classeur Le nom de la feuille de calcul suivi d’un point d’exclamation, puis de la référence de cellule ou du nom de la plage. Feuille2!B2:B4
Feuille3!ChiffreVentes
Une cellule ou une plage d’un autre classeur ouvert Le nom de fichier du classeur entre crochets ([]), suivi du nom de la feuille de calcul, d’un point d’exclamation, puis de la référence de cellule ou du nom de la plage. [MonClasseur.xlsx]Feuille1!A7
Une cellule ou une plage d’un autre classeur qui n’est pas ouvert Le chemin complet et le nom de fichier du classeur entre crochets ([]), suivi du nom de la feuille de calcul, d’un point d’exclamation, puis de la référence de cellule ou du nom de la plage. Si le chemin complet contient des espaces, placez des apostrophes au début du chemin et à la fin du nom de la feuille (voir exemple). [’C:\Mes documents\[MonClasseur.xlsx]Feuille1’!A2:A5

Haut de la page Haut de la page

Additionner et soustraire des valeurs de date et d’heure

Vous pouvez utiliser des fonctions d’heure et de date et même une addition ou soustraction simple pour calculer le temps écoulé, estimer la date d’exécution d’un projet etc. Le tableau suivant présente plusieurs formules qui peuvent être utilisées pour calculer le temps ou les jours écoulés. Notez que si vous soustrayez une date ou une heure de façon à obtenir une valeur négative, Excel affiche les caractères ### dans la cellule contenant la formule.

 
1
2
3
4
5
A B C
Heure de début Heure de fin Formule de calcul du temps écoulé Description (résultat)
11:55:24 14:48:13 =B2-A2 Affiche le temps écoulé en heures, minutes et secondes. Dans ce cas, Excel affiche le résultat (2:52:49) au format « AM » car la différence est inférieure à 12 heures. Si la différence était de plus de 12 heures, Excel l’afficherait au format « PM ».
       
Date de début Date de fin Formule de calcul des jours écoulés Description (résultat)
28/5/2008 03/6/2008 =B5-A5 Affiche le nombre de jours écoulés (6).

Lorsque vous travaillez avec des valeurs de date et d’heure, vous pouvez obtenir des résultats imprévus. Il convient d’être vigilant avec ce type d’opération.

Haut de la page Haut de la page

Affichage des calculs dans la barre d’état d’Excel

Pour jeter un coup d’œil rapide aux totaux de cellules sélectionnées dans votre feuille de calcul, examinez la barre d’état d’Excel (située en bas de la fenêtre du document). Dans la barre d’état, Excel affiche la somme de deux ou plusieurs cellules sélectionnées contenant des données numériques. La valeur de somme affichée dans la barre d’état est mise à jour au fur et à mesure que vous sélectionnez ou désélectionnez des cellules.

Barre d’état d’Excel

Légende 1 Barre d’état d’Excel
Légende 2 Valeur de somme calculée dans la barre d’état d’Excel

Lorsqu’une ou plusieurs cellules sont sélectionnées, des informations sur les données de ces cellules s’affichent dans la barre d’état d’Excel. Par exemple, si quatre cellules sont sélectionnées dans votre feuille de calcul et qu’elle contiennent les valeurs 2, 3, une chaîne de texte (par exemple « nuage » et 4, les valeurs suivantes peuvent s’afficher simultanément dans la barre d’état : Moyenne, Nombre, Nb (nombres), Min, Max et Somme. Cliquez avec le bouton droit sur la barre d’état pour afficher ou masquer l’une de ces valeurs ou toutes. Ces valeurs sont illustrées ci-dessous.

Barre d’état affichant les calculs et le nombre de cellules sélectionnées

Remarque    Dans les versions d’Excel antérieures à Excel 2007, ces valeurs peuvent être affichées dans la barre d’état, mais uniquement une par une.

Haut de la page Haut de la page

 
 
S'applique à :
Excel 2010, Excel 2007