Fonction SOMME.SI

Cet article décrit la syntaxe de la formule et l’utilisation de la fonction (fonction : formule pré-écrite qui prend une ou plusieurs valeurs, exécute une opération, puis renvoie une ou plusieurs valeurs. Utilisez des fonctions pour simplifier et raccourcir des formules sur une feuille de calcul, notamment celles qui effectuent des calculs longs et complexes.) SOMME.SI dans Microsoft Office Excel.

Description

La fonction SOMME.SI permet de calculer la somme des valeurs d’une plage (plage : deux cellules au minimum d’une feuille de calcul. Une plage peut contenir des cellules adjacentes ou non adjacentes.) qui répond au critère spécifié. Par exemple, supposons que dans une colonne contenant des nombres, vous vouliez uniquement calculer la somme des valeurs supérieures à 5. Vous pouvez utiliser la formule suivante :

=SOMME.SI(B2:B25;">5")

Dans cet exemple, le critère est appliqué aux valeurs calculées. Si vous le souhaitez, vous pouvez appliquer le critère à une plage et calculer les valeurs dans une autre plage. Par exemple, la formule =SOMME.SI(B2:B5;"Jean";C2:C5) calcule uniquement la somme des valeurs de la plage C2:C5, dans laquelle les cellules correspondantes de la plage B2:B5 contiennent le mot « Jean ».

 Remarque   Pour calculer la somme de cellules en fonction de plusieurs critères, voir Fonction SOMME.SI.ENS.

Syntaxe

SOMME.SI(plage;critère;[somme_plage])

La syntaxe de la fonction SOMME.SI comporte les arguments (argument : valeur qui fournit des informations à une action, un événement, une méthode, une propriété, une fonction ou une procédure.) suivants :

  • plage    Obligatoire. Plage de cellules à calculer en fonction du critère. Les cellules de chaque plage doivent être des nombres ou des noms, des matrices ou des références contenant des nombres. Les valeurs vides ou textuelles ne sont pas prises en compte.
  • critère    Obligatoire. critère, exprimé sous forme de nombre, d’expression, de référence de cellule, de texte ou de fonction qui définit les cellules à ajouter. Par exemple, l’argument critère peut être exprimé sous une des formes suivantes : 32, ">32", B5, 32, "32", "pommes" ou AUJOURDHUI().

 Important   Tous les critères textuels et tous les critères qui contiennent des symboles mathématiques ou logiques doivent être placés entre guillemets ("). En revanche, les guillemets ne sont pas nécessaires pour les critères numériques.

  • plage_somme    Facultatif. Cellules réelles à ajouter, si vous voulez ajouter d’autres cellules que celles qui sont spécifiées dans l’argument plage. Si l’argument plage_somme est omis, Excel ajoute les cellules spécifiées dans l’argument plage (les cellules auxquelles s’applique le critère).

 Remarques 

  • L’argument plage_somme ne doit pas nécessairement avoir la même taille et la même forme que l’argument plage. Les cellules effectivement additionnées sont déterminées en utilisant la cellule supérieure gauche de l’argument plage_somme comme cellule de début, puis en incluant les cellules dont la taille et la forme correspondent à l’argument plage. Par exemple :
Si la plage est Si somme_plage est Les cellules sont
A1:A5 B1:B5 B1:B5
A1:A5 B1:B3 B1:B5
A1:B4 C1:D4 C1:D4
A1:B4 C1:C2 C1:D4
  • Vous pouvez utiliser les caractères génériques  point d’interrogation (?) et astérisque (*)  dans l’argument critère. Le point d’interrogation correspond à un caractère quelconque et l’astérisque correspond à une séquence de caractères quelconque. Pour rechercher réellement un point d’interrogation ou un astérisque, tapez un tilde (~) devant ce caractère.

Exemple 1

L'exemple sera peut-être plus facile à comprendre si vous le copiez dans une feuille de calcul vide.

AfficherComment copier un exemple ?

  • Sélectionnez l’exemple dans cet article. Si vous copiez l’exemple dans Excel Web App, copiez et collez une cellule à la fois.

 Important   Ne sélectionnez pas les en-têtes des lignes ou des colonnes.

Sélection d’un exemple de l’aide

Sélection d’un exemple de l’aide
  • Appuyez sur Ctrl + C.
  • Créez un classeur ou une feuille de calcul vide.
  • Dans la feuille de calcul, sélectionnez la cellule A1, puis appuyez sur Ctrl + V. Si vous travaillez dans Excel Web App, répétez la copie et le collage pour chaque cellule dans l’exemple.

 Important   Pour que l’exemple fonctionne correctement, vous devez le coller dans la cellule A1 de la feuille de calcul.

  • Pour passer de l’affichage des résultats à celui des formules qui ont permis d’obtenir les résultats affichés, appuyez sur Ctrl+` (accent grave) ou, sous l’onglet Formules, dans le groupe Audit des formules, cliquez sur le bouton Afficher les formules.

Après avoir copié l’exemple dans une feuille de calcul vide, vous pouvez l’adapter en fonction de vos besoins.


 
1
2
3
4
5
6

7

8


9


10
A B C
Valeur de propriété Commission Données
100 000 7 000 250 000
200 000 14 000
300 000 21 000
400 000 28 000
Formule Description Résultat
=SOMME.SI(A2:A5;">160 000";B2:B5) Somme des valeurs de commissions excédant 160 000 63 000
=SOMME.SI(A2:A5;">160 000") Somme des valeurs de propriétés excédant 160 000 900 000
=SOMME.SI(A2:A5;300000;B2:B3) Somme des commissions relatives aux valeurs de propriétés égales à 300 000 21 000
=SOMME.SI(A2:A5;">" & C2;B2:B3) Somme des commissions relatives aux valeurs de propriétés supérieures à la valeur de C2. 49 000

Exemple 2

L'exemple sera peut-être plus facile à comprendre si vous le copiez dans une feuille de calcul vide.

AfficherComment copier un exemple ?

  • Sélectionnez l’exemple dans cet article. Si vous copiez l’exemple dans Excel Web App, copiez et collez une cellule à la fois.

 Important   Ne sélectionnez pas les en-têtes des lignes ou des colonnes.

Sélection d’un exemple de l’aide

Sélection d’un exemple de l’aide
  • Appuyez sur Ctrl + C.
  • Créez un classeur ou une feuille de calcul vide.
  • Dans la feuille de calcul, sélectionnez la cellule A1, puis appuyez sur Ctrl + V. Si vous travaillez dans Excel Web App, répétez la copie et le collage pour chaque cellule dans l’exemple.

 Important   Pour que l’exemple fonctionne correctement, vous devez le coller dans la cellule A1 de la feuille de calcul.

  • Pour passer de l’affichage des résultats à celui des formules qui ont permis d’obtenir les résultats affichés, appuyez sur Ctrl+` (accent grave) ou, sous l’onglet Formules, dans le groupe Audit des formules, cliquez sur le bouton Afficher les formules.

Après avoir copié l’exemple dans une feuille de calcul vide, vous pouvez l’adapter en fonction de vos besoins.


 
1
2
3
4
5
6
7
8

9

10


11


12
A B C
Catégorie Produits alimentaires Ventes
Légumes Tomates 2300
Légumes Céleri 5500
Fruits Oranges 800
Beurre 400
Légumes Carottes 4200
Fruits Pommes 1200
Formule Description Résultat
=SOMME.SI(A2:A7;"Fruits";C2:C7) Somme de la vente de tous les produits alimentaires dans la catégorie « Fruits ». 2000
=SOMME.SI(A2:A7;"Légumes";C2:C7) Somme de la vente de tous les produits alimentaires dans la catégorie « Légumes ». 12000
=SOMME.SI(B2:B7;"*es";C2:C7) Somme de la vente de tous les produits alimentaires se terminant par « es » (Tomates, Oranges et Pommes). 4300
=SOMMES.SI(A2:A7;"";C2:C7) Somme de la vente de tous les produits alimentaires n’appartenant pas à une catégorie spécifique. 400
 
 
S'applique à :
Excel 2007