Calculer la moyenne des nombres

AfficherPour calculer la moyenne des nombres dans une ligne ou une colonne contiguë

  1. Cliquez sur une cellule située en dessous ou à droite des nombres dont vous souhaitez connaître la moyenne.
  2. Cliquez sur la flèche en regard de Somme automatique image du bouton dans la barre d'outils (barre d’outils : barre qui contient des boutons et des options que vous utilisez pour exécuter des commandes. Pour afficher une barre d’outils, appuyez sur ALT, puis sur MAJ+F10.) Standard, puis sur Moyenne et appuyez sur ENTRÉE.

AfficherPour calculer la moyenne des nombres ne se trouvant pas dans une ligne ou une colonne contiguë

Utilisez la fonction MOYENNE pour exécuter cette tâche.

Exemple de feuille de calcul

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.
 
1
2
3
4
5
6
7
A
Données
10
7
9
27
0
4
Formule Description (résultat)
=MOYENNE(A2:A7) Calcule la moyenne de tous les nombres de la liste ci-dessus (9,5)
=MOYENNE(A2:A4,A7) Calcule la moyenne des trois premiers nombres et du dernier de la liste (7,5)
=MOYENNE(SI(A2:A7<>0, A2:A7,"")) Calcule la moyenne des nombres de la liste à l'exception de ceux qui contiennent la valeur zéro, par exemple la cellule A6 (11,4)

 Remarque    La dernière formule de cet exemple doit être entrée sous la forme d'une formule matricielle (formule matricielle : formule qui effectue plusieurs calculs sur un ou plusieurs ensembles de valeurs et qui renvoie un ou plusieurs résultats. Les formules matricielles sont placées entre accolades { } et sont entrées en appuyant sur Ctrl+Maj+Entrée.). Après avoir copié l'exemple dans une feuille de calcul vide, sélectionnez la cellule A11. Appuyez sur F2, puis sur CTRL+MAJ+ENTRÉE. Si la formule n'est pas entrée sous la forme d'une formule matricielle, l'erreur #VALEUR! est renvoyée.

Détails de la fonction

MOYENNE

AfficherPour calculer une moyenne pondérée

Utilisez les fonctions SOMMEPROD et SOMME pour exécuter cette tâche.

Exemple de feuille de calcul

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.

Cet exemple calcule le prix moyen payé pour une unité parmi trois achats, où chaque achat comporte un nombre différent d'unités à un prix unitaire différent.

 
1
2
3
4
A B
Prix à l'unité Nombre d'unités
20 500
25 750
35 200
Formule Description (résultat)
=SOMMEPROD(A2:A4,B2:B4)/SOMME(B2:B4) Divise le coût total des trois commandes par le nombre d'unités commandées  (24,66)

Détails de la fonction

SOMME

SOMMEPROD

AfficherPour calculer la moyenne des nombres, en ignorant les valeurs nulles (0)

Utilisez les fonctions MOYENNE et SI pour exécuter cette tâche.

Exemple de feuille de calcul

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.
 
1
2
3
4
5
6
7
A
Données
10
7
9
27
0
4
Formule Description (résultat)
=MOYENNE(SI(A2:A7<>0, A2:A7,"")) Calcule la moyenne des nombres dans la liste à l'exception de ceux qui contiennent la valeur zéro, par exemple la cellule A6 (11,4)

 Remarque    La formule de cet exemple doit être entrée sous la forme d'une formule matricielle (formule matricielle : formule qui effectue plusieurs calculs sur un ou plusieurs ensembles de valeurs et qui renvoie un ou plusieurs résultats. Les formules matricielles sont placées entre accolades { } et sont entrées en appuyant sur Ctrl+Maj+Entrée.). Après avoir copié l'exemple dans une feuille de calcul vide, sélectionnez la cellule A9. Appuyez sur F2 et sur CTRL+MAJ+ENTRÉE. Si la formule n'est pas entrée sous la forme d'une formule matricielle, l'erreur #VALEUR! est renvoyée.

Détails de la fonction

MOYENNE

SI

 
 
S'applique à :
Excel 2003