Additionner des nombres

AfficherAdditionner des nombres

Vous pouvez additionner des nombres au fur et à mesure que vous les tapez dans une cellule. Par exemple, tapez =5+10 dans une cellule pour afficher le résultat 15.

AfficherPour additionner tous les nombres d'une ligne ou d'une colonne contiguë

Utilisez la fonction Somme automatique image du bouton   pour effectuer cette tâche.

  1. Cliquez sur une cellule en dessous de la colonne de nombres ou à droite de la ligne de nombres.
  2. Cliquez sur Somme automatique image du bouton dans la barre d'outils (barre d’outils : barre qui contient des boutons et des options que vous utilisez pour exécuter des commandes. Pour afficher une barre d’outils, appuyez sur ALT, puis sur MAJ+F10.) Standard, puis appuyez sur ENTRÉE.

AfficherPour additionner des nombres qui ne se trouvent pas dans une ligne ou une colonne contiguë

Vous pouvez utiliser la fonction SOMME pour effectuer cette tâche, comme indiqué dans l'exemple ci-dessous.

Exemple

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.
 
1
2
3
4
5
6
7
A B
Vendeur Facture
Beaune 15000
Beaune 9000
Schwartz 8000
Schwartz 20000
Beaune 5000
Duprez 22500
Formule Description (résultat)
=SOMME(B2:B3;B5) Additionne 2 factures de Beaune et une facture de Schwartz (44000)
=SOMME(B2;B5;B7) Additionne les factures individuelles de Beaune, Schwartz et Duprez (57500)

 Remarque    La fonction SOMME peut comprendre jusqu'à 30 cellules ou références de plage.

Pour plus d'informations, consultez la fonction SOMME.

AfficherPour additionner des nombres en fonction d'une condition

Vous pouvez utiliser la fonction SOMME.SI pour créer le total d'une plage en fonction de la valeur d'une autre plage, comme indiqué dans l'exemple ci-dessous.

Exemple

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.
 
1
2
3
4
5
6
7
A B
Vendeur Facture
Beaune 15000
Beaune 9000
Schwartz 8000
Schwartz 20000
Beaune 5000
Duprez 22500
Formule Description (résultat)
=SOMME.SI(A2:A7;"Beaune";B2:B7) Somme des factures de Beaune (29000)
=SOMME.SI(B2:B7;">=9000";B2:B7) Somme des factures importantes supérieures ou égales à 9 000 (66500)
=SOMME.SI(B2:B7;"<9000";B2:B7) Somme des factures moins importantes inférieures à 9000 (13000)

La fonction SOMME.SI utilise les arguments suivants

Formule avec la fonction SOMME.SI

Formule avec la fonction SOMME.SI

Légende 1   Plage à évaluer : vérifie ces cellules pour déterminer si une ligne répond à vos critères.

Légende 2   Critères : la condition à laquelle les cellules que vous évaluez doivent répondre pour que la ligne soit incluse dans la somme.

Légende 3   Plage à additionner : additionne les chiffres de ces cellules, à condition que la ligne répond à la condition.

Pour plus d'informations, consultez la fonction SOMME.SI.

AfficherPour additionner des nombres en fonction de plusieurs conditions

Vous pouvez utiliser les fonctions SI et SOMME pour effectuer cette tâche, comme indiqué dans l'exemple ci-dessous.

Exemple

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Région Vendeur Style Ventes
Sud Beaune Boissons 3571
Ouest Bartoli Produits laitiers 3338
Est Schwartz Boissons 5122
Nord Schwartz Produits laitiers 6239
Sud Duprez Produit 8677
Sud Bartoli Viandes 450
Sud Bartoli Viandes 7673
Est Schwartz Produit 664
Nord Bartoli Produit 1500
Sud Duprez Viandes 6596
Formule Description (résultat)
=SOMME(SI((A2:A11="Sud")*(C2:C11="Viandes");D2:D11)) Somme des ventes de viandes dans la région Sud (14719)
=SOMME(SI((A2:A11="Sud")+(A2:A11="Est");D2:D11)) Somme des ventes pour la région Sud ou Est (32753)

 Remarque    Les formules de l'exemple doivent être entrées sous la forme de formules matricielles (formule matricielle : formule qui effectue plusieurs calculs sur un ou plusieurs ensembles de valeurs et qui renvoie un ou plusieurs résultats. Les formules matricielles sont placées entre accolades { } et sont entrées en appuyant sur Ctrl+Maj+Entrée.). Après avoir copié l'exemple dans une feuille de calcul vide, sélectionnez la cellule de formule. Appuyez sur F2 et sur CTRL+MAJ+ENTRÉE. Si la formule n'est pas entrée sous la forme d'une formule matricielle, l'erreur #VALEUR ! est renvoyée.

Pour plus d'informations, consultez les fonctions SOMME et SI.

AfficherPour additionner des nombres en fonction de critères stockés dans une plage distincte

Vous pouvez utiliser la fonction BDSOMME pour effectuer cette tâche, comme indiqué dans l'exemple ci-dessous.

Exemple

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Région Vendeur Style Ventes
Sud Beaune Boissons 3571
Ouest Bartoli Produits laitiers 3338
Est Schwartz Boissons 5122
Nord Schwartz Produits laitiers 6239
Sud Duprez Produit 8677
Sud Bartoli Viandes 450
Sud Bartoli Viandes 7673
Est Schwartz Produit 664
Nord Bartoli Produit 1500
Sud Duprez Viandes 6596
Région Vendeur Style Ventes
Sud Viandes
Produit
Formule Description (résultat)
=BDSOMME(A1:D11; "Ventes"; A12:D13) Somme des ventes de viandes dans la région Sud (14719)
=BDSOMME(A1:D11; "Ventes"; A12:D14) Somme des ventes de viandes et de produits dans la région Sud (25560)

La fonction BDSOMME utilise les arguments suivants.

Formule avec la fonction BDSOMME

Légende 1   Plage à évaluer : la liste à partir de laquelle vous souhaitez additionner.

Légende 2   Champ : l'étiquette de la colonne à additionner.

Légende 3   Critères : représente la plage de cellules qui contient les conditions.

Pour plus d'informations, consultez la fonction BDSOMME.

AfficherPour additionner des nombres en fonction de plusieurs conditions à l'aide de l'Assistant Somme conditionnelle

Si vous souhaitez synthétiser les valeurs d'une liste (liste : ensemble de lignes contenant des données similaires ou une série de lignes que vous définissez de sorte qu’elles fonctionnent comme une feuille de données à l’aide de la commande Créer une liste.) en fonction de conditions spécifiques, vous pouvez utiliser l'Assistant Somme conditionnelle. Par exemple, si votre liste contient des résultats de ventes pour plusieurs vendeurs, la macro complémentaire (macro complémentaire : programme complémentaire qui ajoute des commandes personnalisées ou des fonctions personnalisées à Microsoft Office.) Assistant Somme conditionnelle vous aide à créer une formule qui calcule le total des ventes par vendeur.

  1. Cliquez sur une cellule de la liste.
  2. Dans le menu Outils, pointez sur Assistant, puis cliquez sur Somme conditionnelle.

Si la commande Somme conditionnelle ne s'affiche pas dans le sous-menu Assistant du menu Outils, vous devez charger la macro complémentaire Assistant Somme conditionnelle.

AfficherProcédure

  1. Dans le menu Outils, cliquez sur Macros complémentaires.
  2. Si la macro complémentaire (macro complémentaire : programme complémentaire qui ajoute des commandes personnalisées ou des fonctions personnalisées à Microsoft Office.) que vous souhaitez utiliser ne s'affiche pas dans la zone Macros complémentaires disponibles, cliquez sur Parcourir, puis recherchez-la.
  3. Dans la zone Macros complémentaires disponibles, activez la case à cocher située à côté de la macro complémentaire que vous voulez charger, puis cliquez sur OK.
  4. Si nécessaire, suivez les instructions du programme d'installation.
  1. Suivez les instructions de l'Assistant.

 Remarque    Les formules créées par l'Assistant Somme conditionnelle sont des formules matricielles (formule matricielle : formule qui effectue plusieurs calculs sur un ou plusieurs ensembles de valeurs et qui renvoie un ou plusieurs résultats. Les formules matricielles sont placées entre accolades { } et sont entrées en appuyant sur Ctrl+Maj+Entrée.). Après les avoir modifiées, vous devez appuyer sur les touches CTRL+MAJ+ENTRÉE pour les verrouiller.

 
 
S'applique à :
Excel 2003