Réussir des graphiques complexes avec Excel : pyramide des âges et diagramme ombrothermique

Madame Trouvetout

Excel est l’outil parfait pour agrémenter un rapport ou un dossier de magnifiques graphiques. Mais certains graphiques un peu spécifiques sont loin d’être simple à réaliser ! Pour réussir une pyramide des âges ou un diagramme ombrothermique, suivez le guide !

S’applique à
Microsoft Office Excel 2007

Consulter tous les articles de Madame Trouvetout


Cette chronique constitue le quatrième article d’une série de cinq. Dans le premier article, je vous ai montré comment tirer le meilleur parti de la fonction de création de graphiques d’Excel. Dans le deuxième article, je vous ai montré comment représenter les trois grandes catégories de données, en fonction de ce que vous vouliez montrer. Dans le troisième article, nous sommes passés au niveau supérieur en étudiant les comparaisons et agrégations de données. Aujourd’hui, nous passons en revue quelques graphiques particuliers qu’il peut être intéressant de savoir construire avec Excel : la pyramide des âges et le diagramme ombrothermique. Dans la prochaine chronique, nous terminerons cette série par quelques trucs et astuces utiles pour bien maîtriser les graphiques dans Excel !

Attachez vos ceintures, c’est parti !!

Réaliser une pyramide des âges

Il est assez fréquent de devoir réaliser une pyramide des âges. Il peut d’agir de celle d’un pays ou d’une région, pour mieux visualiser la manière dont les différentes générations sont représentées au sein d’un pays donné. Il peut aussi s’agir de celle d’un établissement ou d’une entreprise.

Une pyramide des âges a un style imposé. Un tel graphique se présente sous la forme suivante :

La population féminine est figurée à droite, la population masculine à gauche, en miroir. Il va donc nous falloir trouver le moyen de représenter l’une des deux séries comme « en miroir » de l’autre !

Collecter et traiter les données

Pour réaliser une pyramide des âges, il faut disposer, pour une population donnée, du nombre d’hommes et de femmes pour chaque année de naissance. Pour la France, ces données sont faciles à trouver sur le portail de l’Insee.

Voici un aperçu du tableau de données qu’il est possible de créer à partir des sources de l’Insee (données au 1er janvier 2009, pour la France entière) :

Construire le graphique

Avec ces chiffres, il est maintenant possible de construire la pyramide des âges.

  1. Sélectionner les données pertinentes (l’âge, le nombre d’hommes, le nombre de femmes)
  2. Cliquer sur l’onglet Insertion et choisir Barres 2D dans le menu Barres du groupe Graphique

  1. Un aperçu du graphique apparaît. Il est déjà (automatiquement !) assez proche de ce que l’on peut souhaiter et il ne reste qu’à l’améliorer pour lui donner toutes les caractéristiques d’une véritable pyramide des âges :

  1. Dans le groupe Emplacement de l’onglet Création du menu contextuel Outils de graphique, choisir de déplacer le graphique vers une feuille dédiée :

  1. Dans le groupe Sélection active de l’onglet Disposition du menu contextuel Outils de graphique, choisir la Série « hommes » dans le menu déroulant, puis cliquer sur le bouton Mise en forme de la sélection :

  1. Dans la boîte de dialogue qui s’ouvre alors, choisir :
    1. Chevauchement sur le curseur Superposition des séries, dans le but de superposer les deux séries ;
    2. Pas d’intervalle sur le curseur Largueur de l’intervalle, afin d’établir la continuité de l’histogramme ;
    3. Axe secondaire, afin de créer un second axe pour la seconde série de données.

  1. La représentation ainsi obtenue est intéressante, puisqu’elle superpose exactement les populations masculines et féminines du même âge, permettant de visualiser très facilement les générations pour lesquelles les femmes sont plus nombreuses et inversement. Pour autant, pour dessiner une pyramide des âges plus « classique », il va falloir faire passer la série représentant la population masculine à gauche du graphique !
    1. Sélectionner l’Axe Secondaire Horizontal (Valeur) et cliquer sur Mise en forme de la sélection. Dans la boîte de dialogue qui s’ouvre, régler les valeurs de l’axe de la manière suivante :

où « 500 000 » représente le nombre de personne maximal par classe d’âge (cette valeur dépendra donc des populations traitées). Dans la même fenêtre, choisir d’afficher les Valeurs en ordre inverse :

  1. Procéder de même pour l’Axe principal (Valeur), mais cette fois sans cocher la case Valeurs en ordre inverse :

  1. Une fois ces différents ajustements réalisés, la pyramide est quasiment prête. Il ne reste plus qu’à masquer les échelles négatives, et à modifier les étiquettes de titres (titre du graphique et des axes), ainsi que l’échelle de l’axe vertical. Pour modifier l’échelle de l’axe vertical, il suffit de :
    1. Sélectionner l’axe vertical et cliquer sur la fonction Mise en forme de l’axe dans le menu contextuel (ou bien sélectionner Axe Vertical (Catégorie) dans le menu déroulant du groupe Sélection active, puis cliquer sur Mise en forme de la sélection.
    2. Choisir un nouvel intervalle entre les graduations (par exemple : 5, pour une graduation tous les 5 ans)

  1. La pyramide est prête. Il ne reste plus qu’à l’enregistrer en tant que modèle pour pouvoir la réutiliser à loisir !

Réaliser un diagramme ombrothermique

Un diagramme ombrothermique est un graphique climatique qui représente les variations mensuelles, sur une année, des températures et des précipitations. Il est principalement adapté aux climats relativement tempérés et donc aux latitudes moyennes.

Un diagramme ombrothermique présente la silhouette suivante :

Collecter les données

Pour construire un diagramme ombrothermique, il faut disposer des températures moyennes mensuelles (minimales et maximales) et des précipitations moyennes mensuelles pour un lieu données.

Voici celles de Montpellier (source : MSN Météo)

Construire le graphique

Une fois les données entrées sous forme de tableau, il est très simple de construire le graphique de base : un graphique en courbe avec trois séries de données.

  1. Sélectionner les données à représenter
  2. Dans l’onglet Insertion, groupe Graphiques, menu Ligne, choisir le modèle de graphique Courbe (le premier) :

  1. L’aperçu du graphique apparaît aussitôt :

  1. Dans l’onglet Création du menu contextuel Outils de graphique qui s’affiche alors, choisir Déplacer le graphique :

  1. Déplacer la légende en utilisant le menu Légende (onglet Disposition, groupe Étiquettes), afin de la placer en dessous du graphique.
  2. Il faut ensuite transformer la représentation graphique des précipitations, qui doit se présenter sous la forme d’un histogramme et non d’une courbe.
    1. Sélectionner la Série « précipitations moyennes » en utilisant le menu déroulant du groupe Sélection active (onglet Disposition) : la courbe représentant les températures moyennes devient active :

  1. Cliquer alors sur Mise en forme de la sélection (dans le même groupe) : une boîte de dialogue s’ouvre alors :

  1. Grâce à cette boîte de dialogue, il est possible de créer un Axe secondaire pour la série « précipitations moyennes » en choisissant l’option correspondante dans l’onglet Options des séries

  1. Ajuster ensuite l’échelle des températures (à gauche) et celle des précipitations (à droite) en respectant les conditions suivantes :
    • Les deux échelles doivent être suffisamment larges pour permettre d’afficher toutes les données à traiter (surtout s’il y a plusieurs lieu à représenter) ;
    • Les deux échelles doivent être telles qu’il soit possible de les rendre fixes et donc de permettre les comparaisons entre diagrammes ombrothermiques ;
    • L’échelle des précipitations doit correspondre au double de celle des températures, ce qui signifie qu’à 5°C doit correspondre la graduation 10 mm – c’est à cette condition seulement que les conditions de sécheresse seront directement perceptible sur les schémas ;
    • Ici, on a choisi une échelle 0>100 mm et 0>50°.
  2. Modifier enfin l’aspect de la série « précipitations moyennes » :
    • Garder la série (et seulement cette série !) sélectionnée ;
    • Revenir sur l’onglet Création (toujours dans le menu Outils de graphique) et cliquer sur Modifier le type de graphique (en fait, dans ce cas, nous n’allons modifier que le type de représentation de la série sélectionnée, et non pas celle de tout le graphique).
    • Dans le menu qui s’affiche, choisir Histogramme groupé :

  • Sélectionner à nouveau la Série « précipitations moyennes » en utilisant le menu déroulant du groupe Sélection active (onglet Disposition), puis en cliquant sur Mise en forme de la sélection :

  • Grâce à la boîte de dialogue qui s’ouvre alors, choisir Pas d’intervalle sur le curseur Largeur de l’intervalle ;

  • Il reste à modifier certains aspects graphiques du diagramme : améliorer l’aspect des différents titres et de la légende, modifier la couleur des séries (en particulier, mettre les barres des précipitations en bleu grâce à l’onglet Remplissage de la boîte de dialogue Mise en forme des séries de données) :

  • Votre diagramme ombrothermique est prêt !

Voilà, c’est terminé pour les graphiques un peu complexes. Y en a-t-il certains que vous aimeriez savoir construire avec Excel ? Parfois, il suffit de connaître une petite astuce pour y parvenir !

Dans ma prochaine chronique, je passerai en revue quelques « trucs » pour vous aider à parfaitement maîtriser les fonctions de graphiques dans Excel. D’ici là, n’hésitez pas à tester toutes ces fonctions pour mieux vous les approprier…

« Ce dessin m’a pris cinq minutes, mais j’ai mis soixante ans pour y arriver. » (Pierre-Auguste Renoir)


Consulter tous les articles de Madame Trouvetout