Utiliser la vérification des erreurs pour corriger les erreurs courantes dans les formules

À l’instar d’un vérificateur d’orthographe qui vérifie les erreurs dans les données que vous entrez dans les cellules, vous pouvez implémenter certaines règles pour rechercher les erreurs dans les formules. Ces règles ne garantissent pas que votre feuille de calcul (feuille de calcul : document principal utilisé dans Microsoft Excel pour traiter et stocker des données ; également appelé tableur. Une feuille de calcul est composée de cellules organisées dans des lignes et des colonnes et fait toujours partie d’un classeur.) sera exempte d’erreurs, mais elles sont efficaces pour rechercher les erreurs courantes. Vous pouvez activer ou désactiver n’importe laquelle de ces règles individuellement.

Les erreurs peuvent être marquées et corrigées de deux façons : une erreur à la fois (de la même manière qu’avec un vérificateur d’orthographe) ou immédiatement quand elles se produisent sur la feuille de calcul lorsque vous travaillez. Dans les deux cas, un triangle s’affiche dans le coin supérieur gauche de la cellule lorsqu’une erreur est trouvée.


Cellule présentant un problème de formule

Cellule présentant une erreur de formule

Les erreurs qui ne peuvent pas renvoyer de résultat (tel que la division d’un nombre par zéro) requièrent votre attention et affichent une valeur d’erreur dans la cellule (en l’occurrence, #DIV/0!). D’autres erreurs peuvent être moins graves, telles qu’une formule semblant incohérente avec les formules adjacentes. La formule renvoie un résultat correct, mais l’erreur vous conseille d’examiner la formule.


Vous pouvez résoudre une erreur en utilisant les options qui s’affichent, ou vous pouvez l’ignorer en cliquant sur Ignorer l’erreur. Si vous ignorez une erreur dans une cellule particulière, l’erreur dans cette cellule ne s’affiche plus dans les contrôles d’erreur ultérieurs. Cependant, vous pouvez rétablir toutes les erreurs précédemment ignorées pour qu’elles s’affichent de nouveau.

Que voulez-vous faire ?


Activer ou désactiver les règles de vérification des erreurs

  1. Cliquez sur l’onglet Fichier, sur Options puis sur la catégorie Formules.
  2. Sous Règles de vérification des erreurs, activez ou désactivez les cases à cocher de l’une des règles suivantes :

Pour plus d’informations sur la façon de résoudre ces erreurs, voir les liens dans la liste Voir aussi.

 Remarque   Si vous entrez directement une valeur d’erreur dans une cellule, celle-ci est marquée en tant qu’erreur.

  • Formule de colonne calculée incohérente dans des tableaux    Une colonne calculée peut inclure des formules différentes de la formule de colonne qui crée une exception. Des exceptions de colonne calculée sont créées lorsque vous :
  • tapez des données autres qu’une formule dans une cellule de colonne calculée ;
  • tapez une formule dans une cellule d’une colonne calculée, puis cliquez sur AnnulerImage du bouton dans la barre d’outils Accès rapide.
  • tapez une nouvelle formule dans une colonne calculée qui contient déjà au moins une exception ;
  • copiez des données dans la colonne calculée qui ne correspond pas à la formule de colonne calculée ;

 Remarque   Si les données copiées contiennent une formule, celle-ci remplace le contenu de la colonne calculée.

  • déplacez ou supprimez une cellule dans une autre zone de la feuille de calcul, qui est référencée par l’une des lignes d’une colonne calculée.
  • Cellules contenant des années à deux chiffres    La cellule contient une date qui pourrait être interprétée comme appartenant à un siècle incorrect lorsqu’elle est utilisée dans les formules. Par exemple, la date dans la formule =ANNEE("1/1/31") peut être 1931 ou 2031. Utilisez cette règle pour vérifier les dates ambiguës.
  • Nombres au format texte ou précédés d’une apostrophe    La cellule contient des nombres stockés sous forme de texte. Cela se produit en règle générale lorsque des données sont importées à partir d’autres sources. Les nombres qui sont stockés sous forme de texte peuvent entraîner des comportements de tri inattendus, et ils ne peuvent pas être calculés. Par conséquent, il est conseillé de convertir leurs cellules au format numérique.
  • Formules incohérentes avec d’autres formules de la zone    La formule ne correspond pas à la structure des autres formules situées à proximité. Dans de nombreux cas, les formules qui sont adjacentes à d’autres formules diffèrent uniquement par les références utilisées.Dans l’exemple suivant de quatre formules adjacentes, Excel affiche une erreur à côté de la formule =SOMME(A10:F10) parce que les formules adjacentes sont incrémentées d’une ligne, alors que dans la formule =SOMME(A10:F10) les formules sont incrémentées de 8 lignes — Excel attend la formule =SOMME(A3:F3).
A
Formules
=SOMME(A1:F1)
=SOMME(A2:F2)
=SOMME(A10:F10)
=SOMME(A4:F4)
  • Si les références qui sont utilisées dans une formule ne sont pas cohérentes avec celles des formules adjacentes, Excel affiche une erreur.
  • Formules omettant des cellules dans une zone    Une formule peut ne pas inclure de références automatiques aux données que vous insérez entre la plage originale de données et la cellule qui contient la formule. Cette règle compare la référence dans une formule à la plage effective de cellules qui est adjacente à la cellule qui contient la formule. Si les cellules adjacentes contiennent des valeurs supplémentaires et ne sont pas vides, Excel affiche une erreur à côté de la formule.

Par exemple, Excel insère une erreur en regard de la formule =SOMME(A2:A4) lorsque cette règle est appliquée, parce que les cellules A5, A6 et A7 sont adjacentes aux cellules qui sont référencées dans la formule (A2:A4) et également à la cellule qui contient la formule (A8), et ces trois cellules (A5, A6 et A7) contiennent des données qui auraient dû être référencées dans la formule.

A
Facture
15 000
9 000
8 000
20 000
5 000
22 500
=SOMME(A2:A4)
  • Cellules déverrouillées contenant des formules    La formule n’est pas verrouillée, et sa protection n’est donc pas assurée. Par défaut, toutes les cellules dans une feuille de calcul sont verrouillées par mesure de protection. Cela signifie donc que la cellule a été définie par un utilisateur pour être non protégée. Lorsqu’une formule est protégée, elle ne peut pas être modifiée, à moins d’annuler d’abord sa protection. Assurez-vous que vous ne voulez pas que la cellule soit protégée. La protection de cellules contenant des formules empêche que ces dernières soient modifiées et peut éviter des erreurs ultérieures.
  • Formules faisant référence à des cellules vides    La formule contient une référence à une cellule vide. Cela peut provoquer des résultats inattendus, comme illustré dans l’exemple suivant.

Supposons que vous vouliez calculer la moyenne des nombres dans la colonne de cellules suivante. Si la troisième cellule est vide, parce qu’elle n’est pas considérée comme étant une valeur, elle n’est pas incluse dans le calcul et le résultat est 22,75. Si la troisième cellule contient 0 (0 est considéré comme étant une valeur), cette cellule est incluse dans le calcul et le résultat est 18,2.

A
Données
24
12
 
45
10
=MOYENNE(A2:A6)
  • Données incorrectes entrées dans un tableau    Un tableau comporte une erreur de validation. Vérifiez le paramètre de validation appliqué à la cellule en cliquant sur Validation des données dans le groupe Outils de données sous l’onglet Données.

Haut de la page Haut de la page

Corriger une par une les erreurs dans les formules

Si lors d’une vérification précédente des erreurs dans la feuille de calcul, des erreurs ont été ignorées, elles n’apparaîtront pas tant que les erreurs ignorées n’auront pas été rétablies.

  1. Sélectionnez la feuille de calcul pour laquelle vous souhaitez vérifier les erreurs.
  2. Si la feuille de calcul est calculée manuellement, appuyez sur F9 pour la recalculer maintenant.
  3. Sous l’onglet Formules, dans le groupe Audit de formules, cliquez sur Vérification des erreurs.

Groupe Audit de formules sous l’onglet Formules

La boîte de dialogue Vérification des erreurs s’affiche lorsque des erreurs sont trouvées.

  1. Si vous aviez ignoré des erreurs, vous pouvez les revérifier en procédant comme suit (vous pouvez laisser la boîte de dialogue Vérification des erreurs ouverte) :
    1. Sous l’onglet Fichier, cliquez sur Options, puis sur Formules.
    2. Dans la section Vérification des erreurs, cliquez sur Rétablir les erreurs ignorées, puis cliquez sur OK.
    3. Dans la boîte de dialogue Vérification des erreurs, cliquez sur Reprendre.

 Remarque   La réinitialisation des erreurs ignorées réinitialise toutes les erreurs dans toutes les feuilles de calcul du classeur actif.

  1. Positionnez la boîte de dialogue Vérification des erreurs juste au-dessous de la barre de formule (barre de formule : barre située en haut de la fenêtre Microsoft Excel qui permet d’entrer ou de modifier des valeurs ou des formules dans des cellules ou des graphiques. Affiche la valeur constante ou la formule enregistrée dans la cellule active.).

Barre de formule

  1. Cliquez sur l’un des boutons d’action à droite dans la boîte de dialogue. Les actions disponibles sont différentes pour chaque type d’erreur.

 Remarque   Si vous cliquez sur Ignorer l’erreur, l’erreur est marquée comme devant être ignorée pour les vérifications suivantes.

  1. Cliquez sur Suivant, puis poursuivez jusqu’à ce que la vérification des erreurs soit terminée.

Haut de la page Haut de la page

Marquer les erreurs dans les formules sur la feuille de calcul et les corriger sur celle-ci

  1. Cliquez sur l’onglet Fichier, sur Options puis sur la catégorie Formules.
  2. Sous Vérification des erreurs, vérifiez que la case à cocher Activer la vérification des erreurs d’arrière-plan est activée.
  3. Pour changer la couleur du triangle qui indique où une erreur s’est produite, dans la zone Indiquer les erreurs à l’aide de cette couleur, sélectionnez la couleur désirée.
  4. Sélectionnez une cellule comportant un triangle dans son coin supérieur gauche.
  5. À côté de la cellule, cliquez sur le bouton Vérification des erreursImage du bouton qui s’affiche, puis cliquez sur l’option souhaitée. Les commandes disponibles sont différentes pour chaque type d’erreur, et la première entrée décrit l’erreur.

Si vous cliquez sur Ignorer l’erreur, l’erreur est marquée comme devant être ignorée pour les vérifications suivantes.

  1. Répétez les deux étapes précédentes.

Haut de la page Haut de la page

 
 
S'applique à :
Excel 2010