Corriger une erreur #REF!

Cette erreur survient lorsqu’une référence de cellule (référence de cellule : ensemble de coordonnées correspondant à l’emplacement d’une cellule dans une feuille de calcul. Par exemple, la référence de la cellule qui se trouve à l’intersection de la colonne B et de la ligne 3 est B3.) n’est pas valide.

Symptôme

Microsoft Excel affiche #REF! dans une ou plusieurs cellules d’une feuille de calcul.

Causes

  • Des cellules auxquelles d’autres formules faisaient référence ont été supprimées ou des cellules ont été collées au-dessus d’autres cellules référencées par d’autres formules.
  • Il existe peut-être une liaison OLE (Object Linking and Embedding) vers un programme qui n’est pas en cours d’exécution.

 Remarque   OLE est une technologie qui permet de partager des informations entre des programmes.

  • Il existe peut-être une liaison vers une rubrique de l’échange dynamique de données (DDE) (un groupe ou une catégorie de données de l’application serveur d’une application client/serveur), telle que «  système », qui n’est pas disponible.

 Remarque   DDE est un protocole établi pour l’échange de données entre des programmes Microsoft Windows.

  • Il existe peut-être une macro dans le classeur qui entre une fonction dans la feuille de calcul qui renvoie une erreur #REF!.

Exemple

Copiez les données de la feuille de calcul exemple dans une feuille de calcul vide, puis supprimez la colonne D (la colonne complète). Les formules, qui se trouvaient à l’origine dans la colonne E, sont décalées vers la colonne D et affichent toutes une erreur #REF!. Si vous sélectionnez la cellule D2, Excel affiche la formule =SOMME(B2,C2,#REF!) dans la barre de formule.

AfficherComment copier un exemple ?

  1. Sélectionnez l’exemple dans cet article. Si vous copiez l’exemple dans Excel Web App, copiez et collez une cellule à la fois.

 Important   Ne sélectionnez pas les en-têtes des lignes ou des colonnes.

Sélection d’un exemple de l’aide

Sélection d’un exemple de l’aide
  1. Appuyez sur Ctrl + C.
  2. Créez un classeur ou une feuille de calcul vide.
  3. Dans la feuille de calcul, sélectionnez la cellule A1, puis appuyez sur Ctrl + V. Si vous travaillez dans Excel Web App, répétez la copie et le collage pour chaque cellule dans l’exemple.

 Important   Pour que l’exemple fonctionne correctement, vous devez le coller dans la cellule A1 de la feuille de calcul.

  1. Pour passer de l’affichage des résultats à celui des formules qui ont permis d’obtenir les résultats affichés, appuyez sur Ctrl+` (accent grave) ou, sous l’onglet Formules, dans le groupe Audit des formules, cliquez sur le bouton Afficher les formules.

Après avoir copié l’exemple dans une feuille de calcul vide, vous pouvez l’adapter en fonction de vos besoins.


 
1
2
3
4
5
A B C D E
Région Ventes 2006 Ventes 2007 Ventes 2008 Formule
Est 22700 24200 11000 =SOMME(B2,C2,D2)
Nord 17400 17800 10200 =SOMME(B3,C3,D3)
Sud 18600 18500 9600 =SOMME(B4,C4,D4)
Ouest 21800 23300 10300 =SOMME(B5,C5,D5)

Une erreur s’affiche car les formules de la colonne E font référence à la colonne D et que le formule n’est plus valide du fait de la suppression de la colonne D. Au lieu de réparer les formules pour qu’elles fassent référence à une autre cellule (ce n’est d’ailleurs pas nécessairement ce que vous voulez),  Excel affiche cette erreur pour vous inviter à corriger vous-même les formules et éviter ainsi des résultats inattendus. Dans ce cas, réparez les formules en supprimant « #REF! » de la formule dans D2, puis en faisant glisser la formule vers les cellules ci-dessous.

Résolution

  • Si la vérification des erreurs est activée dans Excel, vous pouvez également cliquer sur le bouton qui s’affiche en regard de la cellule qui contient l’erreur Image du bouton, puis cliquer sur Afficher les étapes du calcul, le cas échéant, et ensuite sélectionner la résolution appropriée pour vos données.

 Conseil   Passez en revue les résolutions suivantes pour déterminer quelle option choisir.

 
 
S'applique à :
Excel 2010