Convertir des heures

AfficherPour convertir des unités de temps

Utilisez la fonction CONVERT pour exécuter cette tâche.

Si cette fonction n'est pas disponible, installez et chargez la macro complémentaire Utilitaire d'analyse.

AfficherProcédure

  1. Dans le menu Outils, cliquez sur Macros complémentaires.
  2. Dans la liste Macros complémentaires disponibles, activez la case à cocher Utilitaire d'analyse, puis cliquez sur OK.
  3. Si nécessaire, suivez les instructions fournies par le programme d'installation.

Exemple de feuille de calcul

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.
 
1
2
A
Données
6
Formule Description (résultat)
=CONVERT(A2,"jour","heure") Convertit 6 jours en heures (144)
=CONVERT(A2,"heure","minute") Convertit 6 heures en minutes (360)
=CONVERT(A2,"année", "jour") Convertit 6 années en jours (2191,5)

 Remarque   Pour des conversions en utilisant une année, une année est considérée comme 365,25 jours.

Détails de la fonction

CONVERT

AfficherPour convertir des heures à partir du format horaire standard (heures : minutes : secondes) en nombre décimal

Utilisez la fonction ENT pour exécuter cette tâche.

Exemple de feuille de calcul

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.
 
1
2
3
A
Heure
10:35
12:15
Formule Description (résultat)
=(A2-ENT(A2))*24 Nombre d'heures depuis 00:00 (10,583333)
=(A3-ENT(A3))*24 Nombre d'heures depuis 00:00 (12,25)

Détails de la fonction

ENT

AfficherPour convertir des heures de nombre décimal en format horaire standard (heures : minutes : secondes)

Utilisez l'opérateur de division (/) et la fonction TEXTE pour exécuter cette tâche.

Exemple de feuille de calcul

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

AfficherProcédure

  1. Créez un classeur ou une feuille de calcul vide.
  2. Sélectionnez l'exemple de la rubrique d'aide. Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

Sélection d'un exemple de l'aide

Sélection d'un exemple de l'aide
  1. Appuyez sur CTRL+C.
  2. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.
  3. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (apostrophe), ou dans le menu Outils, pointez sur Audit des formules, puis cliquez sur Mode d'audit des formules.
 
1
2
3
A
Heures
10,5833
12,25
Formule Description (résultat)
=TEXTE(A2/24, "h:mm") Heures depuis 00:00 (10:35)
=TEXTE(A3/24, "h:mm") Heures depuis 00:00 (12:15)

 Remarque   Vous pouvez également appliquer le format numérique horaire sans utiliser la fonction TEXTE pour indiquer le format. Pour afficher le nombre sous forme d'heure, sélectionnez la cellule, puis cliquez sur Cellule dans le menu Format. Cliquez sur l'onglet Nombre, puis sur Heure dans la zone Catégorie. Cependant, si vous utilisez un format appliqué à la fois avec la fonction TEXTE et le format numérique, la fonction TEXTE est prioritaire.

Détails de la fonction

TEXTE

 
 
S'applique à :
Excel 2003