Kaavan luominen käyttämällä funktiota

 Tärkeää   Kaavojen ja joidenkin Excel-laskentataulukkofunktioiden lasketut tulokset saattavat olla hieman erilaisia tietokoneissa, joissa käytetään x86- tai x86-64-arkkitehtuuria, sekä Windows RT PC:ssä, jossa käytetään ARM-arkkitehtuuria. Lisätietoa eroista.

Voit luoda kaavan (kaava: Joukko solussa olevia arvoja, soluviittauksia, nimiä, funktioita tai operaattoreita, jotka yhdessä tuottavat uuden arvon. Kaava alkaa aina yhtäläisyysmerkillä (=).), jos haluat laskea laskentataulukon arvoja käyttämällä funktiota (funktio: Valmiiksi kirjoitettu kaava, joka ottaa käsittelyyn yhden tai useita arvoja, suorittaa laskutoimituksen ja palauttaa yhden tai useita arvoja. Funktioita käytetään laskentataulukon kaavojen yksinkertaistamiseen ja lyhentämiseen, erityisesti jos ne suorittavat pitkiä tai monimutkaisia laskutoimituksia.). Esimerkiksi kaavoissa =SUMMA(A1:A2) ja SUMMA(A1;A2) lasketaan solujen A1 ja A2 arvot yhteen SUMMA-funktiolla. Kaavat alkavat aina yhtäläisyysmerkillä (=).

  1. Valitse solu, johon haluat kirjoittaa kaavan.
  2. Voit aloittaa kaavan funktiolla napsauttamalla kaavarivillä Lisää funktioPainikkeen kuva -painiketta Painikkeen kuva.

Excel lisää kaavaan yhtäläisyysmerkin (=) puolestasi.

  1. Valitse Tai valitse luokka -ruudusta Kaikki.

Jos tunnet funktioluokat, voit valita myös luokan.

Jos et ole varma käytettävästä funktiosta, voit kirjoittaa toimintoa vastaavan kysymyksen Etsi funktio -ruutuun (esimerkiksi "laske luvut yhteen" palauttaa SUMMA-funktion ).

 Vihje    Käytettävissä olevista funktioista on luettelo artikkeleissa Excelin funktiot (aakkosjärjestyksessä) ja Excelin funktiot (luokittain).

  1. Valitse haluamasi funktio Valitse funktio -ruutuun ja valitse sitten OK.
  2. Kirjoita haluamasi arvot, tekstimerkkijonot tai soluviittaukset valitsemasi funktion perusteella näytettäviin argumenttiruutuihin.

Soluviittausten kirjoittamisen sijaan voit myös valita solut, joihin haluat viitata. Pienennä valintaikkuna napsauttamalla Painikkeen kuva -painiketta, valitse solut, joihin haluat viitata, ja laajenna valintaikkuna uudelleen napsauttamalla sitten Painikkeen kuva -painiketta.

 Vihje    Jos haluat lisätietoja funktiosta ja sen argumenteista, valitse Tämän funktion ohje.

  1. Kun olet kirjoittanut kaavan argumentit, valitse OK.

 Vihje    Jos käytät funktioita usein, voit lisätä kaavoja suoraan laskentataulukkoon. Kun olet kirjoittanut yhtäläisyysmerkin (=) ja funktion nimen, saat tietoja kaavan syntaksista ja funktion argumenteista painamalla F1-näppäintä.

Esimerkkejä

Kopioi taulukko Excelin tyhjän laskentataulukon soluun A1, jos haluat käyttää näiden esimerkkien funktioita käyttäviä kaavoja.

Tiedot
5 4
2 6
3 8
7 1
Kaava Kuvaus Tulos
'=SUMMA(A:A) Lisää kaikki numerot sarakkeesta A =SUMMA(A:A)
'=KESKIARVO(A1:B4) Laskee solualueella A1:B4 olevien numeroiden keskiarvon =KESKIARVO(A1:B4)

Sivun alkuun Sivun alkuun

 
 
Käyttö:
Excel 2013