Mostrar u ocultar los valores cero

Puede tener una preferencia personal para mostrar valores cero en una celda o puede utilizar una hoja de cálculo que se adhiera a un conjunto de estándares de formato que requiere que oculte los valores cero. Hay varias maneras de mostrar u ocultar valores cero.

¿Qué desea hacer?


Mostrar u ocultar todos los valores cero en una hoja de cálculo

  1. Haga clic en el botón de Microsoft Office Imagen del botón, haga clic en Opciones de Excel y, a continuación, haga clic en la categoría Avanzadas.
  1. En Mostrar opciones para esta hoja, seleccione una hoja de cálculo y, a continuación, siga uno de los procedimientos siguientes:
    • Para mostrar los valores cero (0) en las celdas, active la casilla de verificación Mostrar un cero en celdas que tienen un valor cero.
    • Para mostrar valores cero como celdas en blanco, desactive la casilla de verificación Mostrar un cero en celdas que tienen un valor cero.

Volver al principio Volver al principio

Utilizar un formato numérico para ocultar los valores cero en las celdas seleccionadas

Siga este procedimiento para ocultar los valores cero en las celdas seleccionadas. Si cambia el valor de una de estas celdas a un valor que no es cero, el formato del valor será similar al formato de número general.

  1. Seleccione las celdas que contengan los valores cero (0) que se desee ocultar.
  2. En el grupo Celdas de la ficha Inicio, haga clic en Formato y luego en Formato de celdas.
  1. En la lista Categoría, haga clic en Personalizada.
  2. En el cuadro Tipo, escriba 0;-0;;@.

 Notas 

  • Los valores ocultos sólo aparecen en la barra de fórmulas Barra de fórmulas o en la celda si realiza cambios dentro de la celda, y no se imprimen.
  • En el grupo Celdas de la ficha Inicio, haga clic en Formato y luego en Formato de celdas.
  • Para que aparezcan de nuevo los valores ocultos, seleccione las celdas y, a continuación, en la ficha Inicio, en el grupo Celdas, elija Formato y haga clic en Formato de celdas. En la lista Categoría, haga clic en General para aplicar el formato de número predeterminado. Para que aparezca de nuevo una fecha o una hora, seleccione el formato de fecha u hora correspondiente en la ficha Número.

Volver al principio Volver al principio

Utilizar un formato condicional para ocultar los valores cero que devuelve una fórmula

  1. Seleccione la celda que contenga el valor cero (0).
  2. En el grupo Estilos de la ficha Inicio, haga clic en la flecha situada junto a Formato condicional, elija Reglas de resaltado de celdas y, a continuación, haga clic en Igual a.
  1. En el cuadro de la izquierda, escriba 0.
  2. En el cuadro de la derecha, seleccione Formato personalizado.
  3. En el cuadro de diálogo Formato de celdas, haga clic en la ficha Fuente.
  4. En el cuadro Color, seleccione blanco.

Volver al principio Volver al principio

Utilizar una fórmula para mostrar los ceros como espacios en blanco o guiones

Para realizar esta tarea, utilice la función SI.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

  1. Seleccione el ejemplo de este artículo.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En Excel, cree una hoja de cálculo o un libro en blanco.
  3. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  1. Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 
1
2
3
4
5

6
7
A B
Datos
10
10
Fórmula Descripción (resultado)
=A2-A3 El segundo número se resta del primero (0)
=SI(A2-A3=0;"";A2-A3) Devuelve una celda en blanco si el valor es cero (celda en blanco)
=SI(A2-A3=0;"-";A2-A3 Devuelve un guión si el valor es cero (-)

Para obtener más información acerca de cómo usar esta función, vea el tema de la función SI.

Volver al principio Volver al principio

Ocultar los valores cero en un informe de tabla dinámica

  1. Haga clic en el informe de tabla dinámica.
  2. En el grupo Opciones de la tabla dinámica de la ficha Opciones, haga clic en la flecha situada junto a Opciones y, a continuación, en Opciones.
  1. Haga clic en la ficha Diseño y formato y siga uno o varios de los procedimientos siguientes:

Cambiar el modo en que se muestran los errores     Active la casilla de verificación Para valores erróneos, mostrar situada bajo Formato. En el cuadro, escriba el valor que desee mostrar en lugar de los errores. Para mostrar los errores como celdas en blanco, elimine los caracteres del cuadro.

Cambiar el modo en que se muestran las celdas vacías     Active la casilla de verificación Para celdas vacías, mostrar. En el cuadro, escriba el valor que desee mostrar en las celdas vacías. Para mostrar celdas en blanco, elimine los caracteres del cuadro. Para mostrar ceros, desactive la casilla de verificación.

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2007