Función CONTAR.SI

Este artículo describe la sintaxis de la fórmula y el uso de la función CONTAR.SI (función: fórmula ya escrita que toma un valor o valores, realiza una operación y devuelve un valor o valores. Utilice funciones para simplificar y acortar fórmulas en una hoja de cálculo, especialmente aquellas que llevan a cabo cálculos prolongados o complejos.) en Microsoft Office Excel.

Descripción

La función CONTAR.SI cuenta el número de celdas dentro de un rango que cumplen un solo criterio especificado por el usuario. Por ejemplo, puede contar todas las celdas que comienzan con cierta letra, o bien todas las celdas que contienen un número mayor o menor que un número especificado por el usuario. Por ejemplo, suponga que tiene una hoja de cálculo que contiene una lista de tareas en la columna A y el primer nombre de la persona asignada a cada tarea en la columna B. Puede usar la función CONTAR.SI para contar cuántas veces aparece el nombre de una persona en la columna B y, de esa forma, determinar cuántas tareas tiene asignadas. Por ejemplo:

=CONTAR.SI(B2:B25,"Nancy")

 Nota   Para contar celdas basándose en varios criterios, vea la función CONTAR.SI.CONJUNTO.

Sintaxis

COUNTIF(range, criteria)

La sintaxis de la función CONTAR.SI tiene los siguientes argumentos (argumento: valor que proporciona información a una acción, un evento, un método, una propiedad, una función o un procedimiento.):

  • rango    Obligatorio. Una o más celdas que se van a contar, incluidos números o nombres, matrices o referencias que contengan números. Los valores en blanco y los de texto no se tienen en cuenta.
  • criterios    Obligatorio. Número, expresión, referencia de celda o cadena de texto que determina las celdas que se van a contar. Por ejemplo, los criterios pueden expresarse como 32, ">32", B4, "manzanas" o "32".

 Notas 

  • En los criterios se puede utilizar los caracteres comodín  — signo de interrogación (?) y asterisco (*) —. El signo de interrogación corresponde a un solo carácter cualquiera y el asterisco equivale a cualquier secuencia de caracteres. Si desea buscar un signo de interrogación o un asterisco reales, escriba una tilde (~) delante del carácter que desea buscar.
  • Los criterios no distinguen entre mayúsculas y minúsculas; por ejemplo, la cadena "manzanas" y la cadena "MANZANAS" corresponden a las mismas celdas.

Ejemplo 1: fórmulas CONTAR.SI comunes

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

  • Seleccione el ejemplo de este artículo.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 
1
2
3
4
5
6

7

8

9


10

11



12
A B C
Datos Datos
manzanas 32
naranjas 54
melocotones 75
manzanas 86
Fórmula Descripción Resultado
=CONTAR.SI(A2:A5;"manzanas") Número de celdas con manzanas en las celdas A2 a A5. 2
=CONTAR.SI(A2:A5;A4) Número de celdas con melocotones en las celdas A2 a A5. 1
=CONTAR.SI(A2:A5;A3)+CONTAR.SI(A2:A5;A2) Número de celdas con naranjas y manzanas en las celdas A2 a A5. 3
=CONTAR.SI(B2:B5;">55") Número de celdas con un valor superior a 55 en las celdas B2 a B5. 2
=CONTAR.SI(B2:B5;"<>"&B4) Número de celdas con un valor no igual a 75 en las celdas B2 a B5. 3
=CONTAR.SI(B2:B5;">=32")-CONTAR.SI(B2:B5;">85") Número de celdas con un valor superior o igual a 32 e inferior o igual a 85 en las celdas B2 a A5. 3

Ejemplo 2: fórmulas CONTAR.SI que usan caracteres comodín y tratan con valores vacíos

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

  • Seleccione el ejemplo de este artículo.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 
1
2
3
4
5
6
7
8



9





10



11


12




13




14
A B C
Datos Datos
manzanas
   
naranjas No
melocotones No
   
manzanas
Fórmula Descripción Resultado
=CONTAR.SI(A2:A7;"*es") Número de celdas que acaban con las letras "es" en las celdas A2 a A7. 4
=CONTAR.SI(A2:A7;"?????es") Número de celdas que acaban con las letras "es" y tienen exactamente 7 letras en las celdas A2 a A7. 2
=CONTAR.SI(A2:A7;"*") Número de celdas que contienen cualquier texto en las celdas A2 a A7. 4
=CONTAR.SI(A2:A7;"<>"&"*") Número de celdas que no contienen texto en las celdas A2 a A7. 2
=CONTAR.SI(B2:B7;"No") / FILAS(B2:B7) Número promedio de votos negativos (incluidas las celdas vacías) de las celdas B2 a B7. 0,333333333
=CONTAR.SI(B2:B7;"Sí") / (FILAS(B2:B7) -CONTAR.SI(B2:B7; "<>"&"*")) El número medio de votos afirmativos (excluidas las celdas vacías) de las celdas B2 a B7. 0,5

 Nota    Para ver un número como porcentaje, seleccione la celda y, a continuación, en la ficha Hoja, en el grupo Número, haga clic en Porcentaje Imagen del botón.

 
 
Corresponde a:
Excel 2007