Formas de sumar valores en una hoja de cálculo

Contar frente a sumar

Sumar (agregar valores) es una parte integral del análisis de los datos, tanto si realiza subtotales de ventas en la región del noroeste como si realiza un total de los recibos semanales. Excel ofrece varias técnicas para sumar datos.

Para ayudarle a realizar la mejor elección, este artículo proporciona un amplio resumen de métodos, una información que le ayudará a decidir rápidamente qué técnica usar, así como vínculos a artículos en profundidad.

Sumar el contenido de las celdas no se debe confundir con contar el número de celdas. Para obtener más información sobre cómo contar el número de celdas, columnas o filas de datos, consulte función CONTAR.SI.

En este artículo


Suma y resta simples

Puede sumar y restar números usando una fórmula simple, haciendo clic en un botón o usando una función de la hoja de cálculo.

Agregar los valores de una celda usando una fórmula simple

Si solo necesita un resultado rápido, puede usar Excel como una minicalculadora. Haga esto usando el operador aritmético del signo más (+).

Fórmula Descripción Resultado
=5+10 Usa el operador + (signo más) para sumar dos o más valores. 15
=A2+B2 Suma los valores de dos o más celdas. En este caso, se asume que A2 = 5 y B2 = 10. 15
=A2+B2+20 Suma los valores de dos celdas a un número que escribe directamente en la fórmula. En este caso, se asume que A2 = 5 y B2 = 10. 35

Volver al principio Volver al principio

Restar los valores de una celda usando una fórmula simple

Haga esto usando el operador aritmético del signo menos (-). Por ejemplo, la fórmula =12-9 muestra un resultado de 3.

Para obtener más información sobre cómo usar operadores aritméticos en una fórmula, vea el artículo Usar Excel como calculadora.

Volver al principio Volver al principio

Agregar los valores de una columna o fila usando un botón

Puede usar Autosuma para sumar rápidamente un rango de números de una columna o fila. Haga clic en una fila vacía debajo de una columna de números o a la derecha de una fila de números y, a continuación, haga clic en Autosuma. Excel selecciona lo que determina que puede ser el rango de datos más probable. Haga clic en Autosuma de nuevo para aceptar el rango que seleccione Excel, o seleccione su propio rango y haga clic en Autosuma.

Uso de Autosuma para sumar rápidamente una fila de datos

Para obtener más información sobre cómo usar Autosuma, vea el artículo Usar Excel como calculadora .

Volver al principio Volver al principio

Agregar los valores de un rango usando una función

La función SUMA es útil si desea sumar o restar valores de distintos rangos o combinar valores numéricos con rangos de números. Use la función SUMA para sumar todos los argumentos (argumento: valores que utiliza una función para llevar a cabo operaciones o cálculos. El tipo de argumento que utiliza una función es específico de esa función. Los argumentos más comunes que se utilizan en las funciones son números, texto, referencias de celda y nombres.) que especifique en los paréntesis de apertura y cierre. Cada argumento puede ser un rango, una celda o un valor numérico positivo o negativo.

Para escribir una fórmula simple, escriba =SUMA en una celda, seguido de un paréntesis de apertura. A continuación, escriba uno o varios números, referencias a celdas o rangos de celdas, separados por comas. Después, escriba un paréntesis de cierre y presione ENTRAR para ver el resultado. También puede usar el mouse para seleccionar celdas que contengan datos que desee sumar.

 
1
2
3
A
Asistencia
4823
12335

Por ejemplo, con los datos de la tabla anterior, todas las fórmulas siguientes usan la función SUMA para devolver el mismo valor (17158):

  • =SUMA(4823,12335)
  • =SUMA(A2,A3)
  • =SUMA(A2:A3)
  • =SUMA(A2,12335)

La siguiente figura muestra la fórmula que usa la función SUMA para sumar el valor de la celda A2 y 12335. Debajo de la fórmula, la información en pantalla proporciona directrices para usar la función SUMA.

Uso de la función SUMA para sumar una celda y un valor

 Notas 

  • En Excel no hay función RESTAR. Para restar valores usando una función, use los valores negativos con la función SUMA. Por ejemplo, la fórmula =SUMA(30,A3,-15,-B6) suma 30 al valor de la celda A3, resta 15, y a continuación resta el valor de la celda B6.
  • Puede incluir hasta 255 valores numéricos o referencias a celdas o rangos, en cualquier combinación, como argumentos en la función SUMA.

Para obtener más información, vea el artículo Función SUMA.

Volver al principio Volver al principio

Restar los valores de un rango usando una función

Use la función SUMA para restar números escribiendo los números que desee restar como números negativos en la fórmula.

 
1
2
3
A
Asistencia
29072
12335

Por ejemplo, con los datos de la tabla anterior, todas las fórmulas siguientes usan la función SUMA para devolver el mismo valor (16737):

  • =SUMA(29072,-12335)
  • =SUMA(A2,-A3)
  • =SUMA(A2,-12335)
  • =SUMA(A2,(-1*(A3)))

Volver al principio Volver al principio

Suma de datos mediante la agrupación y la creación de tablas

Puede usar un esquema o un informe de tabla dinámica para agrupar y resumir sus datos.

Agregar los valores de una columna usando un esquema

Si sus datos están ordenados de la forma habitual (es decir, en filas y columnas) y puede agruparlos de forma logística por valores de columna, puede agrupar y resumir los datos creando un esquema. Al crear un esquema, podrá resumir los datos insertando subtotales y totales generales. Imaginemos que tiene las siguientes cifras de ventas, ordenadas por región y mes.

 
1
2
3
4
5
6
7
A B C
Región Mes Ventas
Este Ene 18.000 $
Este Feb 23.000 $
Este Mar 19.000 $
Oeste Ene 17.000 $
Oeste Feb 27.000 $
Oeste Mar 21.000 $

La siguiente ilustración muestra un esquema con subtotales, agrupados por región, y un total general.

Esquema con subtotales y total general

Use el comando Subtotal (ficha Datos, grupo Esquema) para crear un esquema, unos subtotales y un total general.

Los datos originales incluían tres filas de datos para la región Este y tres filas de datos para la región Oeste (de las filas 2 a la 7). Observe la operación de subtotal insertada en el Total del este en la fila 5 entre la última fila de los datos de Este y la primera fila de los datos de Oeste.

Si hace clic en la celda A4 y en el comando Subtotal, Excel crea un esquema e inserta filas para Total del este, Total del oeste y Total general, y rellena las celdas de la columna Ventas con esos totales.

Para obtener más información, vea los siguientes artículos:

Volver al principio Volver al principio

Agregar los valores de una lista o columna de tabla de Excel usando una función

Como una alternativa más flexible al comando Subtotal, puede usar la función SUBTOTAL para calcular subtotales y totales generales en listas o tablas de Excel que contengan filas o columnas ocultas. En la función SUBTOTAL, se puede especificar un argumento que incluya o no incluya valores ocultos.

 Nota   La función SUBTOTAL puede controlar si las filas ocultas se incluyen o no en los resultados e ignora siempre las filas filtradas.

Por ejemplo, supongamos que desea calcular subtotales y un total general de los datos de las celdas de la C2 a la C7, pero que desea ignorar los datos ocultos de las filas 3 y 6. La función que use se parecerá a la siguiente:

=SUBTOTAL(109,C2:C7)

El primer argumento (109) especifica que desea agregar los valores del rango e ignorar los valores ocultos. Para incluir los valores ocultos, use el 9 en su lugar como primer argumento.

Para obtener más información, vea el artículo Función SUBTOTAL.

Volver al principio Volver al principio

Sumar los datos y verlos desde distintas perspectivas

Si una hoja de cálculo contiene cientos o incluso miles de filas de datos similares, puede ser difícil extraer un significado de esos números. Puede crear un informe de tabla dinámica en Excel de los datos que muestre subtotales, totales generales y que resuma los datos basándose en las categorías que especifique.

Puede crear rápidamente una tabla dinámica seleccionando una celda de un rango de datos o tabla de Excel y, a continuación, en la ficha Insertar, en el grupo Tablas, haciendo clic en TablaDinámica.

Para ver la potencia de una tabla dinámica, tenga en cuenta que, en el siguiente ejemplo, los datos de ventas contienen muchas filas (son 40 filas de datos, pero el gráfico solo muestra una parte). Además, los datos no están resumidos y no contiene subtotales ni total general.

Datos usados en un informe de tabla dinámica

Un informe de tabla dinámica basado en los mismos datos muestra subtotales, totales generales y un resumen conciso de un solo vistazo.

Datos resumidos y sumados en un informe de tabla dinámica

La creación de tablas dinámicas y el trabajo con estas puede requerir una preparación inicial de los datos y que se familiarice con algunos conceptos. Para obtener más información a modo de introducción, vea los siguientes artículos:

Volver al principio Volver al principio

Suma de datos basada en una o varias condiciones

Al usar las funciones de la hoja de cálculo, puede aplicar condiciones (también conocidas como criterios) para agregar solo los datos que cumplan las condiciones que especifique.

Agregar los valores de un rango basándose en una condición simple usando una única función o una combinación de funciones

Use la función SUMAR.SI o anide la función SUMA en la función SI.

Puede agregar números basándose en un único criterio usando la función SUMAR.SI o usando una combinación de las funciones SUMA y SI.

Por ejemplo, la fórmula =SUMAR.SI(A2:A6,">20") solo suma los números superiores a 20 del rango de A2 a A6.

 Nota   La siguiente información es un poco técnica, pero merece la pena su aprendizaje.

Si la función SUMAR.SI no existía, puede producir la misma respuesta combinando las funciones SI y SUMA. La combinación de las funciones de esta forma también se conoce como "anidamiento", ya que una función se usa dentro de otra función.

Para crear una fórmula que imite la función SUMAR.SI, escriba una fórmula que trate el rango de A2 a A6 como una matriz, lo que significa que el rango se considera una única entidad que contiene cinco celdas.

La fórmula se verá así: {=SUMA(SI(A2:A6>20,A2:A6))}. Las llaves que rodean a la fórmula indican que se trata de una fórmula de matriz. Una fórmula de matriz requiere un tratamiento especial: en lugar de escribir las llaves usted mismo, debe presionar CTRL+MAYÚS+ENTRAR  , y Excel rodeará la fórmula =SUMA(SI(A2:A6>20,A2:A6)) con las llaves. Si escribe las llaves usted mismo, no creará una fórmula de matriz.

Intente lo siguiente    

Copie los datos de la siguiente tabla en una hoja de cálculo en la celda A1. Tras pegar los datos, verá que la celda A10 contiene un error de #¡VALOR!. Esto significa que debe convertir la celda A10 en una fórmula de matriz. Para ello, presione F2 y, a continuación, presione CTRL+MAYÚS+ENTRAR. Excel mostrará el resultado (65) en las celdas A8 y A10.

 
1
2
3
4
5
6
7
8
9
10
A
Grosor
18
29
36
11
16
Uso de la función SUMAR.SI
=SUMAR.SI(A2:A6,">20")
Uso de las funciones SUMA y SI
=SUMA(SI(A2:A6>20,A2:A6))

Para obtener más información, vea el artículo Función SUMAR.SI y la sección "Sumar números basándose en una condición" en el artículo Sumar números.

Además, el artículo de la Knowledge Base Cuándo usar SUMA(SI()) en lugar de CONTAR.BLANCO() proporciona más información sobre cuándo usar la función SUMAR.SI.

Volver al principio Volver al principio

Agregar los valores de una columna basándose en una única función o en varias condiciones usando una función

Use la función BDSUMA para sumar los números de un campo (columna) de los registros de una lista o base de datos que reúnan las condiciones (también conocidas como criterios) que especifique.

También puede usar la función BDSUMA si tiene una lista de columna y le resulta más sencillo definir las condiciones en un rango separado de celdas en lugar de usar una función anidada.

Para obtener más información, vea el artículo Función BDSUMA.

Para obtener más información, consulte también la sección "Sumar números basándose en condiciones almacenadas en otro rango", en el artículo Sumar números.

Volver al principio Volver al principio

Agregar los valores de un rango basándose en varias condiciones usando una única función o una combinación de funciones

Use la función SUMAR.SI.CONJUNTO . Proporcione el rango que desee sumar, un rango que contenga condiciones y las condiciones que se apliquen al rango de condiciones. Como alternativa, puede anidar las funciones SUMA y SI.

Para obtener más información, vea el artículo Función SUMAR.SI.CONJUNTO.

Consulte la sección "Sumar números basándose en varias condiciones", en el artículo Sumar números, para obtener más información sobre cómo usar las funciones SUMA y SI juntas.

Consulte también los siguientes artículos de la Knowledge Base para obtener información adicional:

Volver al principio Volver al principio

Suma de valores cuadrados y de matriz

Puede usar funciones de la hoja de cálculo para sumar valores de dos o varias columnas que correspondan una a la otra. Este tipo de operación puede ser tan simple como determinar un promedio ponderado (vea el siguiente ejemplo, que computa una puntuación media), o puede ser un cálculo estadístico o de ingeniería complejo.

Sumar el producto de los valores correspondientes en una o varias matrices

Use la función SUMAPRODUCTO. Por ejemplo, puede calcular una puntuación media de un estudiante usando la función SUMAPRODUCTO y dividiendo el resultado por el número de créditos, tal y como se muestra en la siguiente figura.

Multiplicación de valores correspondientes en dos matrices

La fórmula =SUMAPRODUCTO(A2:A6,B2:B6)/SUMA(B2:B6) multiplica la puntuación obtenida por cada clase por su número de créditos, suma estos productos (61,3), divide la suma por los créditos totales (18) y determina la puntuación media (3,41). Este tipo de cálculo también se conoce como promedio ponderado.

También puede usar la función SUMAPRODUCTO en operaciones matemáticas más avanzadas multiplicando varias matrices (matriz: utilizada para crear fórmulas sencillas que producen varios resultados o que funcionan en un grupo de argumentos que se organizan en filas y columnas. Un rango de matriz comparte una fórmula común; una constante de matriz es un grupo de constantes utilizadas como un argumento.).

La función SUMAPRODUCTO es fácil de usar con matrices que tienen las mismas dimensiones, pero también puede usar la función SUMA en una fórmula de matriz (fórmula de matriz: fórmula que lleva a cabo varios cálculos en uno o más conjuntos de valores y devuelve un único resultado o varios resultados. Las fórmulas de matriz se encierran entre llaves { } y se especifican presionando CTRL+MAYÚS+ENTRAR.) si necesita más flexibilidad.

Para obtener más información, vea el artículo Función SUMAPRODUCTO.

Las cuatro funciones siguientes se suelen usar solo en aplicaciones matemáticas estadísticas o complejas, por lo que solo se proporciona una breve descripción. Para obtener más información, haga clic en el nombre de la función para ir directamente a su tema de referencia.

  • Función SUMA.CUADRADOS Devuelve la suma de los cuadrados de una lista de números o valores de un rango. Por ejemplo, SUMA.CUADRADOS(2,3) devuelve 13.
  • Función SUMAX2MASY2 Agrega la suma de los cuadrados de los valores correspondientes en dos matrices.
  • Función SUMAX2MENOSY2  Devuelve la suma de la diferencia de los cuadrados de los valores correspondientes en dos matrices.
  • Función SUMAXMENOSY2 Devuelve la suma de los cuadrados de las diferencias de los valores correspondientes en dos matrices.

Volver al principio Volver al principio

Casos especiales (total, valores únicos)

Puede usar las funciones de la hoja de cálculo para crear totales que se actualizan automáticamente conforme agrega más datos a un rango o tabla o para agregar solo los valores únicos que se encuentran en un rango o tabla.

Crear un total usando una función

Use la función SUMA. Por ejemplo, cree encabezados de columna en una hoja de cálculo llamada Depósitos, Reembolsos y Saldo.

  1. En la primera celda de la columna Saldo, escriba el saldo inicial.
  2. En la celda directamente debajo del saldo (en este caso, la C3), escriba la fórmula que sume el valor de la columna Depósitos en la misma fila y reste el valor de la columna Reembolsos (=SUMA(C2,A3,-B3).
  3. Arrastre esta fórmula hacia abajo a las filas nuevas que agregue. En el siguiente ejemplo, la fórmula se ha arrastrado hasta la fila 4.
 
1
2
3
4
A B C
Depósitos Reembolsos Saldo
500
1000 625 =SUMA(C2,A3,-B3)
1000 740 =SUMA(C3,A4,-B4)

Puede usar un saldo acumulativo del mismo modo que usaría un registro de cheques para ver el aumento o la disminución de los valores de elementos de celdas conforme especifica nuevos elementos y valores.

Para obtener más información, vea el artículo Calcular un saldo acumulativo.

Volver al principio Volver al principio

Agregar los valores únicos en un rango usando una fórmula compuesta

En una columna, escriba una lista de valores que contenga duplicados y, a continuación, use una combinación de las funciones SUMA, SI y FRECUENCIA para sumar solo los valores únicos que se encuentren en ese rango.

Para obtener más información sobre cómo realizar este tipo de operación, vea la sección "Sumar valores únicos", en el artículo Sumar números.

Volver al principio Volver al principio

Inclusión de valores de otras hojas de cálculo u otros libros en una fórmula

Puede sumar o restar celdas o rangos de datos de otras hojas de cálculo u otros libros en una fórmula incluyendo una referencia. Para hacer referencia a una celda o rango de otra hoja de cálculo u otro libro, use las instrucciones proporcionadas en la siguiente tabla.

Para hacer referencia a: Escriba esto Ejemplos
Una celda o rango de otra hoja de cálculo del mismo libro El nombre de la hoja de cálculo seguido por un signo de exclamación, seguido por la referencia a la celda o al nombre del rango. Hoja2!B2:B4
Hoja3!CifrasVentas
Una celda o rango de otro libro actualmente abierto El nombre de archivo del libro entre corchetes ([]) y el nombre de la hoja de cálculo seguido por un signo de exclamación, seguido por la referencia a la celda o el nombre del rango. [MiLibro.xlsx]Hoja1!A7
Una celda o rango de otro libro que no está abierto La ruta completa y el nombre de archivo del libro entre corchetes ([]) y el nombre de la hoja de cálculo seguido por un signo de exclamación, seguido por la referencia a la celda o el nombre del rango. Si la ruta completa contiene espacios de caracteres, rodee el comienzo de la ruta y el final del nombre del libro con comillas simples (vea el ejemplo). ['C:\Mis Documentos\[MiLibro.xlsx]Hoja1'!A2:A5

Volver al principio Volver al principio

Suma y resta de valores de fecha y hora

Puede usar las funciones de fecha y hora e incluso la suma o resta simples para calcular el tiempo transcurrido, estimar las fechas de finalización de proyectos, etc. La siguiente tabla muestra algunas fórmulas que calculan las horas y los días transcurridos. Tenga en cuenta que si resta una fecha o una hora que dé como resultado un valor negativo, Excel muestra los caracteres ### en la celda que contiene la fórmula.

 
1
2
3
4
5
A B C
Hora de inicio Hora de finalización Fórmula de tiempo transcurrido Descripción (resultado)
11:55:24 A.M. 2:48:13 P.M. =B2-A2 Muestra el tiempo transcurrido en horas, minutos y segundos. En este caso, Excel muestra el resultado (2:52:49 A.M.) en un formato "A.M." porque la diferencia es inferior a 12 horas. Si la diferencia fuera de 12 horas o más, Excel mostraría un formato "P.M.".
       
Fecha de inicio Fecha de finalización Fórmula de días transcurridos Descripción (resultado)
28/05/2008 03/06/2008 =B5-A5 Muestra los días transcurridos como un número (6).

Trabajar con valores de fecha y hora puede producir resultados inesperados, por lo que se recomienda proceder con cuidado.

Volver al principio Volver al principio

Visualización de cálculos en la barra de estado de Excel

Para obtener una vista rápida de las celdas seleccionadas en su hoja de cálculo, eche un vistazo a la barra de estado de Excel (la barra de estado se encuentra en la parte inferior de la ventana del documento). En la barra de estado, Excel muestra la suma de dos o varias celdas seleccionadas que contienen datos numéricos. El valor de la suma de la barra de estado se actualiza en cuanto selecciona o anula la selección de celdas.

Barra de estado de Excel

Llamada 1 Barra de estado de Excel
Llamada 2 Valor de suma calculado en la barra de estado de Excel

Cuando se seleccionan una o varias celdas, la información de los datos de dichas celdas se muestra en la barra de estado de Excel. Por ejemplo, si se seleccionan cuatro celdas de la hoja de cálculo y contienen los valores 2, 3, una cadena de texto (como "nube") y 4, todos los valores siguientes se pueden mostrar en la barra de estado a la vez: Promedio, Cuenta, Recuento numérico, Mín., Máx. y Suma. Haga clic con el botón secundario en la barra de estado para mostrar u ocultar todos estos valores o alguno de ellos. Estos valores se muestran a continuación en la ilustración.

Visualización en la barra de estado de los cálculos y las cuentas de las celdas seleccionadas

Nota    En versiones de Excel anteriores a Excel 2007, estos mismos valores pueden verse en la barra de estado, pero uno por uno.

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2010, Excel 2007