Convertir horas

MostrarConvertir unas unidades de tiempo en otras

Utilice la función CONVERTIR para realizar esta tarea.

Si no está disponible esta función, instale y cargue el programa de complementos Herramientas para análisis.

Mostrar¿Cómo?

  1. En el menú Herramientas, elija Complementos.
  2. En la lista Complementos disponibles, seleccione el cuadro Herramientas para análisis y, a continuación, haga clic en Aceptar.
  3. Si es necesario, siga las instrucciones del programa de instalación.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
A
Datos
6
Fórmula Descripción (Resultado)
=CONVERTIR(A2,"day","hr") Convierte 6 días en horas (144)
=CONVERTIR(A2,"hr","mn") Convierte 6 horas en minutos (360)
=CONVERTIR(A2,"yr", "day") Convierte 6 años en días (2191,5)

 Nota   Para las conversiones en que se utilizan años, se considera que el año tiene 365,25 días.

Detalles de la función

CONVERTIR

MostrarConvertir las horas en el formato de hora estándar (horas : minutos : segundos) en un número decimal

Utilice la función ENTERO para realizar esta tarea.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
A
Hora
10:35:00 a.m.
12:15 p.m.
Fórmula Descripción (Resultado)
=(A2-ENTERO(A2))*24 Número de horas desde las 12:00 a.m. (10,583333)
=(A3-ENTERO(A3))*24 Número de horas desde las 12:00 a.m. (12,25)

Detalles de la función

ENTERO

MostrarConvertir horas en formato de número decimal en el formato de hora estándar (horas : minutos : segundos)

Utilice el operador de división (/) y la función TEXTO para realizar esta tarea.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
A
Horas
10,5833
12,25
Fórmula Descripción (Resultado)
=TEXTO(A2/24, "h:mm") Horas desde las 12:00 a.m. (10:35:00)
=TEXTO(A3/24, "h:mm") Horas desde las 12:00 a.m. (12:15)

 Nota   También puede aplicar el formato de número de hora sin utilizar la función TEXTO para especificar el formato. Para ver el número con formato de hora, seleccione la celda y haga clic en Celdas en el menú Formato. Haga clic en la ficha Número y, a continuación, en Hora en el cuadro Categoría. Sin embargo, si utiliza al mismo tiempo un formato aplicado con la función TEXTO y un formato de número, la función TEXTO prevalecerá.

Detalles de la función

TEXTO

 
 
Corresponde a:
Excel 2003