BUSCARV

Busca un valor específico en la primer columna de una matriz de tabla y devuelve, en la misma fila, un valor de otra columna de dicha matriz de tabla.

La V de BUSCARV significa vertical. Utilice BUSCARV en lugar de BUSCARH si los valores de comparación se encuentran en una columna situada a la izquierda de los datos que desea buscar.

Sintaxis

BUSCARV(valor_buscado;matriz_buscar_en;indicador_columnas;ordenado)

Valor_buscado     Valor que se va a buscar en la primera columna de la matriz (matriz: utilizada para crear fórmulas sencillas que producen varios resultados o que funcionan en un grupo de argumentos que se organizan en filas y columnas. Un rango de matriz comparte una fórmula común; una constante de matriz es un grupo de constantes utilizadas como un argumento.) de tabla. Valor_buscado puede ser un valor o una referencia. Si valor_buscado es inferior al menor de los valores de la primera columna de matriz_buscar_en, BUSCARV devuelve al valor de error #N/A.

Matriz_buscar_en    Dos o más columnas de datos. Use una referencia a un rango o un nombre de rango. Los valores de la primera columna de matriz_buscar_en son los valores que busca valor_buscado. Estos valores pueden ser texto, números o valores lógicos. Las mayúsculas y minúsculas del texto son equivalentes.

Indicador_columnas    Número de columna de matriz_buscar_en desde la cual debe devolverse el valor coincidente. Si el argumento indicador_columnas es igual a 1, la función devuelve el valor de la primera columna del argumento matriz_buscar_en; si el argumento indicador_columnas es igual a 2, devuelve el valor de la segunda columna de matriz_buscar_en y así sucesivamente. Si indicador_columnas es:

  • Si es inferior a 1, BUSCARV devuelve al valor de error #VALUE!
  • Si es superior al número de columnas de matriz_buscar_en, BUSCARV devuelve el valor de error #REF!

Ordenado    Valor lógico que especifica si BUSCARV va a buscar una coincidencia exacta o aproximada:

  • Si se omite o es VERDADERO, se devolverá una coincidencia exacta o aproximada. Si no localiza ninguna coincidencia exacta, devolverá el siguiente valor más alto inferior a valor_buscado.

Los valores de la primera columna de matriz_buscar_en deben estar clasificados según un criterio de ordenación ascendente; en caso contrario, es posible que BUSCARV no devuelva el valor correcto. Para obtener más información, vea Ordenar datos.

  • Si es FALSO, BUSCARV sólo buscará una coincidencia exacta. En este caso, no es necesario ordenar los valores de la primera columna de matriz_buscar_en. Si hay dos o más valores en la primera columna de matriz_buscar_en, se utilizará el primer valor encontrado. Si no se encuentra una coincidencia exacta, se devolverá el valor de error #N/A.

Observaciones

  • Al buscar valores de texto en la primera columna de matriz_buscar_en, asegúrese de que los datos de ésta no tienen espacios al principio ni al final, de que no hay un uso incoherente de las comillas rectas ( ' o " ) ni tipográficas ( ‘ o “), y de que no haya caracteres no imprimibles. En estos casos, BUSCARV puede devolver un valor inesperado o incorrecto. Para obtener más información, vea LIMPIAR y ESPACIOS.
  • Al buscar valores de fechas o números, asegúrese de que los datos de la primera columna de matriz_buscar_en no se almacenen como valores de texto, ya que, en ese caso, BUSCARV puede devolver un valor incorrecto o inesperado. Para obtener más información, vea Convertir números almacenados como texto en números.
  • Si Ordenado es FALSO y valor_buscado es un valor de texto, se pueden utilizar los caracteres comodín de signo de interrogación (?) y asterisco (*) en el argumento valor_buscado. El signo de interrogación corresponde a un solo carácter cualquiera y el asterisco equivale a cualquier secuencia de caracteres. Si lo que desea buscar es un signo de interrogación o un asterisco, escriba una tilde (~) antes del carácter.

Ejemplo 1

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

En este ejemplo, se busca en la columna Densidad de una tabla de propiedades atmosféricas los valores correspondientes de las columnas Viscosidad y Temperatura (los valores se refieren a aire a 0 grados Celsius al nivel del mar, o 1 atmósfera).

 
1
2
3
4
5
6
7
8
9
10
A B C
Densidad Viscosidad Temperatura 
0,457 3,55 500
0,525 3,25 400
0,616 2,93 300
0,675 2,75 250
0,746 2,57 200
0,835 2,38 150
0,946 2,17 100
1,09 1,95 50
1,29 1,71 0
Fórmula Descripción (resultado)
=BUSCARV(1;A2:C10;2) Utilizando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0.946, y después devuelve el valor de la columna B en la misma fila (2,17).
=BUSCARV(1;A2:C10;3;VERDADERO) Utilizando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0.946, y después devuelve el valor de la columna C en la misma fila (100).
=BUSCARV(0,7;A2:C10;3;FALSO) Utilizando una coincidencia exacta, busca el valor 0,7 en la columna A. Como en la columna A no hay ninguna coincidencia exacta, devuelve un error (#N/A).
=BUSCARV(0,1;A2:C10;2;VERDADERO) Utilizando una coincidencia aproximada, busca el valor 0,1 en la columna A. Como 0,1 es inferior al menor de los valores de la columna A, se devuelve un error (#N/A).
=BUSCARV(2;A2:C10;2;VERDADERO) Utilizando una coincidencia aproximada, busca el valor 2 en la columna A, busca el mayor de los valores que sea inferior o igual a 2 en la columna A, que es 1,29, y después devuelve el valor de la columna B en la misma fila (1,71).

Ejemplo 2

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

En este ejemplo, se buscan valores en la columna Id. de artículo de una tabla de productos para bebés y se les asignan los valores correspondientes de las columnas Costo y Marcas para calcular los precios y las condiciones de prueba.

 
1
2
3
4
5
6
A B C D
Id. de artículo Artículo Costo Marcas
ST-340 Cochecito 145,67 $ 30%
BI-567 Babero 3,56 $ 40%
DI-328 Pañales 21,45 $ 35%
WI-989 Toallitas 5,12 $ 40%
AS-469 Aspirador 2,56 $ 45%
Fórmula Descripción (resultado)
= BUSCARV("DI-328", A2:D6, 3, FALSO) * (1 + BUSCARV("DI-328", A2:D6, 4, FALSO)) Calcula el precio minorista de los pañales agregando el porcentaje marcado al costo ($28,96)
= (BUSCARV("WI-989", A2:D6, 3, FALSO) * (1 + BUSCARV("WI-989", A2:D6, 4, FALSO))) * (1 - 20%) Calcula el precio de venta de las toallitas restando un descuento especificado al precio minorista (5,73 $)
= SI(BUSCARV(A2, A2:D6, 3, FALSO) >= 20, "La marca es " & 100 * BUSCARV(A2, A2:D6, 4, FALSO) &"%", "El costo es inferior a 20,00 $") Si el costo de un artículo es superior o igual a 20,00 $, muestra la cadena "La marca es nn%"; en caso contrario, muestra "El costo es inferior a $20,00". (La marca es 30%)
= SI(BUSCARV(A3, A2:D6, 3, FALSO) >= 20, "La marca es: " & 100 * BUSCARV(A3, A2:D6, 4, FALSO) &"%", "El costo es $" & BUSCARV (A3, A2:D6, 3, FALSO)) Si el costo de un artículo es superior o igual a 20,00 $, muestra la cadena "La marca es nn%"; en caso contrario, muestra el costo "El costo es n,nn $". (El costo es 3,56 $)

Ejemplo 3

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

En este ejemplo, se busca en la columna Id. de una tabla de empleados y se buscan los valores coincidentes de otras columnas para calcular las edades y probar las condiciones de error.

 
1
2
3
4
5
6
7
A B C D E
Id. Apellidos Nombre Puesto Fecha nacimiento
1 Davolio Nancy Rep. de ventas 8 de diciembre de 1968
2 Fuller Andrew Vicepresidente de ventas 19 de febrero de 1952
3 Leverling Janet Rep. de ventas 30 de agosto de 1963
4 Peacock Margaret Rep. de ventas 19 de septiembre de 1958
5 Buchanan Steven Jefe de ventas 4 de marzo de 1955
6 Suyama Michael Rep. de ventas 2 de julio de 1963
Fórmula Descripción (resultado)
=ENTERO(FRAC.AÑO(FECHA(2004,6,30), BUSCARV(5,A2:E7,5, FALSO), 1)) Para el año fiscal 2004, busca la edad de un empleado cuyo id. es 5. Utiliza la función FRAC.AÑO para restar la fecha de nacimiento de la fecha final del año fiscal y muestra el resultado como un entero utilizando la función ENTERO (49).
=SI(ESNOD(BUSCARV(5,A2:E7,2,FALSO)) = VERDADERO, "Empleado no encontrado", BUSCARV(5,A2:E7,2,FALSO))

Si hay un empleado cuyo id. es 5, muestra sus apellidos; en el caso contrario, muestra el mensaje "Empleado no encontrado" (Buchanan).

La función ESNOD devuelve el valor VERDADERO si la función BUSCARV devuelve el valor de error #NA.

=SI(ESNOD(BUSCARV(15,A3:E8,2,FALSO)) = VERDADERO, "Empleado no encontrado", BUSCARV(15,A3:E8,2,FALSO))

Si hay un empleado cuyo id. es 5, muestra sus apellidos; en el caso contrario, muestra el mensaje "Empleado no encontrado" (Empleado no encontrado).

La función ESNOD devuelve el valor VERDADERO si la función BUSCARV devuelve el valor de error #NA.

=BUSCARV(4,A2:E7,3,FALSO) & " " & BUSCARV(4,A2:E7,2,FALSO) & " es un " & BUSCARV(4,A2:E7,4,FALSO) & "." Para un empleado cuyo id. es 4, concatena los valores de tres celdas para formar una frase completa (Margaret Peacock es un Agente de ventas).
 
 
Corresponde a:
Excel 2007