Función SUMAR.SI.CONJUNTO

En este artículo se describen la sintaxis de la fórmula y el uso de la función (función: fórmula ya escrita que toma un valor o valores, realiza una operación y devuelve un valor o valores. Utilice funciones para simplificar y acortar fórmulas en una hoja de cálculo, especialmente aquellas que llevan a cabo cálculos prolongados o complejos.)SUMAR.SI.CONJUNTO de Microsoft Office Excel.

Descripción

Agrega las celdas de un rango (rango: dos o más celdas de una hoja. Las celdas de un rango pueden ser adyacentes o no adyacentes.) que cumpla con varios criterios. Por ejemplo, si desea sumar los números del rango A1:A20 sólo si los números de B1:B20 correspondientes son mayores que cero (0) y los números de C1:C20 correspondientes son menores que 10, puede usar la siguiente fórmula:

=SUMAR.SI.CONJUNTO(A1:A20; B1:B20; ">0"; C1:C20; "<10")

 Importante   El orden de los argumentos es diferente entre las funciones SUMAR.SI.CONJUNTO y SUMAR.SI. Concretamente, el argumento rango_suma es el primer argumento de SUMAR.SI.CONJUNTO, pero es el tercero de SUMAR.SI. Si está copiando o editando estas funciones similares, asegúrese de poner los argumentos en el orden correcto.

Sintaxis

SUMAR.SI.CONJUNTO(rango_suma; rango_criterios1; criterios1, [rango_criterios2;
         criterios2]; …)

La sintaxis de la función SUMAR.SI.CONJUNTO tiene los siguientes argumentos (argumento: valor que proporciona información a una acción, un evento, un método, una propiedad, una función o un procedimiento.):

Observaciones

  • Las celdas del argumento rango_suma se suman sólo si se cumplen los criterios correspondientes especificados para esa celda. Por ejemplo, supongamos que una fórmula contiene dos argumentos rango_criterios. Si la primera celda de rango_criterios1 cumple con criterios1 y la primera celda de rango_criterios2 cumple con criterios2, se agrega la primera celda de rango_suma a la suma y así sucesivamente para todas las celdas restantes de los rangos especificados.
  • Las celdas del argumento rango_suma que contienen VERDADERO se evalúan como 1; las celdas de rango_suma que contienen FALSO se evalúan como 0 (cero).
  • A diferencia de los argumentos rango y criterios de la función SUMAR.SI, en la función SUMAR.SI.CONJUNTO, cada argumento rango_criterios debe contener el mismo número de filas y columnas que el argumento rango_suma.
  • Puede usar caracteres comodín como  el signo de interrogación (?) y el asterisco (*) en los criterios. Un signo de interrogación coincide con un carácter individual, un asterisco coincide con una secuencia de caracteres. Si desea buscar un signo de interrogación o un asterisco, escriba una tilde (~) antes del carácter.

Ejemplo 1

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

  • Seleccione el ejemplo de este artículo.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 
1
2
3
4
5
6
7
8
9
10


11


12
A B C
Cantidad vendida Producto Vendedor
5 Manzanas 1
4 Manzanas 2
15 Alcachofas 1
3 Alcachofas 2
22 Bananas 1
12 Bananas 2
10 Zanahorias 1
33 Zanahorias 2
Fórmula Descripción Resultado
=SUMAR.SI.CONJUNTO(A2:A9; B2:B9; "=A*"; C2:C9; 1) Agrega la cantidad total de productos vendidos que comienzan con "A" y fueron vendidos por el vendedor 1. 20
=SUMAR.SI.CONJUNTO(A2:A9; B2:B9; "<>Bananas"; C2:C9; 1) Agrega la cantidad total de productos (sin incluir bananas) vendidos por el vendedor 1. 30

Ejemplo 2

Agregar importes de cuentas bancarias sobre la base del interés pagado

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

  • Seleccione el ejemplo de este artículo.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 

1

2

3

4

5
6



7





8
A B C D E
Totales Cuenta 1 Cuenta 2 Cuenta 3 Cuenta 4
Cantidad en dólares 100 390 8321 500
Interés pagado (2000) 1% 0,5% 3% 4%
Interés pagado (2001) 1% 1,3% 2,1% 2%
Interés pagado (2002) 0,5% 3% 1% 4%
Fórmula Descripción Resultado
=SUMAR.SI.CONJUNTO(B2:E2; B3:E3; ">3%"; B4:E4; ">=2%") Importes totales de cada una de las cuentas bancarias en las que el interés era mayor que 3% para el año 2000 y mayor o igual que 2% para el año 2001. 500
=SUMAR.SI.CONJUNTO(B2:E2; B5:E5; ">=1%"; B5:E5; "<=3%"; B4:E4; ">1%") Importes totales de cada una de las cuentas bancarias en las que el interés era entre 1% y 3% para el año 2002 y mayor que 1% para el año 2001. 8711

Ejemplo 3

Agregar las lluvias de días concretos

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

  • Seleccione el ejemplo de este artículo.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 

1

2


3


4
5












6
A B C D E
Medidas diarias Primer día Segundo día Tercer día Cuarto día
Lluvia (pulgadas totales) 3,3 0,8 5,5 5,5
Temperatura promedio (grados) 55 39 39 57,5
Velocidad promedio del viento (millas por hora) 6,5 19,5 6 6,5
Fórmula Descripción Resultado
=SUMAR.SI.CONJUNTO(B2:E2; B3:E3; ">=40"; B4:E4; "<10")

Agrega la cantidad total de lluvia de los días en que la temperatura promedio era de al menos 40° Fahrenheit y la velocidad promedio del viento era menor de 10 millas por hora.

Sólo se suman las celdas B2 y E2 porque, para cada columna (de B a E), los valores de las filas 3 y 4 deben cumplir con los criterios1 y los criterios2 respectivamente. Las celdas B3 y B4 cumplen con ambos criterios, al igual que E3 y E4. Sin embargo, C3 y C4 no cumplen con ninguno de los criterios. Por último, aunque D4 cumple con los criterios2, D3 no cumple con los criterios1.

8,8

Ejemplo 4

Agregar lluvia para los períodos de mañana y tarde de días específicos

Este ejemplo se basa en los datos del Ejemplo 3 y separa la lluvia, las temperaturas promedio y la velocidad promedio del viento en dos períodos de 12 horas para cada día.

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

  • Seleccione el ejemplo de este artículo.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 


1

2

3


4


5



6



7
8
















9
A B C D E
Medidas de mañana y tarde Primer día Segundo día Tercer día Cuarto día
a.m.: lluvia (pulgadas totales) 1,3 0 1,5 3
p.m.: lluvia (pulgadas totales) 2 0,8 4 2,5
a.m.: temperatura promedio (grados) 56 44 40 38
p.m.: temperatura promedio (grados) 54 34 38 77
a.m.: velocidad promedio del viento (millas por hora) 13 6 8 1
p.m.: velocidad promedio del viento (millas por hora) 0 33 4 12
Fórmula Descripción Resultado
=SUMAR.SI.CONJUNTO(B2:E3; B4:E5; ">=40"; B6:E7; "<10")

Agrega la cantidad total de lluvias para los períodos de 12 horas en los que la temperatura promedio era de al menos 40° Fahrenheit y la velocidad promedio del viento era menor de 10 millas por hora.

Sólo se suman las celdas B3, C2, y D2, ya que sus celdas correspondientes cumplen con ambos criterios. Las celdas correspondientes de B3 son B5 y B7, las celdas correspondientes de C2 son C4 y C6, y las celdas correspondientes de D2 son D4 y D6.

Como ejemplo de los datos excluidos de la operación, las celdas correspondientes de B2 (B4 y B6) no cumplen con ambos criterios; concretamente, la celda B6 se excluye porque su valor (13) es mayor que el valor del argumento criterios2 (10).

3,5
 
 
Corresponde a:
Excel 2007