Usar comprobación de errores para corregir errores comunes en las fórmulas

Al igual que un corrector ortográfico, que comprueba los datos que se escriben en las celdas para ver si contienen errores, se pueden implementar determinadas reglas para comprobar si hay errores en las fórmulas. Estas reglas no garantizan que la hoja de cálculo (hoja de cálculo: documento principal que se utiliza en Excel para almacenar y trabajar con datos. Consta de celdas que se organizan en filas y columnas. Una hoja de cálculo se almacena siempre en un libro.) no tenga ningún error, pero ayudan en gran medida a encontrar los errores más comunes. Todas ellas se pueden activar y desactivar individualmente.

Los errores se pueden señalar y corregir de dos formas: de uno en uno, como con el corrector ortográfico, o inmediatamente a medida que se produzcan en la hoja de cálculo en la que trabaja. En ambos casos, cuando se detecta un error, aparece un triángulo en la esquina superior izquierda de la celda.


Celda con un problema de fórmula

Celda con un error de fórmula

Los errores que impiden devolver un resultado (por ejemplo, cuando se divide un número por cero) obligan a prestarles atención, y provocan que en la celda aparezca un valor de error (en este caso, #DIV/0!). Puede haber otros errores menos graves, por ejemplo cuando entre una fórmula y las fórmulas adyacentes parece haber una incoherencia. Aunque la fórmula devuelve un resultado correcto, el mensaje de error alerta sobre la conveniencia de examinar la fórmula.


Puede solucionar el error mediante las opciones que aparecen u omitirlo haciendo clic en Omitir error. Si omite une error en una celda en particular, ese error ya no volverá a aparecer en las comprobaciones de errores subsiguientes. Sin embargo, todos los errores que haya omitido se pueden restablecer para que vuelvan a mostrarse.

¿Qué desea hacer?


Activar o desactivar reglas de revisión de errores

  1. Haga clic en la pestaña Archivo, en Opciones y, a continuación, en la categoría Fórmulas.
  2. En Reglas de verificación de Excel, active o desactive las casillas de cualquiera de las siguientes reglas:

Para obtener más información acerca de cómo resolver estos errores, vea los vínculos en la lista Vea también.

 Nota   Si especifica un valor de error directamente en una celda, no se marcará como error.

  • Fórmula de columna calculada incoherente en tablas    Una columna calculada puede incluir fórmulas que son diferentes de la fórmula de columna que crea una excepción. Las excepciones de columna calculada se crean al realizar las acciones siguientes:
  • Escribir datos que no son fórmulas en una celda de columna calculada.
  • Escribir una fórmula en una celda de columna calculada y, a continuación, hacer clic en el botón DeshacerImagen del botón de la Barra de herramientas de acceso rápido.
  • Escribir una nueva fórmula en una columna calculada que ya contiene una o varias excepciones.
  • Copiar datos en la columna calculada que no coinciden con la fórmula de columna calculada.

 Nota   Si los datos copiados contienen una fórmula, esta fórmula sobrescribe los datos en la columna calculada.

  • Mover o eliminar una celda de otra área de hoja de cálculo a la que hace referencia una de las filas de una columna calculada.
  • Celdas que contienen años representados con 2 dígitos    La celda contiene una fecha de texto en la que el siglo se puede interpretar incorrectamente si se utiliza en fórmulas. Por ejemplo, la fecha de la fórmula =AÑO("1/1/31") podría ser 1931 ó 2031. Utilice esta regla para comprobar fechas de texto que no sean claras.
  • Números con formato de texto o precedidos por un apóstrofo    La celda contiene números guardados como texto. Esto suele ocurrir cuando se importan datos importados de otros orígenes. Los números guardados como texto pueden ocasionar cambios inesperados en la forma de ordenar; además, no pueden usarse para cálculos. Por ello, es preferible convertir las celdas correspondientes a un formato numérico.
  • Fórmulas incoherentes con otras fórmulas de la región    La fórmula no coincide con el patrón de las demás fórmulas cercanas. En muchos casos, las fórmulas que son adyacentes a otras fórmulas difieren solo en las referencias que se usan. En el siguiente ejemplo de cuatro fórmulas adyacentes, Excel muestra un error junto a la fórmula =SUMA(A10:F10) ya que las fórmulas adyacentes incrementan en una fila y la fórmula =SUMA(A10:F10) incrementa en filas 8 ; Excel espera la fórmula = SUMA(A3:F3).
A
Fórmulas
=SUMA(A1:F1)
=SUMA(A2:F2)
=SUMA(A10:F10)
=SUMA(A4:F4)
  • Si las referencias que se usan en una fórmula no son coherentes con las de las fórmulas adyacentes, Excel muestra un error.
  • Fórmulas que omiten celdas en una región    Puede ocurrir que una fórmula no incluya automáticamente referencias a datos que se inserten entre el rango de datos original y la celda que contiene la fórmula. Esta regla compara la referencia de una fórmula con el rango real de celdas que es adyacente a la celda que contiene la fórmula. Si las celdas adyacentes contienen más valores (no son celdas en blanco), Excel muestra un error al lado de la fórmula.

Por ejemplo, cuando se aplica esta regla, Excel inserta un error al lado de la fórmula =SUMA(A2:A4), porque las celdas A5, A6 y A7 son adyacentes a las celdas a las que hace referencia la fórmula (A2:A4) y también a la celda que contiene la fórmula (A8), y esas tres celdas (A5, A6 y A7) contienen datos a los que debería hacerse referencia en la fórmula.

A
Factura
15.000
9.000
8.000
20.000
5.000
22.500
=SUMA(A2:A4)
  • Celdas desbloqueadas que contengan fórmulas    La fórmula no está bloqueada para protección. Dado que todas las celdas en una hoja de cálculo están bloqueadas para protección de manera predeterminada, esto quiere decir que un usuario desprotegió la celda. Cuando una fórmula está protegida, no se puede modificar sin desprotegerla. Asegúrese de que no desea que la celda esté protegida. La protección de las celdas que contienen fórmulas impide que se modifiquen y puede ayudar a evitar futuros errores.
  • Fórmulas que hacen referencia a celdas vacías    La fórmula contiene una referencia a una celda vacía. Esto puede dar lugar a resultados no deseados, tal como se muestra en el siguiente ejemplo.

Suponga que desea calcular el promedio de los números que figuran en la siguiente columna de celdas. Si la tercera celda está en blanco, como esto no se considera un valor, la celda no se incluye en el cálculo y el resultado es 22,75. Si la tercera celda contiene 0 (lo cual se considera un valor), la celda se incluye en el cálculo y el resultado es 18,2.

A
Datos
24
12
 
45
10
=PROMEDIO(A2:A6)
  • Los datos de una tabla no son válidos    Error de validación en una tabla. Haga clic en Validación de datos en el grupo Herramientas de datos de la ficha Datos para comprobar la configuración de validación de la celda.

Volver al principio Volver al principio

Corregir errores comunes en las fórmulas de uno en uno

Si previamente ha revisado si la hoja de cálculo contiene errores, los errores omitidos no aparecerán hasta que se restablezcan.

  1. Seleccione la hoja de cálculo cuyos errores desee revisar.
  2. Si la hoja de cálculo se calcula manualmente, presione F9 para actualizarla.
  3. En el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en Comprobación de errores.

Grupo Auditoría de fórmulas en la ficha Fórmulas

Cuando se encuentra un error, aparece el cuadro de diálogo Comprobación de errores.

  1. Si previamente ha omitido algunos errores, vuelva a comprobarlos de la siguiente manera (puede mantener abierto el cuadro de diálogo Comprobación de errores):
    1. En la ficha Archivo, haga clic en Opciones y, a continuación, haga clic en Fórmulas.
    2. En la sección Comprobación de errores, haga clic en Restablecer errores omitidos y, a continuación, haga clic en Aceptar.
    3. En el cuadro de diálogo Comprobación de errores, haga clic en Reanudar.

 Nota   Al restablecer los errores omitidos, se restablecerán todos los errores en todas las hojas de cálculo del libro activo.

  1. Coloque el cuadro de diálogo Comprobación de errores justo debajo de la Barra de fórmulas (barra de fórmulas: barra de la parte superior de la ventana de Excel que se utiliza para escribir o editar valores o fórmulas en celdas o gráficos. Muestra la fórmula o el valor constante almacenado en la celda activa.).

Barra de fórmulas

  1. Haga clic en uno de los botones de acción en la parte derecha del cuadro de diálogo. Las acciones disponibles son diferentes para cada tipo de error.

 Nota   Si hace clic en Omitir error, se marcará el error para omitirlo en las revisiones subsiguientes.

  1. Haga clic en Siguiente, y continúe hasta finalizar la comprobación de errores.

Volver al principio Volver al principio

Marcar los errores comunes de las fórmulas en la hoja de cálculo y corregirlos directamente

  1. Haga clic en la pestaña Archivo, en Opciones y, a continuación, en la categoría Fórmulas.
  2. En Comprobación de errores, asegúrese de que la casilla Habilitar comprobación de errores en segundo plano está seleccionada.
  3. Para cambiar el color del triángulo que marca dónde se produce un error, en el cuadro Indicar errores con el color, seleccione el color que desea.
  4. Seleccione una celda que tenga un triángulo en la esquina superior izquierda.
  5. Junto a la celda, haga clic en el botón Comprobación de errores Imagen del botón que aparece y, a continuación, haga clic en la opción que desee. Los comandos disponibles varían en función de cada tipo de error, mientras que la primera entrada describe el error.

Si hace clic en Omitir error, el error se marcará para omitirlo en las siguientes revisiones.

  1. Repita los dos pasos anteriores.

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2010