Tres maneras de convertir números en texto

Se aplica a
Microsoft Office Excel 2003

Logotipo de Mr. Excel Este artículo es una es una adaptación de MrExcel.com. Visite el sitio Web MrExcel.com para obtener más información y sugerencias.

¿Hay alguna manera sencilla de dar formato de texto a los números existentes? Aquí encontrará tres respuestas a esta pregunta tan frecuente.

Utilizar el cuadro de diálogo Formato de celdas

Supongamos que tiene una hoja de cálculo con una columna de números. Podría dar formato de texto a la columna utilizando el comando Formato > Celdas > Número > Texto.

Para obtener más información, consulte Dar formato de texto a los números.

Utilizar la función TEXTO

Otra posibilidad consiste en utilizar la función TEXTO, que convierte en texto los valores que tengan un formato de número específico. En este ejemplo, supongamos que posee números en las celdas A2:A100. Para convertirlos en texto, podría hacer lo siguiente.

  1. Inserte una columna B en blanco.
  2. En la celda B2, escriba esta fórmula:

=TEXTO(A2;"0")

  1. Rellene hacia abajo la fórmula de la celda B2, desde B3:B100.
  2. Ahora deberá cambiar las fórmulas a valores para que se conviertan en texto. Resalte las celdas B2:B100.
  3. Utilice Ctrl+C para copiarlas y, a continuación, haga clic en Edición > Pegado especial > Valores > Aceptar.

Ahora las entradas de la columna B serán versiones en texto de los números de la columna A.

  1. Vuelva a copiar la columna B en la columna A.
  2. Elimine la columna B temporal.

La clave de esta técnica es la función =TEXTO(). El segundo parámetro de esta función especifica el formato que debería tener el número antes de convertirlo en texto. Puede que sea necesario ajustarlo tomando como base sus números. Por ejemplo:

  • El resultado de la función =TEXTO(123,25;"0") será 123.
  • El resultado de =TEXTO(123,25;"0,0") será 123,3.
  • El resultado de la función =TEXTO(123,25;"0,00") será 123,25.
  • Para mantener sólo las cifras decimales que se escribieron, utilice =TEXTO(A2,"General").

Esta función también es magnífica para convertir fechas en fechas con formato. Si tiene el valor 29/5/2003 en una celda, utilizando =TEXTO(A2,"d mmmm, yyyy") se obtiene 29 Mayo 2003.

Para obtener más información, consulte el tema de la Ayuda TEXTO.

Utilizar el Asistente para convertir texto en columnas

Un tercer método consiste en resaltar la columna de números y utilizar el comando Datos > Texto en columnas. En la Página 1 del Asistente, elija el tipo de archivo apropiado (probablemente será Delimitado). En la Página 2, quite los divisores de columnas que puedan aparecer para mantener los datos en una sola columna. En la Página 3, haga clic Texto, bajo Formato de los datos en columnas, para indicar que esta columna contiene texto.

 Sugerencia   Una vez terminado el Asistente, puede que aparezcan pequeños triángulos, denominados indicadores de errores, en una o varias celdas. Si le distraen los indicadores, puede seleccionar la columna y quitarlos todos de una vez, quitando sólo uno de ellos. Para obtener más información, consulte Ocultar valores e indicadores de errores en las celdas.

 
 
Corresponde a:
Excel 2003