Sumar números

Supongamos que desea sumar precios para todos los artículos que no están a la venta en un almacén o sumar los márgenes de beneficio bruto para todos los departamentos bajo presupuesto. Existen varias formas de sumar números.

¿Qué desea hacer?


Sumar números de una celda

Para realizar esta tarea, utilice el operador aritmético + (signo más).

Por ejemplo, si escribe la fórmula siguiente en una celda:

=5+10

La celda muestra el resultado siguiente:

15

Volver al principio Volver al principio

Sumar todos los números contiguos en una fila o columna

Para realizar esta tarea, utilice Autosuma Imagen del botón.

  1. Haga clic en una celda situada debajo de la columna de números o a la derecha de la fila de números.
  2. En la ficha Inicio, en el grupo Modificar, haga clic en Autosuma Imagen del botón y, a continuación, presione ENTRAR.

Volver al principio Volver al principio

Sumar números no contiguos

Para realizar esta tarea, utilice la función SUMA.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
4
5
6
7
A B
Vendedor Factura
Buchanan 15.000
Buchanan 9.000
Suyama 8.000
Suyama 20.000
Buchanan 5.000
Dodsworth 22.500
Fórmula Descripción (resultado)
=SUMA(B2:B3; B5) Suma dos facturas de Buchanan y una de Suyama (44.000)
=SUMA(B2;B5;B7) Suma facturas individuales de Buchanan, Suyama y Dodsworth (57.500)

 Nota    La función SUMA puede incluir hasta 30 referencias a celdas o rangos.

Detalles de la función

SUMA

Volver al principio Volver al principio

Sumar números basándose en una condición

Puede utilizar la función SUMAR.SI para crear un valor total para un rango basándose en el valor de otro rango, como en el siguiente ejemplo.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
4
5
6
7
A B
Vendedor Factura
Buchanan 15.000
Buchanan 9.000
Suyama 8.000
Suyama 20.000
Buchanan 5.000
Dodsworth 22.500
Fórmula Descripción (resultado)
=SUMAR.SI(A2:A7;"Buchanan";B2:B7) Suma de la facturas de Buchanan (29000)
=SUMAR.SI(B2:B5;">=9000";B2:B7) Suma de grandes facturas mayores o iguales que 9.000 (66500)
=SUMAR.SI(B2:B7;"<9000";B2:B7) Suma de pequeñas facturas menores que 9.000 (13000)

La función SUMAR.SI utiliza los siguientes argumentos


Fórmula con función SUMAR.SI

Fórmula con función SUMAR.SI
Llamada 1 Rango de evaluación: comprobar estas celdas para determinar si una fila cumple los criterios.
Llamada 2 Criterios: la condición que las celdas evaluadas deben cumplir para que la fila se incluya en la suma.
Llamada 3 Rango de suma: sumar los números de estas celdas si la fila cumple la condición.

Detalles de la función

SUMAR.SI

Volver al principio Volver al principio

Sumar números basándose en varias condiciones

Para realizar esta tarea, utilice las funciones SI y SUMA.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Región Vendedor Tipo Ventas
Sur Buchanan Bebidas 3571
Oeste Davolio Lácteos 3338
Este Suyama Bebidas 5122
Norte Suyama Lácteos 6239
Sur Dodsworth Alimentos 8677
Sur Davolio Carnes 450
Sur Davolio Carnes 7673
Este Suyama Alimentos 664
Norte Davolio Alimentos 1500
Sur Dodsworth Carnes 6596
Fórmula Descripción (resultado)
=SUMA(SI((A2:A11="Sur")*(C2:C11="Carnes");D2:D11)) Suma de las ventas de carne en la región sur (14719)
=SUMA(SI((A2:A11="Sur")+(A2:A11="Este");D2:D11)) Suma de las ventas en las regiones sur o este (32753)

 Nota    Las fórmulas del ejemplo deben escribirse como fórmulas de matriz (fórmula de matriz: fórmula que lleva a cabo varios cálculos en uno o más conjuntos de valores y devuelve un único resultado o varios resultados. Las fórmulas de matriz se encierran entre llaves { } y se especifican presionando CTRL+MAYÚS+ENTRAR.). Tras copiar el ejemplo en una hoja en blanco, seleccione la celda de fórmula. Presione F2 y, a continuación, CTRL+MAYÚS+ENTRAR. Si la fórmula no se especifica como fórmula de matriz, se devolverá el error #¡VALOR!.

Detalles de la función

SUMA

SI

Volver al principio Volver al principio

Sumar números basándose en los criterios almacenados en otro rango

Para realizar esta tarea, utilice la función BDSUMA.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
4
5
6
7
8
9
10
11
A B C D
Región Vendedor Tipo Ventas
Sur Buchanan Bebidas 3571
Oeste Davolio Lácteos 3338
Este Suyama Bebidas 5122
Norte Suyama Lácteos 6239
Sur Dodsworth Alimentos 8677
Sur Davolio Carnes 450
Sur Davolio Carnes 7673
Este Suyama Alimentos 664
Norte Davolio Alimentos 1500
Sur Dodsworth Carnes 6596
Región Vendedor Tipo Ventas
Sur Carnes
Alimentos
Fórmula Descripción (resultado)
=BDSUMA(A1:D11; "Ventas"; A12:D13) Suma de las ventas de carne en la región sur (14719)
=BDSUMA(A1:D11; "Ventas"; A12:D14) Suma de las ventas de carne y verduras en la región sur (25560)

La función BDSUMA utiliza los siguientes argumentos.


Fórmula con función BDSUMA

Llamada 1 Rango de evaluación: la lista de la que se desea sumar.
Llamada 2 Campo: el rótulo de la columna que se va a sumar.
Llamada 3 Criterios: es el rango de celdas que contiene las condiciones.

Detalles de la función

BDSUMA

Volver al principio Volver al principio

Sumar números basándose en varias condiciones con el Asistente para suma condicional

Si desea resumir un rango de celdas basándose en condiciones específicas, puede utilizar el Asistente para suma condicional. Por ejemplo, si la lista contiene los importes de ventas de diferentes vendedores, el programa de complemento (complemento: programa suplementario que agrega funciones o comandos personalizados a Microsoft Office.) Asistente para suma condicional puede ser útil para crear una fórmula que calcule el importe total de las ventas de un vendedor.

  1. Haga clic en el rango de celdas.
  2. En la ficha Fórmulas, en el grupo Soluciones, haga clic en Suma condicional.

Si el comando Suma condicional o la ficha Soluciones no está disponible, deberá cargar el programa de complemento Asistente para suma condicional.

MostrarInstalar y cargar el programa de complemento Asistente para suma condicional

  1. Haga clic en el botón de Microsoft Office Imagen del botón, haga clic en Opciones de Excel y, a continuación, haga clic en la categoría Complementos.
  1. Seleccione Complementos de Excel en el cuadro de lista Administrar y, a continuación, haga clic en Ir.
  2. En la lista Complementos disponibles, active la casilla de verificación Asistente para suma condicional y, a continuación, haga clic en Aceptar.
  1. Siga las instrucciones del Asistente.

 Nota    Las fórmulas creadas por el Asistente para suma condicional son fórmulas de matriz (fórmula de matriz: fórmula que lleva a cabo varios cálculos en uno o más conjuntos de valores y devuelve un único resultado o varios resultados. Las fórmulas de matriz se encierran entre llaves { } y se especifican presionando CTRL+MAYÚS+ENTRAR.). Tras modificar estas fórmulas, se debe presionar CTRL+MAYÚS+ENTRAR para bloquearlas.

Volver al principio Volver al principio

Sumar valores únicos

Para realizar esta tarea, utilice las funciones SUMA, SI y FRECUENCIA.

En el ejemplo siguiente se utiliza:

  • La función FRECUENCIA para identificar los valores únicos. Para la primera aparición de un valor específico, esta función devuelve un número igual al número de apariciones de dicho valor. Para cada aparición del mismo valor después del primero, esta función devuelve un 0 (cero).
  • La función SI para asignar un valor de 1 a cada condición verdadera.
  • La función SUMA para sumar los valores únicos.

Sugerencia    Para ver cómo se evalúa una función paso a paso, seleccione la celda que contiene la fórmula y, a continuación, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en Evaluar fórmula.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
4
5
6
7
8
9
10
A
Datos
986
456
67
1
34
689
456
56
67
Fórmula Descripción (resultado)
=SUMA(SI(FRECUENCIA(A2:A10;A2:A10)>0;A2:A10)) Suma los valores únicos de las celdas A2:A10 (2289)

Detalles de la función

FRECUENCIA

SUMA

SI

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2007