SI

Devuelve un valor si la condición especificada es VERDADERO y otro valor si dicho argumento es FALSO.

Utilice SI para realizar pruebas condicionales en valores y fórmulas.

Sintaxis

SI(prueba_lógica;valor_si_verdadero;valor_si_falso)

Prueba_lógica  es cualquier valor o expresión que pueda evaluarse como VERDADERO o FALSO. Por ejemplo, A10=100 es una expresión lógica; si el valor de la celda A10 es igual a 100, la expresión se evalúa como VERDADERO. De lo contrario, la expresión se evalúa como FALSO. Este argumento puede utilizar cualquier operador de comparación.

Valor_si_verdadero  es el valor que se devuelve si el argumento prueba_lógica es VERDADERO. Por ejemplo, si este argumento es la cadena de texto "Dentro de presupuesto" y el argumento prueba_lógica se evalúa como VERDADERO, la función SI muestra el texto "Dentro de presupuesto". Si el argumento prueba_lógica es VERDADERO y el argumento valor_si_verdadero está en blanco, este argumento devuelve 0 (cero). Para mostrar la palabra VERDADERO, utilice el valor lógico VERDADERO para este argumento. Valor_si_verdadero puede ser otra fórmula.

Valor_si_falso  es el valor que se devuelve si el argumento prueba_lógica es FALSO. Por ejemplo, si este argumento es la cadena de texto "Presupuesto excedido" y el argumento prueba_lógica se evalúa como FALSO, la función SI muestra el texto "Presupuesto excedido". Si el argumento prueba_lógica es FALSO y se omite valor_si_falso, (es decir, después de valor_si_verdadero no hay ninguna coma), se devuelve el valor lógico FALSO. Si prueba_lógica es FALSO y valor_si_falso está en blanco (es decir, después de valor_si_verdadero hay una coma seguida por el paréntesis de cierre), se devuelve el valor 0 (cero). Valor_si_falso puede ser otra fórmula.

Observaciones

Ejemplo 1

El ejemplo puede resultar más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
A
Datos
50
Fórmula Descripción (Resultado)
=SI(A2<=100;"Dentro de presupuesto";"Presupuesto excedido") Si el número anterior es menor o igual que 100, la fórmula muestra "Dentro de presupuesto". De lo contrario, la función mostrará "Presupuesto excedido" (Dentro de presupuesto)
=SI(A2=100;SUMA(B5:B15);"") Si el número anterior es 100, se calcula el rango B5:B15. En caso contrario, se devuelve texto vacío ("") ()

Ejemplo 2

El ejemplo puede resultar más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
4
A B
Gastos reales Gastos previstos
1500 900
500 900
500 925
Fórmula Descripción (Resultado)
=SI(A2>B2;"Presupuesto excedido";"Aceptar") Comprueba si la primera fila sobrepasa el presupuesto (Presupuesto excedido)
=SI(A3>B3;"Presupuesto excedido";"Aceptar") Comprueba si la segunda fila sobrepasa el presupuesto (Aceptar)

Ejemplo 3

El ejemplo puede resultar más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
4
A
Puntuación
45
90
78
Fórmula Descripción (Resultado)
=SI(A2>89,"A",SI(A2>79;"B";SI(A2>69;"C";SI(A2>59;"D";"F")))) Asigna una puntuación de una letra al primer resultado (F)
=SI(A3>89;"A";SI(A3>79;"B";SI(A3>69;"C";SI(A3>59;"D";"F")))) Asigna una puntuación de una letra al segundo resultado (A)
=SI(A4>89;"A";SI(A4>79;"B";SI(A4>69;"C";SI(A4>59;"D";"F")))) Asigna una puntuación de una letra al tercer resultado (C)

En el ejemplo anterior, la segunda instrucción SI representa también el argumento valor_si_falso de la primera instrucción SI. De manera similar, la tercera instrucción SI es el argumento valor_si_falso de la segunda instrucción SI. Por ejemplo, si el primer argumento prueba_lógica (Promedio>89) es VERDADERO, se devuelve el valor "A". Si el primer argumento prueba_lógica es FALSO, se evalúa la segunda instrucción SI y así sucesivamente.

Las letras de puntuación se asignan a números utilizando la siguiente clave.

Si la puntuación es La función devuelve
Mayor que 89 A
De 80 a 89 B
De 70 a 79 C
De 60 a 69 D
Menor que 60 F
 
 
Corresponde a:
Excel 2003