Ocultar valores e indicadores de error en las celdas

Supongamos que las fórmulas de su hoja de cálculo tienen errores que puede prever pero que no necesitan corregirse, aunque le gustaría mejorar la presentación de los resultados. Existen diversas maneras de ocultar valores de error e indicadores de error en las celdas.

Hay muchas razones por las que las celdas devuelven errores. Por ejemplo, la división por 0 no está permitida y si escribe la fórmula =1/0, obtendrá #¡DIV/0!. Los valores de error son #¡DIV/0!, #N/A, #¿NOMBRE?, #¡NULO!, #¡NUM!, #¡REF! y #¡VALOR!.

¿Qué desea hacer?


Dar formato al texto de las celdas que contienen errores para que éstos no se muestren

  1. Seleccione el rango de celdas que contenga el valor de error.
  2. En el grupo Estilos de la ficha Inicio, haga clic en la flecha situada junto a Formato condicional y, a continuación, en Administrar reglas.

Se mostrará el cuadro de diálogo Administrador de reglas de formato condicionales.

  1. Haga clic en Nueva regla.

Aparecerá el cuadro de diálogo Nueva regla de formato.

  1. En Seleccionar un tipo de regla, haga clic en Utilizar una fórmula que determine las celdas para aplicar formato.
  2. En Editar una descripción de regla, en el cuadro de lista Dar formato a los valores donde esta fórmula sea verdadera, escriba la siguiente fórmula:

= ESERROR (referencia)

Donde referencia es una referencia relativa a la celda que contiene el valor de error.

  1. Haga clic en Formato y, a continuación, en la ficha Fuente.
  2. En el cuadro Color, seleccione blanco.

Volver al principio Volver al principio

Mostrar un guión, #N/A o NOD en lugar del valor de error

Para realizar esta tarea, utilice las funciones SI.ERROR y NOD.

Ejemplo

El ejemplo será más fácil de entender si lo copia a una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree una hoja de cálculo o un libro en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave), o en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
A
Datos
10
0
Fórmula Descripción (resultado)
=A2/A3 Da un error (#¡DIV/0!)
=SI.ERROR(A2/A3;"NOD") Devuelve NOD cuando el valor es un error
=SI.ERROR(A2/A3;"-") Devuelve un guión cuando el valor es un error
=SI.ERRORA2/A3,NOD()) Devuelve #N/A cuando el valor es un error

Detalles de la función

SI.ERROR

ND

Volver al principio Volver al principio

Ocultar los valores de error en un informe de tabla dinámica

  1. Haga clic en el informe de tabla dinámica.
  2. En el grupo Opciones de la tabla dinámica de la ficha Opciones, haga clic en la flecha situada junto a Opciones y, a continuación, en Opciones.
  1. Haga clic en la ficha Diseño y formato y siga uno o varios de los procedimientos siguientes:

Cambiar el modo en que se muestran los errores     Active la casilla de verificación Para valores erróneos, mostrar situada bajo Formato. En el cuadro, escriba el valor que desee mostrar en lugar de los errores. Para mostrar los errores como celdas en blanco, elimine los caracteres del cuadro.

Cambiar el modo en que se muestran las celdas vacías     Active la casilla de verificación Para celdas vacías, mostrar. En el cuadro, escriba el valor que desee mostrar en las celdas vacías. Para mostrar celdas en blanco, elimine los caracteres del cuadro. Para mostrar ceros, desactive la casilla de verificación.

Volver al principio Volver al principio

Ocultar indicadores de error en las celdas

Si una celda contiene una fórmula que incumple alguna regla, aparece un triángulo en la esquina superior izquierda de la celda. Puede evitar que se muestren estos indicadores.


Celda con un problema de fórmula

Celda con un problema de fórmula

  1. Haga clic en el botón de Microsoft Office Imagen del botón, haga clic en Opciones de Excel y, a continuación, haga clic en la categoría Fórmulas.
  1. En Comprobación de errores, desactive la casilla de verificación Habilitar comprobación de errores en segundo plano.

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2007