Mostrar u ocultar los valores cero

Puede tener una preferencia personal para mostrar valores cero en una celda o puede utilizar una hoja de cálculo que se adhiera a un conjunto de estándares de formato que requiere que oculte los valores cero. Hay varias maneras de mostrar u ocultar valores cero.

¿Qué desea hacer?


Mostrar u ocultar todos los valores cero en una hoja de cálculo

  1. En el menú Herramientas, haga clic en Opciones y, a continuación, en la pestaña Ver.
  2. Siga uno de estos pasos:
    • Para mostrar valores cero (0) en celdas, active la casilla de verificación Valores cero.
    • Para mostrar valores cero como celdas en blanco, desactive dicha casilla.

Volver al principio Volver al principio

Usar un formato numérico para ocultar los valores cero en las celdas seleccionadas

Siga este procedimiento para ocultar los valores cero en las celdas seleccionadas. Si cambia el valor de una de estas celdas a un valor que no es cero, el formato del valor será similar al formato de número general.

  1. Seleccione las celdas que contengan los valores cero (0) que se desee ocultar.
  2. En el menú Formato, haga clic en Celdas y, a continuación, haga clic en la pestaña Número.
  3. En la lista Categoría, haga clic en Personalizada.
  4. En el cuadro Tipo, escriba 0;-0;;@.

 Notas 

  • Los valores ocultos sólo aparecen en la barra de fórmulas Barra de fórmulas (o en la celda si realizan cambios dentro de la celda) y no se imprimen.
  • Para mostrar nuevamente los valores ocultos, seleccione las celdas, haga clic en el comando Celdas en el menú Formato y, a continuación, haga clic en la pestaña Número. En la lista Categoría, haga clic en General para aplicar el formato de número predeterminado. Para que aparezca de nuevo una fecha o una hora, seleccione el formato de fecha u hora correspondiente en la ficha Número.

Volver al principio Volver al principio

Usar un formato condicional para ocultar los valores cero que devuelve una fórmula

  1. Seleccione la celda que contenga el valor cero (0).
  2. En el menú Formato, haga clic en Formato condicional.
  3. En el cuadro ubicado a la izquierda, haga clic en Valor de la celda.
  4. En el segundo cuadro de la izquierda, haga clic en igual a.
  5. En el cuadro de la derecha, escriba 0.
  6. Haga clic en Formato y, a continuación, en la pestaña Fuente.
  7. En el cuadro Color, seleccione blanco.

Volver al principio Volver al principio

Usar una fórmula para mostrar los ceros como espacios en blanco o guiones

Para realizar esta tarea, use la función SI.

Ejemplo

Posiblemente sea más sencillo comprender el ejemplo si lo copia en una hoja de cálculo en blanco.

Procedimientos para copiar un ejemplo

  1. Cree una hoja de cálculo o un libro en blanco.
  • Seleccione el ejemplo en el tema de Ayuda.
  •  Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  2. Para alternar entre la visualización de los resultados y la visualización de las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o, en el grupo Auditoría de fórmulas de la pestaña Fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
A
Datos
10
10
Fórmula Descripción (resultado)
=A2-A3 El segundo número se resta del primero (0)
=SI(A2-A3=0;"";A2-A3) Devuelve una celda en blanco si el valor es cero (celda en blanco)
=SI(A2-A3=0;"-";A2-A3) Devuelve un guión si el valor es cero (-)

Detalles de la función

SI

Volver al principio Volver al principio

Ocultar los valores cero en un informe de tabla dinámica

  1. Haga clic en el informe.
  2. En la barra de herramientas Tabla dinámica, haga clic en Tabla dinámica y, a continuación, en Opciones de la tabla.
  3. Siga uno o varios de estos procedimientos:

Cambiar el modo en que se muestran errores     Active la casilla de verificación Para valores erróneos, mostrar de Opciones de formato. En el cuadro, escriba el valor que desee mostrar en lugar de los errores. Para mostrar los errores como celdas en blanco, elimine los caracteres del cuadro.

Cambiar el modo en que se muestran celdas vacías     Active la casilla de verificación Para celdas vacías, mostrar. En el cuadro, escriba el valor que desee mostrar en las celdas vacías. Para mostrar celdas en blanco, elimine todos los caracteres del cuadro. Para mostrar ceros, desactive la casilla de verificación.

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2003