Insertar fechas julianas

El término "Fecha juliana" se utiliza a veces para referirse a un formato de fecha que combina el año actual y el número de días desde el principio del año. Por ejemplo, el 1 de enero de 2007 se representa como 2007001 y el 31 de diciembre de 2007 se representa como 2003356. Observe que este formato no se basa en el calendario juliano.

También existe una fecha juliana que suele utilizarse en astronomía, que consiste en un sistema de fechas en serie que comienza el 1 de enero de 4713 a. c.

MostrarEscribir la fecha actual como "fecha juliana"

Utilice las funciones TEXTO, HOY y FECHANUMERO para realizar esta tarea.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
A B
Fórmula Descripción (Resultado)
=TEXTO(HOY() ,"aa")&TEXTO((HOY() -FECHANUMERO("1/1/"&TEXTO(HOY(),"aa"))+1),"000") Fecha actual en formato "juliano", con un año de dos dígitos (Varía)
=TEXTO(HOY() ,"aaaa")&TEXTO((HOY() -FECHANUMERO("1/1/"&TEXTO(HOY(),"aa"))+1),"000") Fecha actual en formato "juliano", con un año de cuatro dígitos (Varía)

 Notas 

  • La fecha actual que se utiliza se toma del reloj del equipo.
  • En las fórmulas anteriores, el año comienza el 1 de enero (1/1). Para convertir las fórmulas y utilizar una fecha inicial diferente, cambie la parte "1/1/" por la fecha que desee.

Detalles de la función

FECHANUMERO

TEXTO

HOY

MostrarConvertir una fecha a "fecha juliana"

Utilice las funciones TEXTO y FECHANUMERO para realizar esta tarea.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
A
Fecha
23.06.07
Fórmula Descripción (Resultado)
=TEXTO(A2,"aa")&TEXTO((A2-FECHANUMERO("1/1/"&TEXTO(A2,"aa"))+1),"000") La fecha anterior en formato "juliano", con un año de dos dígitos (07174)
=TEXTO(A2,"aaaa")&TEXTO((A2-FECHANUMERO("1/1/"&TEXTO(A2,"aa"))+1),"000") La fecha anterior en formato "juliano", con un año de cuatro dígitos (2007174)

 Nota    En la fórmula anterior, el año comienza el 1 de enero (1/1). Para convertir las fórmulas y utilizar una fecha inicial diferente, cambie la parte "1/1/" por la fecha que desee.

Detalles de la función

FECHANUMERO

TEXTO

MostrarConvertir una fecha a la fecha juliana utilizada en astronomía

Esta fórmula sólo funciona en fechas posteriores al 3/1/1901 y en libros que utilizan el sistema de fechas 1900.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
A
Fecha
23.06.07
Fórmula Descripción (Resultado)
=A2+2415018.50 La primera fecha anterior en formato de fecha juliana utilizada en astronomía (2454274.50)

 Nota    Para ver la fecha como un número, seleccione la celda y haga clic en Celdas en el menú Formato. Haga clic en la ficha Número y, a continuación, haga clic en Número del cuadro Categoría.

 
 
Corresponde a:
Excel 2003