Función SUMAR.SI

En este artículo se describe la sintaxis y el uso de la fórmula de la función (función: fórmula ya escrita que toma un valor o valores, realiza una operación y devuelve un valor o valores. Utilice funciones para simplificar y acortar fórmulas en una hoja de cálculo, especialmente aquellas que llevan a cabo cálculos prolongados o complejos.) SUMAR.SI en Microsoft Office Excel.

Descripción

La función SUMAR.SI sirve para sumar los valores en un rango (rango: dos o más celdas de una hoja. Las celdas de un rango pueden ser adyacentes o no adyacentes.) que cumple los criterios que se especifican. Por ejemplo, supongamos que en una columna que contiene números, desea sumar sólo los valores que son mayores que 5. Puede usar la siguiente fórmula:

=SUMAR.SI(B2:B25,">5")

En este ejemplo, los criterios se aplican a los mismos valores que se están sumando. Si lo desea, puede aplicar los criterios a un rango y sumar los valores correspondientes en un rango distinto. Por ejemplo, la fórmula =SUMAR.SI(B2:B5, "Juan", C2:C5) suma sólo los valores del rango C2:C5, donde las celdas correspondientes al rango B2:B5 son iguales a "Juan."

 Nota   Para sumar las celdas en función de criterios múltiples, vea la función SUMAR.SI.CONJUNTO.

Sintaxis

SUMIF(range, criteria, [sum_range])

La sintaxis de la función SUMAR.SI cuenta con los argumentos (argumento: valor que proporciona información a una acción, un evento, un método, una propiedad, una función o un procedimiento.) siguientes:

  • rango    Obligatorio. El rango de celdas que se desea evaluar según los criterios especificados. Las celdas de cada rango deben ser números, o bien nombres, matrices o referencias que contengan números. Los valores en blanco y los de texto no se tienen en cuenta.
  • criterios    Obligatorio. El criterio en forma de número, expresión o texto, que determina las celdas que se van a sumar. Por ejemplo, los criterios pueden expresarse como 32, ">32", B5, 32, "32", "manzanas" u HOY().

 Importante   Cualquier criterio de texto o cualquier criterio que incluya los símbolos lógicos o matemáticos debe estar entre comillas dobles ("). Si el criterio es numérico, las comillas dobles no son obligatorias.

  • rango_suma    Opcional. Las celdas reales para agregar, si desea agregar celdas a las ya especificadas en el argumento rango. Si se omite el argumento rango_suma, Excel agrega las celdas que están especificadas en el argumento rango (las mismas celdas a las que se aplica los criterios).

 Notas 

  • No es necesario que rango_suma tenga el mismo tamaño y forma que el argumento rango. Las celdas reales que se deben sumar se determinan usando la celda superior del extremo izquierdo del argumento rango_suma como la celda inicial e incluye las celdas que corresponden con el tamaño y la forma del argumento rango. Por ejemplo:
Si rango es y rango_suma es las celdas reales serán
A1:A5 B5:B15 B5:B15
A1:A5 B1:B3 B5:B15
A1:B4 C1:D4 C1:D4
A1:B4 C1:C2 C1:D4
  • Se pueden usar los caracteres comodín signo de interrogación (?) y asterisco (*)  como el argumento criterios. El signo de interrogación corresponde a cualquier carácter único y el asterisco equivale a cualquier secuencia de caracteres. Si desea buscar un signo de interrogación o un asterisco reales, escriba una tilde (~) antes del carácter.

Ejemplo 1

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo se copia un ejemplo?

  • Seleccione el ejemplo de este artículo.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 
1
2
3
4
5
6

7

8


9


10
A B C
Valor de propiedad Comisión Datos
100.000 7.000 250.000
200.000 14.000
300.000 21.000
400.000 28.000
Fórmula Descripción Resultado
=SUMAR.SI(A2:A5;">160000";B2:B5) Suma las comisiones de los valores de propiedad superiores a 160.000 (900.000) 63.000
=SUMAR.SI(A2:A5;">160000") Suma los valores de propiedad superiores a 160.000. 900.000
=SUMAR.SI(A2:A5,300000,B2:B3) Suma las comisiones de los valores de propiedad igual a 300.000. 21.000
=SUMAR.SI(A2:A5,">" & C2,B2:B3) Suma las comisiones de los valores de propiedad superiores al valor en C2. 49.000

Ejemplo 2

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo se copia un ejemplo?

  • Seleccione el ejemplo de este artículo.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  • Presione CTRL+C.
  • En Excel, cree una hoja de cálculo o un libro en blanco.
  • En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  • Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 
1
2
3
4
5
6
7
8

9

10


11


12
A B C
Categoría Alimentos Ventas
Verduras Tomates 2.300
Verduras Apio 5.500
Frutas Naranjas 800
Manteca 400
Verduras Zanahorias 4.200
Frutas Manzanas 1.200
Fórmula Descripción Resultado
=SUMAR.SI(A2:A7,"Frutas",C2:C7) Suma de las ventas de todos los alimentos en la categoría "Frutas". 2.000
=SUMAR.SI(A2:A7,"Verduras",C2:C7) Suma de las ventas de todos los alimentos en la categoría "Verduras". 12.000
=SUMAR.SI(B2:B7,"*s",C2:C7) Suma de las ventas de todos los alimentos que terminan en "s" (Tomates, Naranjas y Manzanas). 4.300
=SUMAR.SI(A2:A7,"",C2:C7) Suma de las ventas de todos los alimentos que no tienen una categoría especificada. 400
 
 
Corresponde a:
Excel 2007