Función SI.ERROR

Devuelve un valor que se especifica si una fórmula lo evalúa como un error; de lo contrario, devuelve el resultado de la fórmula. Utilice la función SI.ERROR para interceptar y controlar errores en una fórmula (fórmula: secuencia de valores, referencias de celda, nombres, funciones u operadores de una celda que producen juntos un valor nuevo. Una formula comienza siempre con el signo igual (=).).

Sintaxis

SI.ERROR(valor,valor_si_error)

Valor     es el argumento en el que se busca un error.

Valor_si_error     es el valor que se devuelve si la fórmula lo evalúa como error. Se evalúan los tipos siguientes de error: #N/A, #¡VALOR!, #¡REF!, #¡DIV/0!, #¡NUM!, #¿NOMBRE? o #¡NULO!

Observaciones

  • Si valor o valor_si_error están en una celda vacía, SI.ERROR los trata como un valor de cadena vacía ("").
  • Si valor es una fórmula de matriz, SI.ERROR devuelve una matriz de resultados para cada celda del rango especificado en el valor. Vea el segundo ejemplo siguiente.

Ejemplo: Interceptar errores de división utilizando una fórmula regular

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
4
5
6
7
8
9
10
A B
Cuota Unidades vendidas
210 35
55 0
  23
Fórmula Descripción (resultado)
=SI.ERROR(A2/B2; "Error en el cálculo") Comprueba si hay un error en la fórmula en el primer argumento (divide 210 por 35), no encuentra ningún error y devuelve los resultados de la fórmula (6).
=SI.ERROR(A3/B3; "Error en el cálculo") Comprueba si hay un error en la fórmula en el primer argumento (divide 55 por 0), encuentra un error de división por 0 y devuelve valor_si_error (Error en el cálculo).
=SI.ERROR(A4/B4; "Error en el cálculo") Comprueba si hay un error en la fórmula en el primer argumento (divide "" por 23), no encuentra ningún error y devuelve los resultados de la fórmula (0).

Ejemplo: Interceptar errores de división utilizando una fórmula de matriz

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
4
5
6
7
8
9
A B C
Cuota Unidades vendidas Relación
210 35 =SI.ERROR(A2:A4/B2:B4; "Error en el cálculo")
55 0
  23
Fórmula Descripción (resultado)
=C2 Comprueba si hay un error en la fórmula en el primer argumento del primer elemento de la matriz (A2/B2 o divide 210 por 35), no encuentra ningún error y devuelve los resultados de la fórmula (6).
=C3 Comprueba si hay un error en la fórmula en el primer argumento del segundo elemento de la matriz (A3/B3 o divide 55 por 0), encuentra un error de división por 0 y devuelve valor_si_error (Error en el cálculo).
=C4 Comprueba si hay un error en la fórmula en el primer argumento del tercer elemento de la matriz (A4/B4 o divide "" por 23), no encuentra ningún error y devuelve los resultados de la fórmula (0).

 Nota   La fórmula del ejemplo debe especificarse como fórmula de matriz. Después de copiar el ejemplo en una hoja de cálculo en blanco, seleccione el rango C2:C4, presione F2 y, a continuación, presione CTRL+MAYÚS+ENTRAR.

 
 
Corresponde a:
Excel 2007