Evaluar una fórmula anidada paso a paso

A veces resulta difícil comprender cómo se calcula una fórmula (fórmula: secuencia de valores, referencias de celda, nombres, funciones u operadores de una celda que producen juntos un valor nuevo. Una formula comienza siempre con el signo igual (=).) anidada porque hay diversos cálculos intermedios y pruebas lógicas. Sin embargo, mediante el cuadro de diálogo Evaluar fórmula, puede ver las diferentes partes de una fórmula anidada en el orden en que la fórmula se calcula. Por ejemplo, la fórmula =SI(PROMEDIO(F2:F5)>50;SUMA(G2:G5);0) es más fácil de entender cuando se pueden ver los siguientes resultados intermedios:

Pasos que se muestran en el cuadro de diálogo Descripción
=SI(PROMEDIO(F2:F5)>50;SUMA(G2:G5);0) Se muestra inicialmente la fórmula anidada. La función PROMEDIO y la función SUMA se anidan dentro de la función SI.
=SI(40>50;SUMA(G2:G5);0) El rango de celdas F2:F5 contiene los valores 55, 35, 45 y 25 y, por lo tanto, el resultado de la función PROMEDIO(F2:F5) es 40.
=SI(Falso;SUMA(G2:G5);0) 40 no es mayor que 50, por tanto, la expresión del primer argumento de la función SI (el argumento prueba_lógica) es falsa.
0 La función SI devuelve el valor del tercer argumento (el argumento valor_si_falso). La función SUMA no se evalúa porque es el segundo argumento de la función SI (argumento valor_si_verdadero) y solamente se devuelve cuando la expresión es verdadera.
  1. Seleccione la celda que desee evaluar. Sólo se puede evaluar una celda a la vez.
  2. En la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en Evaluar fórmula.

Imagen de cinta de opciones de Excel

  1. Haga clic en Evaluar para examinar el valor de la referencia subrayada. El resultado de la evaluación se muestra en cursiva.

Si la parte subrayada de la fórmula es una referencia a otra fórmula, haga clic en Paso a paso para entrar para mostrar la otra fórmula en el cuadro Evaluación. Haga clic en Paso a paso para salir para volver a la celda y fórmula anteriores.

 Nota   El botón Paso a paso para entrar no está disponible para una referencia la segunda vez que ésta aparece en la fórmula, ni si la fórmula hace referencia a una celda de un libro distinto.

  1. Continúe hasta que se hayan evaluado todas las partes de la fórmula.
  2. Para ver de nuevo la evaluación, haga clic en Reiniciar.

Para finalizar la evaluación, haga clic en Cerrar.

 Notas 

  • Algunas de las partes de las fórmulas que utilizan las funciones SI y ELEGIR no se evalúan, y aparece #N/A en el cuadro Evaluación.
  • Si una referencia está en blanco, aparece el valor cero (0) en el cuadro Evaluación.
  • Las siguientes funciones se actualizan cada vez que se cambia la hoja de cálculo y pueden provocar que Evaluar fórmula proporcione resultados distintos a los que aparecen en las celdas: ALEATORIO, AREAS, INDICE, DESREF, CELDA, INDIRECTO, FILAS, COLUMNAS, AHORA, HOY, ALEATORIO.ENTRE.
 
 
Corresponde a:
Excel 2007