ELEGIR

Utiliza el argumento núm_índice para devolver un valor de una lista de argumentos de valores. Utilice ELEGIR para seleccionar uno de los 29 valores posibles a partir del rango del argumento índice. Por ejemplo, si valor1 a valor 7 son los días de la semana, ELEGIR devuelve uno de los días cuando se utiliza un número entre 1 y 7 como argumento núm_índice .

Sintaxis

ELEGIR(núm_índice;valor1;valor2;...)

Núm_índice     especifica el argumento de valor que se selecciona. El argumento núm_índice debe ser un número entre 1 y 29, o bien una fórmula o referencia a una celda que contenga un número entre 1 y 29.

  • Si núm_índice es 1, ELEGIR devuelve valor1; si es 2, ELEGIR devuelve valor2 y así sucesivamente.
  • Si núm_índice es menor que 1 o mayor que el número del último valor de la lista, ELEGIR devuelve el valor de error #¡VALOR!
  • Si núm_índice es una fracción, se trunca al entero inferior antes de ser utilizada.

Valor1, valor2,...     son de 1 a 29 argumentos de valores entre los cuales ELEGIR selecciona un valor o una acción que se ejecuta basándose en el argumento núm_índice. Los argumentos pueden ser números, referencias a celdas, nombres definidos, fórmulas, funciones o texto.

Observaciones

Por ejemplo, la fórmula:

=SUMA(ELEGIR(2;A1:A10;B1:B10;C1:C10))

evalúa:

=SUMA(B1:B10)

que después devuelve un valor basado en los valores del rango B1:B10.

La función ELEGIR se evalúa primero, devolviendo la referencia B1:B10. La función SUMA se evalúa a continuación utilizando B1:B10, que es el resultado de la función ELEGIR, como su argumento.

Ejemplo 1

El ejemplo puede resultar más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
4
5
A B
Datos Datos
Clavos
Tornillos
Tuercas
Terminado Pernos
Fórmula Descripción (Resultado)
=ELEGIR(2;A2;A3;A4;A5) Valor del segundo argumento A3 (2º)
=ELEGIR(4;B2;B3;B4;B5) Valor del cuarto argumento B5 (Pernos)

Ejemplo 2

El ejemplo puede resultar más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
4
5
A
Datos
23
45
12
10
Fórmula Descripción (Resultado)
=SUMA(A2:ELEGIR(2;A3;A4;A5)) Suma el rango A2:A4 (80)
 
 
Corresponde a:
Excel 2003