Crear una referencia externa (enlace) a un rango de celdas de otro libro

Puede hacer referencia al contenido de las celdas de otro libro mediante una referencia externa. Una referencia externa (también denominada vínculo) es una referencia a una celda o a un rango de celdas de una hoja de cálculo de otro libro de Excel, o una referencia a un nombre definido en otro libro. Puede hacer referencia a rangos de celdas específicas, a un nombre específico de los rangos de celdas, o bien definir un nombre para la referencia externa.

¿Qué desea hacer?


Obtenga más información sobre referencias externas

Aunque las referencias externas se parecen a las referencias de celdas, existen diferencias importantes. Las referencias externas se usan al trabajar con cantidades grandes de datos o fórmulas complejas que se encuentran extendidas por varios libros. Se crean de modo distinto y aparecen de manera distinta en una celda o en la barra de fórmulas.

Dónde pueden utilizarse eficazmente las referencias externas

Las referencias externas son especialmente útiles cuando no resulta práctico mantener juntos en el mismo libro los modelos de hoja de cálculo grandes.

Métodos para crear referencias externas

Si utiliza una referencia de celda para crear una referencia externa, también puede aplicar fórmulas a la información. Al cambiar entre los distintos tipos de referencias de celda, puede controlar además las celdas con las que se establecen vínculos si mueve la referencia externa. Por ejemplo, si utiliza una referencia relativa, al mover la referencia externa, la celda o celdas con las que se establece el vínculo cambian para reflejar su nueva posición en la hoja de cálculo.

Cuando se crea una referencia externa de un libro a otro, debe utilizar un nombre para hacer referencia a las celdas con las que se establece el vínculo. Puede crear una referencia externa utilizando un nombre que ya se haya definido, o puede definir el nombre cuando cree la referencia externa. Este nombre permite recordar más fácilmente el contenido de las celdas con las que se establece el vínculo. Las referencias externas que utilizan nombres definidos no cambian cuando se mueven, ya que un nombre hace referencia a una celda o rango de celdas específico. Si desea utilizar una referencia externa con un nombre definido que cambie al moverse, puede cambiar el nombre que se utiliza en la referencia externa o puede cambiar las celdas a las que hace referencia el nombre.

Aspecto de una referencia externa a otro libro

Las fórmulas con referencias externas a otros libros se muestran de dos maneras, en función de si el libro de origen, el que proporciona datos a la fórmula, se encuentra abierto o cerrado.

Cuando el libro de origen está abierto, la referencia externa incluye el nombre del libro entre corchetes ([ ]), seguido del nombre de la hoja de cálculo, un signo de exclamación (!) y las celdas de las que depende la fórmula. Por ejemplo, la siguiente fórmula suma las celdas C10:C25 del libro Presupuesto.xls.

Referencia externa
=SUMA([Presupuesto.xlsx]Anual!C10:C25)

Si el libro de origen está cerrado, la referencia externa incluye toda la ruta de acceso.

Referencia externa
=SUMA('C:\Informes\[Presupuesto.xlsx]Anual'!C10:C25)

 Nota   Si el nombre de la otra hoja de cálculo o del otro libro contiene caracteres no alfabéticos, se deberá poner el nombre (o la ruta de acceso) entre comillas sencillas.

Las fórmulas vinculadas con un nombre (nombre: palabra o cadena de caracteres que representa una celda, rango de celdas, fórmula o valor constante. Utilice nombres fáciles de entender, como Productos, para referirse a rangos difíciles de entender, como Ventas!C20:C30.) definido en otro libro usan e nombre del libro seguido de un signo de exclamación (!) y el nombre. Por ejemplo, la siguiente fórmula suma las celdas del rango Ventas del libro Presupuesto.xlsx.

Referencia externa
=SUMA(Presupuesto.xlsx!Ventas)

Volver al principio Volver al principio

Crear una referencia externa entre celdas de libros distintos

  1. Abra el libro que contendrá la referencia externa (el libro de destino (archivo de destino: archivo donde se inserta un objeto vinculado o incrustado. El archivo de origen contiene la información que se utiliza para crear el objeto. Cuando se cambia la información de un archivo de destino, no se actualiza en el archivo de origen.)) y el libro que contiene los datos con los que desea establecer el vínculo (el libro de origen).
  2. En el libro de origen, haga clic en Guardar Imagen del botón en la barra de herramientas de acceso rápido.
  3. Seleccione la celda o las celdas en las que desea crear la referencia externa.
  4. Escriba = (signo de igual). Si desea ejecutar cálculos o funciones en el valor de la referencia externa, escriba el operador (operador: signo o símbolo que especifica el tipo de cálculo que se debe llevar a cabo en una expresión. Hay operadores matemáticos, comparativos, lógicos y referenciales.) o la función que debe preceder a la referencia externa.
  5. Cambie al libro de origen y, a continuación, haga clic en la hoja de cálculo que contiene las celdas con las que desea establecer el vínculo.
  6. Seleccione la celda o las celdas con las que desee establecer el vínculo.
  7. Vuelva al libro de destino y observe que Excel agrega la referencia al libro de origen y a las celdas que seleccionó en el paso anterior.
  8. También puede modificar o cambiar la fórmula en la hoja de cálculo de destino.
  9. Presione CTRL+MAYÚS+ENTRAR.

Volver al principio Volver al principio

Crear una referencia externa a un nombre definido en otro libro

  1. Abra el libro que contendrá la referencia externa (el libro de destino) y el libro que contiene los datos con los que desea establecer el vínculo (el libro de origen).
  2. En el libro de origen, haga clic en Guardar Imagen del botón en la barra de herramientas de acceso rápido.
  3. Seleccione la celda o las celdas en las que desea crear la referencia externa.
  4. Escriba = (signo de igual). Si desea ejecutar cálculos o funciones en el valor de la referencia externa, escriba el operador o la función que debe preceder a la referencia externa.
  5. En la ficha Vista, en el grupo Ventana, haga clic en Cambiar ventanas, en el libro de origen y después en la hoja de cálculo que contiene las celdas con las que desea establecer el vínculo.

Imagen de cinta de opciones de Excel

  1. Presione F3 y, a continuación, seleccione el nombre con el que desea establecer el vínculo.

Volver al principio Volver al principio

Definir un nombre que contenga una referencia externa a las celdas de otro libro

  1. Abra el libro de destino y el libro de origen.
  2. En el libro de destino, en la ficha Fórmulas, en el grupo Nombres definidos, haga clic en Definir nombre.

Imagen de cinta de opciones de Excel

  1. En el cuadro de diálogo Nombre nuevo, en el cuadro Nombre, escriba un nombre para el rango.
  2. Borre el contenido del cuadro Se refiere a y mantenga el cursor dentro del cuadro.

Si el nombre contiene una fórmula, escríbala y, a continuación, sitúe el cursor en la posición donde desee colocar la referencia externa. Por ejemplo, escriba =SUMA() y sitúe el cursor entre los paréntesis.

  1. En la ficha Vista, en el grupo Ventana, haga clic en Cambiar ventanas, en el libro de origen y después en la hoja de cálculo que contiene las celdas con las que desea establecer el vínculo.

Imagen de cinta de opciones de Excel

  1. Seleccione la celda o el rango de celdas con las que desea establecer el vínculo.
  2. En el cuadro de diálogo Nombre nuevo, haga clic en Aceptar.

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2007