Crear fórmulas condicionales utilizando la función SI

MostrarPara un resultado que es un valor lógico (VERDADERO o FALSO)

Utilice las funciones Y, O y NO y los operadores (operador: signo o símbolo que especifica el tipo de cálculo que se debe llevar a cabo en una expresión. Hay operadores matemáticos, comparativos, lógicos y referenciales.) para realizar esta tarea.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
4
A
Datos
15
9
8
Fórmula Descripción (Resultado)
=Y(A2>A3, A2<A4) ¿Es 15 mayor que 9 y menor que 8? (FALSO)
=O(A2>A3, A2<A4) ¿Es 15 mayor que 9 o menor que 8? (VERDADERO)
=NO(A2+A3=24) 15 más 9 no es igual que 24 (FALSO)

Detalles de la función

Y

O

NO

MostrarPara obtener un resultado que es otro cálculo o cualquier otro valor distinto de VERDADERO o FALSO

Utilice las funciones SI, Y y O para realizar esta tarea.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
4
A
Datos
15
9
8
Fórmula Descripción (Resultado)
=SI(A2=15, "Correcto", "Incorrecto") Si el valor de la celda A2 es igual a 15, devuelve "Correcto". (Correcto)
=SI(Y(A2>A3, A2<A4), "Correcto", "Incorrecto") Si 15 es mayor que 9 y menor que 8, devuelve "Correcto". (Incorrecto)
=SI(O(A2>A3, A2<A4), "Correcto", "Incorrecto") Si 15 es mayor que 9 o menor que 8, devuelve "Correcto". (Correcto)

La función SI utiliza los siguientes argumentos.

Fórmula con la función SI

Fórmula con la función SI

Llamada 1   prueba_lógica: la condición que se desea comprobar

Llamada 2   valor_si_verdadero: valor que se devolverá si la condición se cumple

Llamada 3   valor_si_falso: valor que se devolverá si la condición no se cumple

Detalles de la función

Y

O

SI

 
 
Corresponde a:
Excel 2003