Crear fórmulas condicionales

Comprobar si las condiciones son verdaderas o falsas y realizar comparaciones lógicas entre expresiones son elementos comunes de varias tareas. Para crear fórmulas condicionales, puede utilizar las funciones Y, O, NO, y SI.

La función SI utiliza los siguientes argumentos.


Fórmula con la función SI

Fórmula con la función SI

Llamada 1  prueba_lógica: condición que se desea comprobar.

Llamada 2  valor_si_verdadero: valor que se devolverá si la condición se cumple.

Llamada 3  valor_si_falso: valor que se devolverá si la condición no se cumple.


¿Qué desea hacer?


Crear una fórmula condicional que devuelva un valor lógico (VERDADERO O FALSO)

Para realizar esta tarea, utilice las funciones Y, O y NO, así como los operadores (operador: signo o símbolo que especifica el tipo de cálculo que se debe llevar a cabo en una expresión. Hay operadores matemáticos, comparativos, lógicos y referenciales.) correspondientes.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
4
A
Datos
15
9
8
Engranajes
Aparatos mecánicos
Fórmula Descripción (resultado)
=Y(A2>A3; A2<A4) ¿Es 15 mayor que 9 y menor que 8? (FALSO)
=O(A2>A3; A2<A4) ¿Es 15 mayor que 9 o menor que 8? (VERDADERO)
=NO(A2+A3=24) 15 más 9 no es igual a 24 (FALSO)
=NO(A5="Engranajes") ¿No es A5 igual a "Engranajes"? (FALSO)
=O(A5<>"Engranajes";A6 = "Aparatos mecánicos") ¿No es A5 igual a "Engranajes" o A6 igual a "Aparatos mecánicos"? (VERDADERO)

Detalles de la función

Y

O

NO

Volver al principio Volver al principio

Crear una fórmula condicional que devuelva otro cálculo o valores distintos a VERDADERO o FALSO

Para realizar esta tarea, utilice las funciones SI, Y y O.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.
 
1
2
3
4
A
Datos
15
9
8
Engranajes
Aparatos mecánicos
Fórmula Descripción (resultado)
=SI(A2=15; "Correcto"; "Incorrecto") Si el valor de la celda A2 es igual a 15, devuelve "Correcto". (Correcto)
=SI(A2<>15; "Correcto"; "Incorrecto") Si el valor de la celda A2 no es igual a 15, se devuelve "Correcto". (Incorrecto)
=SI(NO(A2<=15); "Correcto"; "Incorrecto") Si el valor de la celda A2 no es menor o igual a 15, se devuelve "Correcto". (Incorrecto)
=SI(A5<>"ENGRANAJES"; "Correcto"; "Incorrecto") Si el valor de la celda A5 no es igual a "ENGRANAJES", se devuelve "Correcto". (Incorrecto)
=SI(Y(A2>A3; A2<A4); "Correcto"; "Incorrecto") Si 15 es mayor que 9 y menor que 8, devuelve "Correcto". (Incorrecto)
=SI(Y(A2<>A3; A2<>A4); "Correcto"; "Incorrecto") Si 15 no es igual a 9 y 15 no es igual a 8, se devuelve "Correcto". (Correcto)
=SI(O(A2>A3; A2<A4); "Correcto"; "Incorrecto") Si 15 es mayor que 9 o menor que 8, devuelve "Correcto". (Correcto)
=SI(O(A5<>"Engranajes"; A6<>"Aparatos mecánicos"); "Correcto"; "Incorrecto") Si el valor de la celda A5 no es igual a "Engranajes" o el valor de la celda A6 no es igual a "Aparatos mecánicos", se devuelve "Correcto". (Incorrecto)
=SI(O(A2<>A3; A2<>A4); "Correcto"; "Incorrecto") Si 15 no es igual a 9 ó 15 no es igual a 8, se devuelve "Correcto". (Correcto)

Detalles de la función

SI

Y

O

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2007