Corregir un error #¡DIV/0!

Microsoft Excel muestra el error #¡DIV/0! cuando un número se divide por cero (0) o por una celda que no contiene ningún valor.

Síntoma

Excel muestra el error #¡DIV/0! en una o más celdas de una hoja de cálculo.

Causas

  • Se ha escrito una fórmula que realiza divisiones explícitas por cero (0), por ejemplo, =5/0.
  • Se ha usado una referencia a una celda en blanco o a una celda que contiene un cero como divisor en una fórmula o función que realiza divisiones.
  • Se ha ejecutado una macro que usa una función o fórmula que devuelve el error #¡DIV/0!

Ejemplo

Al copiar los datos de ejemplo en una hoja de cálculo en blanco, las fórmulas de las celdas A3, A4 y A5 devuelven un error #¡DIV/0!

Mostrar¿Cómo se copia un ejemplo?

  1. Seleccione el ejemplo de este artículo. Si va a copiar el ejemplo en Excel Web App, copie y pegue las celdas de una en una.

 Importante   No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. Cree un libro o una hoja de cálculo en blanco.
  3. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V. Si está trabajando en Excel Web App, repita la acción de copiar y pegar para cada celda del ejemplo.

 Importante   Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  1. Para alternar entre la visualización de los resultados y la visualización de las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o, en el grupo Auditoría de fórmulas de la pestaña Fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.


 
1
2
3
4
5
A
1
0
=A1/0
=A1/A2
=COCIENTE(A1;A2)

Solución

  • Compruebe que el divisor en la función o fórmula no sea ni cero (0) ni esté en blanco.
  • Cambie la referencia de celda de la fórmula a otra celda que no contenga ni cero ni un valor en blanco.
  • Escriba el valor #N/A en la celda a la que se hace referencia como divisor de la fórmula.

Al escribir el valor #N/A, el resultado de la fórmula cambiará de #¡DIV/0! a #N/A para indicar que el valor del divisor no está disponible.

  • Impida que el valor de error se muestre mediante la función de hoja de cálculo SI. A continuación, puede mostrar 0 o cualquier otra cadena como resultado.

Por ejemplo, si la fórmula que produce el error es =A1/A2, use =SI(A2=0;"";A1/A2) para devolver una cadena vacía, o bien =SI(A2=0;0;A1/A2) para devolver 0.

 
 
Corresponde a:
Excel 2010