Corregir errores comunes en las fórmulas

Al igual que un corrector gramatical, Microsoft Office Excel emplea determinadas reglas para comprobar si hay errores en las fórmulas. Estas reglas no garantizan que la hoja de cálculo no tenga ningún error, pero ayudan en gran medida a encontrar los errores más comunes. Se pueden activar y desactivar individualmente. Los dos métodos empleados a continuación tienen las mismas opciones.

Los errores se pueden revisar de dos formas: de uno en uno, como con el corrector ortográfico, o inmediatamente en la hoja de cálculo mientras trabaja. Cuando se detecta un error, aparece un triángulo en la esquina superior izquierda de la celda. Ambos métodos presentan las mismas opciones.


Celda con un problema de fórmula

Celda con un error de fórmula

Puede solucionar el error utilizando las opciones que aparecen u omitirlo. Si lo omite, ya no volverá a aparecer en las comprobaciones de errores subsiguientes. Sin embargo, todos los errores que haya omitido se pueden restablecer para que vuelvan a mostrarse.

¿Qué desea hacer?


Cambiar los errores comunes que comprobará Excel

  1. Haga clic en el botón de Microsoft Office Imagen del botón, haga clic en Opciones de Excel y, a continuación, haga clic en la categoría Fórmulas.
  1. Active o desactive las casillas de verificación que desee en la sección Excel muestra un error cuando.

MostrarLas celdas contienen fórmulas que producen un error

La fórmula no utiliza la sintaxis, los argumentos (argumento: valores que utiliza una función para llevar a cabo operaciones o cálculos. El tipo de argumento que utiliza una función es específico de esa función. Los argumentos más comunes que se utilizan en las funciones son números, texto, referencias de celda y nombres.) o los tipos de datos que esperaba. Los valores de error son #¡DIV/0!, #N/A, #¿NOMBRE?, #¡NULO!, #¡NUM!, #¡REF! y #¡VALOR!. Cada valor de error tiene distintas causas y se resuelve de modo diferente.

 Nota   Si especifica un valor de error directamente en una celda, no se marcará como error.

MostrarLas celdas con formato de texto contienen años representados como 2 dígitos

La celda contiene una fecha de texto en la que el siglo se puede interpretar incorrectamente si se utiliza en fórmulas. Por ejemplo, la fecha de la fórmula =AÑO("1/1/31") podría ser 1931 o 2031. Utilice esta regla para comprobar fechas de texto ambiguas.

MostrarLos números tienen formato de texto o están precedidos por un apóstrofo

La celda contiene números guardados como texto. Suelen proceder de datos importados de otros orígenes. Los números guardados como texto pueden ocasionar cambios inesperados en la forma de ordenar; es preferible convertirlos a números.

MostrarUna fórmula es incoherente con otras fórmulas en la región

La fórmula no coincide con el patrón de las demás fórmulas cercanas. En muchos casos, las fórmulas adyacentes a otras sólo se diferencian en las referencias empleadas. Por ejemplo, la fórmula =SUMA(A10:F10) se anotaría porque las fórmulas adyacentes cambian en una fila, y ésta cambia en 8 filas.

Fórmulas
=SUMA(A1:F1)
=SUMA(A2:F2)
=SUMA(A10:F10)
=SUMA(A4:F4)

Si las referencias utilizadas en una fórmula no son coherentes con las de las fórmulas adyacentes, se anotará el error.

MostrarUna fórmula omite las celdas de una región

La fórmula puede no incluir una referencia correcta. Si una fórmula hace referencia a un rango de celdas y se agregan celdas debajo y a la derecha del mismo, las referencias pueden dejar de ser correctas. La fórmula no siempre actualiza automáticamente su referencia para incluir las nuevas celdas. Esta regla compara la referencia de una celda con las celdas adyacentes. Si las celdas adyacentes contienen más números (no son celdas en blanco), entonces se anota el error.

Por ejemplo, la fórmula =SUMA(A2:A4) se anotaría con esta regla, puesto que las celdas A5, A6 y A7 son adyacentes y contienen datos.

Factura
15.000
9.000
8.000
20.000
5.000
22.500
=SUMA(A2:A4)

MostrarLas celdas desbloqueadas contienen fórmulas

La fórmula no está bloqueada para protección. De manera predeterminada, las celdas están bloqueadas para protección. Cuando una fórmula está protegida, no se puede modificar sin desprotegerla. Asegúrese de que no desea que la celda esté protegida. La protección de las celdas que contienen fórmulas impide que se modifiquen y puede ayudar a evitar futuros errores.

MostrarUna fórmula se refiere a celdas vacías

La fórmula contiene una referencia a una celda vacía. Esto puede dar lugar a resultados no deseados, como en el siguiente ejemplo.

Suponga que desea obtener el promedio de los números indicados a continuación. Si la tercera celda hacia abajo está en blanco, el resultado es 22,75. Si la tercera celda hacia abajo contiene 0, el resultado es 18,2.

Datos
24
12
45
10
Fórmula
=PROMEDIO(A2:A6)

MostrarLos datos incluidos en una tabla no son válidos

Error de validación en una tabla. Compruebe la configuración de validación de la celda haciendo clic en el botón agrupado Validación de datos del grupo Herramientas de datos de la ficha Datos.

MostrarFórmula de columna calculada incoherente en tablas

Una columna calculada puede incluir fórmulas que son diferentes de la fórmula de columna que crea una excepción. Las excepciones de columna calculada se crean al realizar las acciones siguientes:

  • Escribir datos que no son fórmulas en una celda de columna calculada.
  • Escribir una fórmula en una celda de columna calculada y, a continuación, hacer clic en el botón DeshacerImagen del botón de la Barra de herramientas de acceso rápido.
  • Escribir una nueva fórmula en una columna calculada que ya contiene una o varias excepciones.
  • Copiar datos en la columna calculada que no coinciden con la fórmula de columna calculada.

 Nota   Si los datos copiados contienen una fórmula, ésta sobrescribirá los datos de la columna calculada.

  • Mover o eliminar una celda de otra área de hoja de cálculo a la que hace referencia una de las filas de una columna calculada.

Volver al principio Volver al principio

Corregir los errores comunes de las fórmulas de uno en uno, como con un corrector ortográfico

Si la hoja de cálculo ya se revisó previamente para buscar errores y éstos no se tuvieron en cuenta, los errores no aparecerán hasta que se restablezcan los errores omitidos.

  1. Seleccione la hoja de cálculo cuyos errores desee revisar.
  2. Si la hoja de cálculo se calcula manualmente, presione F9 para actualizarla.
  3. On the En el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón de grupo Comprobación de errores.

Imagen de cinta de opciones de Excel

Aparece el cuadro de diálogo Comprobación de errores.

  1. Si ha omitido errores anteriormente, puede volver a comprobarlos.

MostrarCómo restablecer errores omitidos

  1. Haga clic en Opciones.
  2. En la sección Comprobación de errores, haga clic en Restablecer errores omitidos.
  3. Haga clic en Aceptar.
  4. Haga clic en Reanudar.
  1. Coloque el cuadro de diálogo Comprobación de errores justo debajo de la barra de fórmulas (barra de fórmulas: barra de la parte superior de la ventana de Excel que se utiliza para escribir o editar valores o fórmulas en celdas o gráficos. Muestra la fórmula o el valor constante almacenado en la celda activa.)Barra de fórmulas. La barra de fórmulas es el lugar más adecuado para realizar cambios cuando se utiliza la herramienta de comprobación de errores.
  2. Haga clic en un botón situado a la derecha del cuadro de diálogo. Las opciones son distintas para cada tipo de error.

Si hace clic en Omitir error, se marcará el error para omitirlo en las revisiones subsiguientes.

  1. Haga clic en Siguiente.
  2. Continúe hasta finalizar la revisión de errores.

Volver al principio Volver al principio

Marcar los errores comunes de las fórmulas en la hoja de cálculo y corregirlos directamente

  1. Haga clic en el botón de Microsoft Office Imagen del botón, haga clic en Opciones de Excel y, a continuación, haga clic en la categoría Fórmulas.
  1. En la sección Comprobación de errores, active la casilla de verificación Habilitar comprobación de errores en segundo plano.
  2. Para cambiar el color del triángulo que indica dónde está el error, seleccione otro color en el cuadro Indicar errores con el color.
  3. Seleccione una celda que tenga un triángulo en la esquina superior izquierda.
  4. Junto a la celda, haga clic en el botón Comprobación de erroresImagen del botón que aparece y, a continuación, haga clic en la opción que desee. Los comandos varían para cada tipo de error, que se describe en la primera entrada.

Si hace clic en Omitir error, se marcará el error para omitirlo en las revisiones subsiguientes.

  1. Repita los dos pasos anteriores.

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2007