CONTAR.SI

Cuenta las celdas, dentro del rango, que no están en blanco y que cumplen con el criterio especificado.

Sintaxis

CONTAR.SI(rango;criterio)

Rango     es el rango dentro del cual desea contar las celdas.

Criterio     es el criterio en forma de número, expresión, referencia a celda o texto, que determina las celdas que se van a contar. Por ejemplo, los criterios pueden expresarse como 32, "32", ">32", "manzanas" o B4.

Observaciones

Microsoft Excel proporciona funciones adicionales que se pueden usar para analizar los datos basándose en una condición.

  • Para calcular una suma basada en una cadena de texto o un número dentro de un rango, use la función de hoja de cálculo SUMAR.SI .
  • Para hacer que una fórmula devuelva uno de dos valores según una condición, como una bonificación por ventas basada en un importe de ventas especificado, utilice la función de hoja de cálculo SI.
  • Para contar celdas que están vacías o no, use las funciones CONTARA y CONTAR.BLANCO.

Ejemplo 1: fórmulas CONTAR.SI comunes

El ejemplo puede resultar más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
4
5
A B
Datos Datos
manzanas 32
naranjas 54
melocotones 75
manzanas 86
Fórmula Descripción (resultado)
=CONTAR.SI(A2:A5;"manzanas") Número de celdas con manzanas en la primera columna anterior (2)
=CONTAR.SI(A2:A5,A4) Número de celdas con melocotones en la primera columna anterior (2)
=CONTAR.SI(A2:A5,A3)+CONTAR.SI(A2:A5,A2) Número de celdas con naranjas y manzanas en la primera columna anterior (3)
=CONTAR.SI(B2:B5;">55") Número de celdas con un valor superior a 55 en la segunda columna anterior (2)
=CONTAR.SI(B2:B5,"<>"&B4) Número de celdas con un valor distinto a 75 en la segunda columna anterior (2)
=CONTAR.SI(B2:B5,">=32")-CONTAR.SI(B2:B5,">85") Número de celdas con un valor superior o igual a 32 e inferior o igual a 85 en la segunda columna anterior (3)

Ejemplo 2: fórmulas CONTAR.SI que usan caracteres comodín y que gestionan valores vacíos

El ejemplo puede que sea más sencillo de entender si lo copia en una hoja de cálculo vacía.

Mostrar¿Cómo?

  1. Cree una hoja de cálculo o un libro vacío.
  2. Seleccione un ejemplo del tema de la Ayuda. No seleccione los encabezados de fila o columna.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
3
4
5
6
7
A B
Datos Datos
manzanas Yes
   
naranjas NO
melocotones No
   
manzanas YeS
Fórmula Descripción (resultado)
=CONTAR.SI(A2:A7,"*es") Número de celdas que acaban con las letras "les" en la primera columna anterior (4)
=CONTAR.SI(A2:A7,"?????es") Número de celdas que acaban con las letras "les" y tienen exactamente 8 letras en la primera columna anterior (2)
=CONTAR.SI(A2:A7,"*") Número de celdas que contienen texto en la primera columna anterior (4)
=CONTAR.SI(A2:A7,"<>"&"*") Número de celdas que no contienen texto en la primera columna anterior (2)
=CONTAR.SI(B2:B7,"No") / FILAS(B2:B7) El número medio de votos negativos, incluidas las celdas vacías de la segunda columna anterior, con el formato de porcentaje sin cifras decimales (33%)
=CONTAR.SI(B2:B7,"Sí") / (FILAS(B2:B7) -CONTAR.SI(B2:B7, "<>"&"*")) El número medio de votos positivos, excluidas las celdas vacías de la segunda columna anterior, con el formato de porcentaje sin cifras decimales (50%)

 Nota    Para ver el número como un porcentaje, seleccione la celda y haga clic en Celdas en el menú Formato. Haga clic en la ficha Número y, a continuación, haga clic en Porcentaje en el cuadro Categoría.

 
 
Corresponde a:
Excel 2003