Contar el número de palabras de una celda o un rango

Supongamos que desea averiguar cuántas palabras hay en una celda o un rango de celdas que contiene una cadena de texto larga, como una descripción o un campo de comentarios. Existen varias formas de realizar esta tarea.

¿Qué desea hacer?


Contar el número de palabras de una celda

Para realizar esta tarea, utilice las funciones LARGO, ESPACIOS y SUSTITUIR.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

En este ejemplo, la celda A1 contiene el texto "¡Que pase buen día!" y la celda A2 contiene la fórmula. La fórmula devuelve un valor de 4 que indica que la celda contiene cuatro palabras separadas por espacios. No habrá diferencia si las palabras están marcadas por varios espacios o si las palabras empiezan o terminan con un espacio. La función ESPACIOS quita los espacios sobrantes, los iniciales y los finales en el texto de la celda.

 
1
2
3
A
¡Que pase buen día!
Fórmula Descripción (resultado)
=SI(LARGO(ESPACIOS(A1))=0;0;LARGO(ESPACIOS(A1))-LARGO(SUSTITUIR(A1;" ";""))+1) Cuenta las palabras existentes en A1 (4)

 Nota   Para evitar referencias circulares, asegúrese de escribir la fórmula en una celda distinta de la celda cuyas palabras va a contar. Asegúrese también de cambiar las referencias de celda en la fórmula para que reflejen la celda que contiene las palabras que desea contar.

Detalles de la función

LARGO, LARGOB

ESPACIOS

SUSTITUIR

Volver al principio Volver al principio

Contar el número de palabras de un rango de celdas

Para realizar esta tarea, utilice las funciones SUMAR.SI, LARGO, ESPACIOS y SUSTITUIR en una fórmula de matriz.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

MostrarCómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda.

 Nota   No seleccione los encabezados de fila ni de columna.

Seleccionar un ejemplo de la Ayuda

  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

En este ejemplo, la fórmula devuelve un valor de 41 que indica que el rango contiene 41 palabras separadas por espacios. No habrá diferencia si las palabras están marcadas por varios espacios o si las palabras empiezan o terminan con un espacio. La función ESPACIOS quita los espacios sobrantes, los iniciales y los finales en el texto de la celda. Para obtener el número total de palabras del rango especificado, la fórmula de matriz cuenta las palabras del rango, y la función SUMA suma los valores de cada celda para obtener el total.

 
1
2
3
4
5
6
A B C D
¡Comer más verdura! Oler las rosas. Un día sin lluvia... ¡Las campanas!
Viernes Sábado Domingo Lunes
Llevar a mamá a cenar Lavar al perro Caminata Entrevista de trabajo
¡No rendirse nunca! ¡Que sea un día estupendo! ¡Seguir adelante! ¡Siempre en marcha!
Fórmula Descripción (resultado)
=SUMA(SI(LARGO(ESPACIOS(A1:D4))=0;0;LARGO(ESPACIOS(A1:D4))-LARGO(SUSTITUIR(A1:D4;" ";""))+1)) Cuenta las palabras existentes en el rango de celdas A1:D4 (41)

 Notas 

  • Para evitar referencias circulares, asegúrese de escribir la fórmula en una celda distinta de la celda cuyas palabras va a contar. Asegúrese de cambiar las referencias del rango de celdas en la fórmula para que reflejen el rango de celdas que contiene las palabras que desea contar.
  • Para escribir una fórmula de matriz, seleccione la celda que contiene la fórmula, presione F2 y, a continuación, presione CTRL+MAYÚS+ENTRAR.

 Sugerencia   Para ver cómo se evalúa una función paso a paso, seleccione la celda que contiene la fórmula. En la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en la opción Evaluar fórmula.

Detalles de la función

SUMAR.SI

LARGO, LARGOB

ESPACIOS

SUSTITUIR

Volver al principio Volver al principio

 
 
Corresponde a:
Excel 2007