Calcular la diferencia entre dos horas

MostrarPara presentar el resultado en el formato de hora estándar (horas : minutos : segundos)

Utilice el operador de sustracción (-) para hallar la diferencia entre horas y la función TEXTO para dar formato a las horas.

Las horas nunca podrán ser mayores que 24, los minutos no deben ser mayores que 60 y los segundos no deben superar la cifra de 60.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
A B
Hora de inicio Hora de finalización
9/6/2007 10:35 a.m. 09.06.07 3:30 p.m.
Fórmula Descripción (Resultado)
=TEXTO(B2-A2,"h") Horas entre dos horas (4)
=TEXTO(B2-A2,"h:mm") Horas y minutos entre dos horas (4:55)
=TEXTO(B2-A2,"h:mm:ss") Horas, minutos y segundos entre dos horas (4:55:00)

 Nota   También puede aplicar el formato de fecha y hora sin utilizar la función TEXTO para especificar el formato. Sin embargo, si utiliza al mismo tiempo un formato aplicado con la función TEXTO y un formato de número, la función TEXTO prevalecerá.

Detalles de la función

TEXTO

MostrarPara presentar el resultado en un total basado en una unidad de tiempo (120 minutos)

Utilice la función ENTERO, o bien las funciones HORA, MINUTO y SEGUNDO para realizar esta tarea.

Ejemplo de hoja de cálculo

El ejemplo puede resultar más fácil si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo?

  1. Cree un libro o una hoja de cálculo en blanco.
  2. Seleccione el ejemplo en el tema de Ayuda. No seleccione los encabezados de fila o de columna. 

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda
  1. Presione CTRL+C.
  2. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.
  3. Para alternar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione CTRL+` (acento grave) o, en el menú Herramientas, elija Auditoría de fórmulas y, a continuación, haga clic en Modo de auditoría de fórmulas.
 
1
2
A B
Hora de inicio Hora de finalización
9/6/2007 10:35 a.m. 10/6/2007 3:30 p.m.
Fórmula Descripción (Resultado)
=ENTERO((B2-A2)*24) Horas totales entre dos horas (28)
=(B2-A2)*1440 Minutos totales entre dos horas (1735)
=(B2-A2)*86400 Segundos totales entre dos horas (104100)
=HORA(B2-A2) Horas entre dos horas, cuando la diferencia no es mayor que 24. (4)
=MINUTO(B2-A2) Minutos entre dos horas, cuando la diferencia no es mayor que 60. (55)
=SEGUNDO(B2-A2) Segundos entre dos horas, cuando la diferencia no es mayor que 60. (0)

Detalles de la función

ENTERO

HORA

MINUTO

SEGUNDO

 
 
Corresponde a:
Excel 2003