Use Office HTML filter to create Web pages that download faster

Applies to

Microsoft Office 2000

When you save a document as a Web page in Word 2000 by clicking Save as Web Page on the File menu, Office adds Office-specific markup to standard Hypertext Markup Language (HTML) and cascading style sheet (CSS) markup. This additional markup fully preserves Rich Text Format (RTF) and page layout, and allows Word to "roundtrip" documents between binary and HTML format. This means you can create documents in Word, save them as HTML, open them again in Word, and still use all the Word editing features you originally used to create the page.

The Office-specific markup increases HTML file size. If you know you won't need to edit the HTML version of a document, you can trade roundtrip capability for smaller file size by using Microsoft Office 2000 HTML Filter version 2.0. The filter removes Office-specific markup from HTML files created in Word so that they take up less storage space on Web servers and take less time for users to download. This process does not affect the appearance of your Web pages.

Download the HTML Filter 2.0 for Office 2000 self-extracting executable file from Microsoft Office Online.

What happens when you use Office HTML Filter in Word

After you download and install Office HTML Filter version 2.0, a new Export To command on the File menu allows you to choose between two options. Each option removes Office-specific markup, which means that you won't be able to use certain Word-specific features when you edit the document again.

The filter does not change how Web pages look in browsers, and it does not affect your original Word document. What changes is your ability to edit elements of the document in the HTML version that are represented by the Office-specific markup.

For example, you might have a Word document with footnotes that you inserted by clicking Footnote on the Insert menu, and you want to convert it to a Web page for your company's intranet. You click Save as Web Page on the File menu so that you keep the roundtrip capability. You decide to add another footnote to the HTML version, so you click Footnote to insert it in sequence.

On the other hand, if you point to Export To on the File menu, and then click Compact HTML, the footnotes will be displayed correctly in browsers, but the filter will remove the Word footnote formatting and convert the footnotes to plain text in the HTML version. This means that if you use the footnote command as you edit the filtered HTML version, Word will insert the new footnote as if it were the first on the page, not recognizing that other footnotes already exist, so the footnotes will not be displayed in the correct order.

How to use the Export To command

You can use the filter on .doc, .rtf, .txt, or .htm files.

Use the Export To command in Word

  1. Open the document that you want to use the filter on.

If you have not already saved your document, you'll be prompted to do so.

  1. On the File menu, point to Export To.
  2. Do one of the following:
  • To create a Web page that contains compact (filtered) HTML, click Compact HTML.
  • To export a cascading style sheet (CSS) file that contains the filtered style definitions from the document, click CSS Style Sheet. You might use this command, for example, to create a style sheet file that you can later link to multiple documents.
How to use the Copy As HTML command

When you install the filter you'll see a new Copy as HTML command on the Edit menu in addition to the Export To command on the File menu. You can use the Copy as HTML command to create a compact HTML copy of a selected portion of a document. For example, instead of writing complicated HTML tags to create nested tables in an HTML editor, you could just draw the tables in Word by using the Draw Table tool. Then select the tables, click Copy as HTML to create a compact HTML copy, and paste the nested tables into Notepad or the HTML editor that you normally work in.

Use the Copy As HTML command in Word   

  1. Select the section of the document that you want to copy.
  2. On the Edit menu, click Copy as HTML.
  3. Open a document in your HTML editor and paste the selected text.

 Note   You can use the filter without opening Word. On the Start menu, point to Programs, point to Microsoft Office Tools, and then click Microsoft Office HTML Filter. You can select multiple files to filter at one time. When you use the filter from the Start menu, you can also filter Microsoft Excel 2000 files saved in HTML format. The filter is not available, however, from within Excel.