Illustrate business processes with Visio flowcharts

Applies to
Microsoft Office Visio® 2003

With Visio flowcharts you can see entire business processes at a glance. You can clarify what works and what doesn’t in your team’s task and information flow, analyze problems, and identify areas for improvement. You can also document your solutions to those problems, explaining the steps in your processes in as much or little detail as you need.

In this article


 Note   You can view a short demo on using a Visio flowchart to analyze and improve order processing, titled I can see clearly now: Business processes in Visio. The demo is one of several Visio demos available at the Office Demos Showcase.

Choose the right flowchart for your process

The following table shows which types of Visio flowcharts suit which types of data. Choose the flowchart that suits the business process you want to document and present.

 Note   Flowcharts marked with an asterisk (*) are also available as downloadable templates from the Templates site at Microsoft Office Online. Downloadable templates require Visio 2003.

Business process flowchart type Sample (click to enlarge) Purpose
Audit Diagram Sample audit diagram Document and analyze processes that involve financial transactions and inventory management.
Basic Flowchart* Sample basic flowchart Describe or analyze processes, document procedures, indicate work or information flow, track cost and efficiency. Use to document process improvements and process management in Six Sigma projects.
Cause-and-Effect Diagram* (also called Ishikawa or Fishbone Diagrams) Sample cause and effect diagram Document the factors that contribute to a given outcome. Use to review factors that contribute to a specific situation. Document Six Sigma and ISO 9000 processes.
Cross-Functional Flowchart* Sample cross-functional flowchart Show the relationship between a business process and the organizational or functional units responsible for the process.
Data Flow Diagram Sample data flow diagram Document the logical flow of data through a set of processes or procedures, including external sources and destinations of the data activities that transform the data, and stores or collections where the data is held. (Available only in Visio Professional.)
EPC Diagram Sample EPC diagram Create EPC (event-driven process chain) diagrams to illustrate SAP/R3 business processes.
Fault Tree Analysis Diagram Sample fault tree analysis diagram Show the events that might lead to a failure so that failures can be prevented. Commonly used in Six Sigma processes.
TQM Diagram Sample TQM diagram Create Total Quality Management (TQM) flowcharts for business process re-engineering, TQM, continuous improvement, and quality solutions.
Work Flow Diagram Sample work flow diagram Describe, analyze, and document information flow, automation of business processes, and accounting, management, and human resources tasks.

Create your flowchart

Visio includes a Connector tool that you can use to connect shapes automatically as you add them to your flowchart, and to keep shapes connected as you move them around. The Connector tool saves time when you're creating and revising flowcharts.

 Note   The following method of creating flowcharts does not apply to cause and effect and data flow diagrams. For more information about those diagrams, see Help in Visio.

To create a business process flowchart

  1. On the File menu, point to New, point to Business Process, and then click Basic Flowchart.
  2. Drag a Process shape from the Basic Flowchart Shapes stencil onto the drawing page.
  3. On the Standard toolbar, click the Connector tool.

If you don't see the Connector tool, on the View menu, point to Toolbars, and then click Standard.

  1. Drag a second Process shape onto the drawing page. The shapes connect automatically.
  2. Continue adding Process, Decision, Document and other shapes until all the shapes you want are on the page.

Each new shape you add to the drawing page connects to the shape that is selected when you add it.

  1. On the Standard toolbar, click the Pointer tool.
  2. To add text to a process step, click the shape representing the step, and then type.
  3. To change the direction of process flow between two steps, click the connector between the steps. Then, on the Shape menu, point to Operations, and click Reverse Ends.
  4. To revise your flowchart layout, click the shape you want to move and then drag it to its new location.

 Tip   To connect a series of shapes simultaneously, click the arrow next to the Pointer tool and click Multiple Select Multiple Select tool, and then select the shapes you want to connect in the order you want them to connect. Then, on the Shape menu, click Connect Shapes.

 Note   Although using the connection method described above is often the best way to create flowcharts in Visio, it's not the only way. To learn more about connection types and how to control the way connected shapes behave, see Connect your process steps.

Add text, links, and numbers

A business process flowchart shows the big picture, but you can easily convey more detail about each process step by adding text and links. You can also format text and connectors to make your flowchart more useful and appealing. For example, you can change the text font size and style, create numbered or bulleted lists in process steps, and number process steps. You can even link from steps to supporting documents that show the steps' actual complexity.

Make your process steps more meaningful with text, links, and numbers

Use this method When Details
Add and format text in flowchart shapes You want to add more detail to flowchart steps and enhance the look of your diagram.

You can add and format text for:

  • Flowchart shapes.
  • Connectors.
Add one or more navigational links to a flowchart shape You want to jump directly from a shape to a diagram, document, or Web page that presents detailed information about the process step the shape represents.

You can add links from shapes to:

  • Another page in the same diagram.
  • Another diagram.
  • Documents created in other programs, such as Microsoft Office Word® and Microsoft Office Excel®.
  • Web pages.
Number flowchart shapes You want to quickly locate references to the process steps in a numbered document.

You can add numbers by:

  • Manually or automatically adding them to shapes in flowcharts you have already created.
  • Setting up the numbering options in advance and automatically numbering shapes as you drop them on the page.

Add and format text

To add text to a flowchart shape or connector line

  • Select the flowchart shape or connector and then type.

To format text

  1. Double-click the shape and select the text you want to format.
  2. On the Format menu, click Text.
  3. In the Text dialog box, select the formatting options you want. Click Apply to see your changes before exiting the dialog box. Click OK when you're done.

Add navigational links

To add navigational links to a flowchart shape

  1. Click the shape to which you want to add a link.
  2. On the Insert menu, click Hyperlinks.
  3. Do one of the following:
    • To link to a Web site, under Address, type the Web site's URL or click Browse. Click Internet Address, and then navigate to the site in your Web browser.
    • To link to a document, under Address, click Browse, and then click Local File. Navigate to the file on your computer or on a server, and then click Open.
    • To link to another page in the same diagram, leave Address blank. Under Sub-address, click Browse, and then choose the page you want to link to.
  4. In the Description box, type the name you want to use for the link. This text appears when you pause over the link.
  5. To add another link to the same shape, click New and then repeat steps 1 through 3.
  6. When you're finished adding links to the shape, click OK.

To follow the link to its destination

  1. Right-click the flowchart shape to which links have been added.
  2. Click the name of the link you want.

Tip     When you display a flowchart in full screen, or presentation view (on the View menu, click Full Screen), links on shapes behave just like hyperlinks on Web pages.

Number flowchart shapes

To add numbers in an existing flowchart

  1. Display the drawing page that contains the flowchart shapes you want to add numbers to.
  2. If you want to add numbers only to specific shapes, select those shapes.
  3. On the Tools menu, point to Add-Ons, point to Visio Extras, and then click Number Shapes.
  4. On the General tab, under Operation, click:
    • Auto Number, to automatically number shapes from left to right and then top to bottom on the drawing page.
    • Manually By Clicking, to control the sequence in which shapes are numbered by manually clicking the shapes in the order you want.
  5. Under Number Assigned, type the number you want to start with and the interval between numbers, and then click OK.

 Note    In a multipage diagram, you have to add numbers to shapes on each page separately. To display a drawing page, click a tab at the bottom left of the drawing window.

To add numbers as you create a flowchart

  1. On the File menu, point to New, point to Business Process, and then click the diagram type you want to create.
  2. On the Tools menu, point to Add-Ons, point to Visio Extras, and then click Number Shapes.
  3. On the General tab, under Number Assigned, type the number you want to start numbering with and the interval between numbers.
  4. Under Operation, click:
    • Auto Number, to automatically number shapes from left to right and then top to bottom on the drawing page.
    • Manually By Clicking, to control the sequence in which shapes are numbered by manually clicking the shapes in the order you want.
  5. Select the Continue numbering shapes as dropped on page check box, and then click OK.
  6. When you have finished adding numbers, on the Tools menu, click Number Shapes. Clear the Continue numbering shapes as dropped on page check box, and then click OK.

Tip     To change the sequence in which shapes are automatically numbered, click the Advanced tab in the Number Shapes dialog box.

Connnect your process steps

It's hard to go wrong using the Connector tool method described in Create your flowchart. However, it's a good idea to understand a bit more about connectors because Visio uses more than one type of shape connection. You might get unexpected results if you inadvertently mix connection types and then reposition your shapes.

The connection method described in Create your flowchart is a shape-to-shape connection. When you move shapes that are connected shape-to-shape, the connectors reposition themselves to keep the connection as direct as possible. For more precise control over where connectors attach to specific shapes, use point-to-point connections.

Shape-to-shape connections

When a connection is shape-to-shape, the ends of the connector are attached, or glued, to entire shapes rather than to specific points on each shape. If you move the shapes, the connector adjusts to keep the connection as direct as possible.

Shape-to-shape connection

Point-to-point connections

When a connection is point-to-point, the ends of the connector are glued to specific points on each shape. If you move the shapes, the connector remains attached at those original points.

Point-to-point connection

How to identify connection type

To see whether a connection is shape-to-shape or point-to-point, click the connector to select it.

Shape-to-shape and point-to-point connections

Button image If the ends of the connector become large red squares, the connection is shape-to-shape.Button image If the ends become small red squares with symbols in them (x or +), the connection is point-to-point.

How to change one type of connection to another

To change a shape-to-shape connection to point-to-point, drag a connector endpoint away from the shape, and then drag it back to the connection point, marked with a blue x, where you want it to connect to the shape. To change a point-to-point connection to shape-to-shape, drag a connector endpoint over the process step shape until a red box surrounds the entire shape.

Change connection type

Work with large flowcharts

Many processes are long and complex, so flowcharts often extend beyond the print boundaries of a letter-size page. There are several methods for making large flowcharts easier to work with and share.

Method Description
Drill-down approach Create a high-level flowchart on one page. From each high-level step, "drill down" to a more detailed flowchart on a new page.
Off-page references Draw as much of your flowchart as you can on one page. Then, use an off-page reference to create a link to the page on which the flowchart continues.
On-page references Draw as much of your flowchart as you can moving down or across the page. Then, use an on-page reference to indicate that the flowchart continues at the top or left of the page.
Change drawing page size and print Change the size of the drawing page to contain the flowchart, and then print your diagram.

To create a drill-down flowchart

  1. On the File menu, point to New, then to Business Process, and then click the type of flowchart you want to create.
  2. Create a high-level flowchart by dropping shapes onto the drawing page.
  3. On the Insert menu, click New Page. Type a name for the new page if you want, and then click OK.
  4. Click the page tab at the bottom of the drawing page window to return to the high-level flowchart page.
  5. On the shape that represents a process step you want to define in detail on the new drawing page, create a navigational link that jumps to the new drawing page.
  6. Repeat steps 3-5 for each high-level process step you want to drill down into.
  7. Drop shapes onto the new drawing pages to create the flowcharts you want to drill down to.

To create a flowchart using off-page references

  1. On the File menu, point to New, point to Flowchart, and then click the type of flowchart you want to create.
  2. Create a flowchart by dropping shapes onto the drawing page. Keep adding shapes until you come close to the bottom or right edge of the drawing page.
  3. Drag the Off-page reference shape onto the page and position it near the edge, as the last shape.
  4. Click OK to add the Off-page reference shape to the current page, and to create a new drawing page that has its own Off-page reference shape.
  5. With the Off-page reference shape on the new drawing page selected, click the Connector tool on the Standard toolbar.
  6. Continue adding flowchart shapes until your flowchart is complete or you reach the end of the new drawing page.
  7. If necessary, repeat steps 3-6 to add another off-page reference.

 Note   Off-page reference shapes are not included in the stencils that open with the data flow, cause and effect, EPC, and fault tree analysis diagrams in Visio. To use off-page reference shapes in any of those diagrams, you can find it on the Basic Flowchart Shapes stencil. On the File menu, point to Shapes, point to Business Process, and then click Basic Flowchart Shapes.

To navigate between pages using off-page references

  • Double-click an Off-page reference shape to navigate to the page the shape references.

To create a flowchart using on-page references

  1. On the File menu, point to New, point to Business Process, and then click the type of flowchart you want to create.
  2. Create a flowchart by dropping shapes onto the drawing page. Keep adding shapes until you come close to the lower or right edge of the drawing page.
  3. Drag the On-page reference shape onto the page and position it near the edge, as the last shape.
  4. With the shape selected, type an identifying label, such as a number or letter.
  5. On the Edit menu, click Duplicate, and then drag the duplicate shape to the top or left of the drawing page.
  6. With the On-page reference shape on the new drawing page selected, click the Connector tool on the Standard toolbar.
  7. Continue adding flowchart shapes until your flowchart is complete or you reach the end of the page.
  8. If necessary, repeat steps 3-7 to add another on-page reference.

 Note   On-page reference shapes are not included in the stencils that open with the data flow, cause and effect, EPC, and fault tree analysis diagrams in Visio. To use off-page reference shapes in any of those diagrams, you can find it on the Basic Flowchart Shapes stencil. On the File menu, point to Shapes, point to Business Process, and then click Basic Flowchart Shapes.

To change drawing page size and print your diagram

  1. With your flowchart open, click the Pointer tool.
  2. Place the pointer over one edge of the page, and then press the CTRL key. When the pointer becomes a two-headed arrow, drag the page edge.
  3. To print the diagram after resizing the page, on the File menu, click Page Setup. On the Print Setup tab, click Fit to 1 sheet across by 1 sheet down, and then click OK.

 Tip    You can preview page breaks and change them before you print.

 
 
Applies to:
Visio 2003