Check a file in or out of a SharePoint library

When you check out a file from a library on a Microsoft Windows SharePoint Services site, you ensure that others cannot make changes to the file while you edit it. While the file is checked out, you can edit the file, close it, reopen it, and even work with the file on your hard disk. Other users cannot change the file or see your changes until you check in the file.

In this article


Overview

Checking out files before working on them helps to avoid conflicts and confusion when multiple people are working on the same set of files. When a file is checked out to you, only you can make changes to it. You can check out any file on a SharePoint site for which you have permission, and you can check out files directly from the following 2007 Microsoft Office system programs: Word, Excel, PowerPoint, and Visio.

When you check in a file, you can type comments about the changes that you made to the file. This helps people to understand what has changed in the file from version to version. This is especially helpful if several people work on a file or if the file is likely to go through several revisions. If your library tracks versions of files, your comments become a part of the version history of the file, which can be helpful if people need to view or restore a previous version.

Your organization may require you to check out a file before you edit it. When check-out is required, you must check in a new file when you create it in a library or upload it to a library.

While a file is checked out to you, the changes that you make are not visible to others until you check the file back in. There may be situations in which you want to check in the file so that others can see your changes, but you want to keep the file checked out so that you can continue working on it. When you check in a file, you can choose to continue working on the file, unless your library tracks both major and minor versions and you are checking in a major version. A major version usually has changed significantly since the previous major version, whereas a minor version usually has changed only slightly since the previous version. For example, a major version may include a large portion of new content, whereas a minor version may include only corrections to spelling errors.

When you use an Office program to check out a file on a Windows SharePoint Services 3.0 site, the file is stored by default on your hard disk in a drafts folder that is in your My Documents folder. You can change this location to another location on your hard disk or network, or you can specify that checked-out files are stored on the Web server when you work on them. Your administrator might specify a custom location or prevent the location from being changed, depending on the needs of your organization.

When you check out a file from a Microsoft Windows SharePoint Services 2.0 site, the file is stored on the server while you work on it, but you must still check in the file before others can see your changes. In most cases, when you check out a file from a Windows SharePoint Services 3.0 site, you receive a message telling you where the file will be stored while you have it checked out. You will not receive such a message when checking out a file from a Windows SharePoint Services 2.0 site.

When a document is checked out, the Document Management task pane in your Office program provides a command to check the file back in.

If both major and minor versions of files are being tracked, you may be prompted to choose whether you are checking in a major version or a minor version.

Top of Page Top of Page

Check out a file from a SharePoint library

Use this procedure to check out a file that is already open in an Office program. You can also check out a file from the library on the SharePoint site.

Do the following in these 2007 Office release programs:

Word, Excel, or PowerPoint
  1. Click the Microsoft Office ButtonButton image, click Server, and then click Check Out.

Word documents often open in Full Screen Reading view by default. If this is the case, you may have to click Print Layout to switch to Print Layout view before you can complete this step.

  1. If a message appears that describes where the file is stored during check-out, click OK.

In most cases, this message appears if you are checking out a file from a Windows SharePoint Services 3.0 site.

 Tip   In the message that describes where your file is being stored during check-out, you can change the options for working with checked-out files.

Visio
  1. On the File menu, click Check Out.
  2. If a message appears that describes where the file is stored during check-out, click OK.

In most cases, this message appears if you are checking out a file from a Windows SharePoint Services 3.0 site.

 Tip   In the message that describes where your file is being stored during check-out, you can change the options for working with checked-out files.

Top of Page Top of Page

Check in a file to a SharePoint library

Use this procedure to check in a file while it is open in the Office program. You can also check in a file from the library on the SharePoint site.

Do the following in these 2007 Office release programs:

Word, Excel, or PowerPoint
  1. Click the Microsoft Office ButtonButton image, click Server, and then click Check In.

Word documents often open in Full Screen Reading view by default. If this is the case, you may have to click Print Layout to switch to Print Layout view before you can complete this step.

  1. If you are prompted whether to check in a major or minor version, click Minor version if you made a minor change or Major version if you made a major change.
  2. In the Version Comments box, type any comments that you want to make about your changes.

These comments appear as part of the version history for the file in the SharePoint library, which can be helpful if you or someone else needs to view information about previous versions.

  1. If the Keep the document checked out after checking in this version check box is available, you can select it if you plan to keep working on the file.

This option is available if your library does not track versions, if it tracks all versions the same way, or if you are checking in a minor version. This option is not available if you are checking in a major version or publishing a file.

Visio
  1. On the File menu, click Check In.
  2. If you are prompted whether to check in a major or minor version, click Minor version if you made a minor change or Major version if you made a major change.
  3. In the Version Comments box, type any comments that you want to make about your changes.

These comments appear as part of the version history for the file in the SharePoint library, which can be helpful if you or someone else needs to view information about previous versions.

  1. If the Keep the document checked out after checking in this version check box is available, you can select it if you plan to keep working on the file.

This option is available if your library does not track versions, if it tracks all versions the same way, or if you are checking in a minor version. This option is not available if you are checking in a major version or publishing a file.

Top of Page Top of Page

Change the location where you work on checked-out files

This setting changes the location where you work on the next file that you check out. If you are currently working on a checked-out file, this procedure does not change its location.

Do the following in these 2007 Office release programs:

Word, Excel, or PowerPoint
  1. Click the Microsoft Office ButtonButton image, and then click the options for your program: Word Options, Excel Options, or PowerPoint Options.
  2. In the dialog box that appears, click Save.
  3. In the Offline editing options for document management server files section, do one of the following:
    • Use the following procedure to work with checked-out files on your hard disk or on a network location:
      1. Under Save checked-out files to, click The server drafts location on this computer.
      2. In the Server drafts location box, type the location on your hard disk where you want to work with checked-out files, or click Browse to find the location.
    • To work with checked-out files on a Web server, under Save checked-out files to, click The web server.

When you choose this option, you work with your checked-out files on the Web server or site where your files are stored. You cannot customize the specific location.

  1. Click OK.
Visio
  1. On the Tools menu, click Options.
  2. In the Options dialog box, click the General tab, and then click Service Options.
  3. In the dialog box that appears, click Offline Editing Options.
  4. In the Offline editing options for document management server files section, do one of the following:
    • Use the following procedure to work with checked-out files on your hard disk or on a network location:
      1. To work on checked-out files on your hard disk, under Save checked-out files to, click The server drafts location on this computer.
      2. Under Server drafts location, type the location on your hard disk where you want to work with check-out files, or click Browse to find the location.
    • To work on checked-out files on a server location, under Save checked-out files to, click The web server.

When you choose this option, you work with your checked-out files on the Web server or site where your files are stored. You cannot customize the specific location.

  1. Click OK.

Top of Page Top of Page

 
 
Applies to:
Excel 2007, PowerPoint 2007, Visio 2007, Word 2007