ZÄHLENWENN

Zählt die nicht leeren Zellen eines Bereichs, deren Inhalte mit den Suchkriterien übereinstimmen.

Syntax

ZÄHLENWENN(Bereich;Kriterien)

Bereich    ist der Zellbereich, von dem Sie wissen möchten, wie viele seiner Zellen einen Inhalt haben, der mit den Suchkriterien übereinstimmt.

Kriterien    gibt die Kriterien in Form einer Zahl, eines Ausdrucks, eines Zellbezugs oder einer Zeichenfolge an. Diese Kriterien bestimmen, welche Zellen gezählt werden. Zum Beispiel kann ein Suchkriterium als 32, "32", ">32", "Äpfel" oder B4 formuliert werden.

Hinweise

Microsoft Excel stellt zusätzliche Funktionen bereit, mit denen Daten auf Grundlage einer Bedingung analysiert werden können.

  • Wenn Sie auf Grundlage einer Zeichenfolge oder einer Zahl innerhalb eines Bereichs eine Summe berechnen möchten, verwenden Sie die SUMMMEWENN-Tabellenfunktion.
  • Damit eine Formel einen oder zwei Werte auf der Grundlage einer Bedingung zurückgibt, beispielsweise einen Umsatzbonus, der auf einer bestimmten Umsatzmenge beruht, verwenden Sie die WENN-Tabellenblattfunktion.
  • Verwenden Sie zum Zählen von leeren oder nicht leeren Zellen die Funktionen ANZAHL2 bzw. ANZAHLLEEREZELLEN.

Beispiel 1: Häufig verwendete ZÄHLENWENN-Formeln

Das Beispiel ist möglicherweise leichter zu verstehen, wenn Sie es in ein leeres Tabellenblatt kopieren.

AnzeigenWie wird's gemacht?

  1. Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.
  2. Wählen Sie das Beispiel im Hilfethema. Markieren Sie jedoch nicht die Zeilen- oder Spaltenüberschriften. 

Auswählen eines Beispiels aus der Hilfe

Auswählen eines Beispiels aus der Hilfe
  1. Drücken Sie STRG+C.
  2. Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.
  3. Um zwischen der Anzeige der Formel, die das Ergebnis liefert, und dem Ergebnis selbst umzuschalten, drücken Sie STRG+` (Graviszeichen). Sie können auch im Menü Extras auf Formelüberwachung zeigen und dann auf Formelüberwachungsmodus klicken.
 
1
2
3
4
5
A B
Daten Daten
Äpfel 32
Orangen 54
Pfirsiche 75
Äpfel 86
Formel Beschreibung (Ergebnis)
=ZÄHLENWENN(A2:A5;"Äpfel") Anzahl der Zellen in der ersten Spalte, die „Äpfel“ enthalten. (2)
=ZÄHLENWENN(A2:A5;A4) Anzahl der Zellen in der ersten Spalte, die „Pfirsiche“ enthalten. (1)
=ZÄHLENWENN(A2:A5;A3)+ZÄHLENWENN(A2:A5;A2) Anzahl der Zellen in der ersten Spalte, die „Äpfel“ und „Orangen“ enthalten. (3)
=ZÄHLENWENN(B2:B5;">55") Anzahl der Zellen in der zweiten Spalte, die einen Wert enthalten, der größer als 55 ist. (2)
=ZÄHLENWENN(B2:B5;"<>"&B4) Anzahl von Zellen in der zweiten Spalte mit einem Wert ungleich 75. (3)
=ZÄHLENWENN(B2:B5;">=32")-ZÄHLENWENN(B2:B5;">85") Anzahl der Zellen in der zweiten Spalte mit einem Wert größer oder gleich 32 und kleiner oder gleich 85. (3)

Beispiel 2: ZÄHLENWENN-Formeln mit Platzhalterzeichen und leeren Werten

Das Beispiel ist möglicherweise leichter zu verstehen, wenn Sie es in ein leeres Arbeitsblatt kopieren.

AnzeigenSo wird's gemacht

  1. Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.
  2. Wählen Sie das Beispiel im Hilfethema aus. Markieren Sie dabei nicht die Zeilen- oder Spaltenüberschriften.

Auswählen eines Beispiels aus der Hilfe

Auswählen eines Beispiels aus der Hilfe
  1. Drücken Sie STRG+C.
  2. Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.
  3. Drücken Sie STRG+` (Graviszeichen), um zwischen den angezeigten Ergebnissen und den Formeln zu wechseln, die die Ergebnisse zurückgeben. Sie können auch im Menü Extras auf Formelüberwachung zeigen und dann auf Formelüberwachungsmodus klicken.
 
1
2
3
4
5
6
7
A B
Daten Daten
Äpfel Ja
   
Orangen NEIN
Pfirsiche Nein
   
Äpfel JA
Formel Beschreibung (Ergebnis)
=ZÄHLENWENN(A2:A7;"*el") Anzahl der Zellen in der ersten Spalte, deren Inhalt mit „el“ endet. (2)
=ZÄHLENWENN(A2:A7;"???el") Anzahl der Zellen in der ersten Spalte, deren Inhalt auf „el“ endet und genau fünf Buchstaben umfasst. (2)
=ZÄHLENWENN(A2:A7;"*") Anzahl der Zellen in der ersten Spalte, die Text enthalten. (4)
=ZÄHLENWENN(A2:A7;"<>"&"*") Anzahl der Zellen in der ersten Spalte, die keinen Text enthalten. (2)
=ZÄHLENWENN(B2:B7;"Nein")/ZEILEN(B2:B7) Durchschnittliche Anzahl von Nein-Stimmen einschließlich leeren Zellen in der zweiten Spalte, als Prozentwert ohne Dezimalstellen formatiert. (33 %)
=ZÄHLENWENN(B2:B7;"Ja")/(ZEILEN(B2:B7)-ZÄHLENWENN(B2:B7;"<>"&"*")) Durchschnittliche Anzahl von Ja-Stimmen ausschließlich leerer Zellen in der zweiten Spalte, als Prozentwert ohne Dezimalstellen formatiert. (50 %)

 Hinweis    Markieren Sie zum Anzeigen der Werte als Prozentwerte die Zelle, und klicken Sie im Menü Format auf Zellen. Klicken Sie auf die Registerkarte Zahlen, und klicken Sie dann im Feld Kategorie auf Prozent.

 
 
Zutreffend für:
Excel 2003