WENN

Gibt eine Wahrheitsprüfung an, die durchgeführt werden soll.

Verwenden Sie die WENN-Funktion, um bedingte Tests an Werten und Formeln auszuführen.

Syntax

WENN(Prüfung;Dann_Wert;Sonst_Wert)

Prüfung     ist ein beliebiger Wert oder Ausdruck, der WAHR oder FALSCH sein kann. Beispielsweise ist A10=100 ein logischer Ausdruck; wenn der Wert in einer Zelle A10 gleich 100 ist, ist der Ausdruck WAHR. Andernfalls ist der Ausdruck FALSCH. Dieses Argument kann einen beliebigen Vergleichsberechnungsoperator verwenden.

Dann_Wert     ist der Wert, der zurückgegeben wird, wenn Prüfung WAHR ist. Wenn dieses Argument beispielsweise die Zeichenfolge "Im Budget" ist und das Argument Prüfung als WAHR ausgewertet wird, zeigt die WENN-Funktion den Text "Im Budget" an. Wenn Prüfung WAHR und Dann_Wert leer ist, gibt dieses Argument 0 (Null) zurück. Um das Wort WAHR anzuzeigen, verwenden Sie für dieses Argument den Wahrheitswert WAHR. Dann_Wert kann eine andere Formel sein.

Sonst_Wert     ist der Wert, der zurückgegeben wird, wenn Prüfung FALSCH ist. Wenn es sich bei diesem Argument beispielsweise um die Zeichenfolge "Budget überschritten" handelt und das Argument Prüfung als FALSCH ausgewertet wird, zeigt die WENN-Funktion den Text "Budget überschritten" an. Wenn Prüfung FALSCH ist und Sonst_Wert nicht angegeben wird (d.h. auf Dann_Wert folgt kein Semikolon), wird der Wahrheitswert FALSCH zurückgegeben. Wenn Prüfung FALSCH und Sonst_Wert leer ist (d.h. auf Dann_Wert folgt ein Semikolon und eine schließende Klammer), wird der Wert 0 (Null) zurückgegeben. Sonst_Wert kann eine andere Formel sein.

Hinweise

Beispiel 1

Das Beispiel ist möglicherweise leichter zu verstehen, wenn Sie es in ein leeres Arbeitsblatt kopieren.

AnzeigenWie wird's gemacht?

  1. Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.
  2. Wählen Sie das Beispiel im Hilfethema. Markieren Sie jedoch nicht die Zeilen- oder Spaltenüberschriften. 

Auswählen eines Beispiels aus der Hilfe

Auswählen eines Beispiels aus der Hilfe
  1. Drücken Sie STRG+C.
  2. Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.
  3. Um zwischen der Anzeige der Formel, die das Ergebnis liefert, und dem Ergebnis selbst umzuschalten, drücken Sie STRG+` (Graviszeichen). Sie können auch im Menü Extras auf Formelüberwachung zeigen und dann auf Formelüberwachungsmodus klicken.
 
1
2
A
Daten
50
Formel Beschreibung (Ergebnis)
=WENN(A2<=100;"Im Budget";"Budget überschritten") Wenn die oben genannte Zahl kleiner gleich 100 ist, zeigt die Formel "Im Budget" an. Andernfalls wird "Budget überschritten" angezeigt. (Im Budget)
=WENN(A2=100;SUMME(B5:B15);"") Wenn die oben genannte Zahl gleich 100 ist, wird der Bereich B5:B15 berechnet. Andernfalls wird eine leere Zeichenfolge ("") zurückgegeben. ()

Beispiel 2

Das Beispiel ist möglicherweise leichter zu verstehen, wenn Sie es in ein leeres Arbeitsblatt kopieren.

AnzeigenWie wird's gemacht?

  1. Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.
  2. Wählen Sie das Beispiel im Hilfethema. Markieren Sie jedoch nicht die Zeilen- oder Spaltenüberschriften. 

Auswählen eines Beispiels aus der Hilfe

Auswählen eines Beispiels aus der Hilfe
  1. Drücken Sie STRG+C.
  2. Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.
  3. Um zwischen der Anzeige der Formel, die das Ergebnis liefert, und dem Ergebnis selbst umzuschalten, drücken Sie STRG+` (Graviszeichen). Sie können auch im Menü Extras auf Formelüberwachung zeigen und dann auf Formelüberwachungsmodus klicken.
 
1
2
3
4
A B
Tatsächliche Kosten Geschätzte Kosten
1500 900
500 900
500 925
Formel Beschreibung (Ergebnis)
=WENN(A2>B2;"Budget überschritten";"OK") Überprüft, ob in der ersten Zeile das Budget überschritten ist (Budget überschritten)
=WENN(A3>B3;"Budget überschritten";"OK") Überprüft, ob in der zweiten Zeile das Budget überschritten ist (OK)

Beispiel 3

Das Beispiel ist möglicherweise leichter zu verstehen, wenn Sie es in ein leeres Arbeitsblatt kopieren.

AnzeigenWie wird's gemacht?

  1. Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.
  2. Wählen Sie das Beispiel im Hilfethema. Markieren Sie jedoch nicht die Zeilen- oder Spaltenüberschriften. 

Auswählen eines Beispiels aus der Hilfe

Auswählen eines Beispiels aus der Hilfe
  1. Drücken Sie STRG+C.
  2. Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.
  3. Um zwischen der Anzeige der Formel, die das Ergebnis liefert, und dem Ergebnis selbst umzuschalten, drücken Sie STRG+` (Graviszeichen). Sie können auch im Menü Extras auf Formelüberwachung zeigen und dann auf Formelüberwachungsmodus klicken.
 
1
2
3
4
A
Punktzahl
45
90
78
Formel Beschreibung (Ergebnis)
=WENN(A2>89;"A";WENN(A2>79;"B"; WENN(A2>69;"C";WENN(A2>59;"D";"F")))) Weist der ersten Punktzahl eine Einstufung zu (F)
=WENN(A3>89;"A";WENN(A3>79;"B"; WENN(A3>69;"C";WENN(A3>59;"D";"F")))) Weist der zweiten Punktzahl eine Einstufung zu (A)
=WENN(A4>89;"A";WENN(A4>79;"B"; WENN(A4>69;"C";WENN(A4>59;"D";"F")))) Weist der dritten Punktzahl eine Einstufung zu (C)

In diesem Beispiel ist die zweite WENN-Anweisung das Argument Sonst_Wert der ersten WENN-Anweisung. Ähnliches gilt für die dritte WENN-Anweisung, die das Argument Sonst_Wert der zweiten WENN-Anweisung ist. Ergibt beispielsweise die erste Prüfung (Durchschnitt>89) den Wert WAHR, wird "A" zurückgegeben. Ergibt die erste Prüfung den Wert FALSCH, wird die zweite WENN-Anweisung ausgeführt usw.

Die Einstufungen werden Zahlen mithilfe des folgenden Schlüssels zugewiesen.

Einstufung Rückgabe
Größer als 89 A
80 bis 89 B
70 bis 79 C
60 bis 69 D
Kleiner als 60 F
 
 
Zutreffend für:
Excel 2003