Ausblenden oder Anzeigen von Nullwerten

Möglicherweise verfügen Sie über eine persönliche Vorliebe für das Anzeigen von Nullwerten in einer Zelle, oder Sie verwenden eine Kalkulationstabelle mit bestimmten Standardformaten, die das Ausblenden von Nullwerten erfordern. Es gibt verschiedene Möglichkeiten zum Ein- oder Ausblenden von Nullwerten.

Was möchten Sie tun?


Anzeigen oder Ausblenden aller Nullwerte auf einem Arbeitsblatt

  1. Klicken Sie auf die Schaltfläche Microsoft Office Abbildung der Schaltfläche, klicken Sie auf Excel-Optionen und anschließend auf die Kategorie Erweitert.
  1. Wählen Sie unter Optionen für dieses Arbeitsblatt anzeigen ein Arbeitsblatt aus, und führen Sie dann eine der folgenden Aktionen aus:
    • Aktivieren Sie das Kontrollkästchen In Zellen mit Nullwert eine Null anzeigen, um Nullwerte (0) in Zellen anzuzeigen.
    • Deaktivieren Sie das Kontrollkästchen In Zellen mit Nullwert eine Null anzeigen, um Nullwerte (0) als leere Zellen anzuzeigen.

Seitenanfang Seitenanfang

Verwenden eines Zahlenformats zum Ausblenden von Nullwerten in ausgewählten Zellen

Befolgen Sie dieses Verfahren zum Ausblenden von Nullwerten in ausgewählten Zellen. Falls sich der Wert in einer dieser Zellen in einen Wert ungleich Null (0) ändert, ist das Format des Werts ähnlich dem Standardzahlenformat.

  1. Markieren Sie die Zellen, die auszublendende Nullwerte (0) enthalten.
  2. Klicken Sie auf der Registerkarte Start in der Gruppe Zellen auf Format und anschließend auf Zellen formatieren.
  1. Klicken Sie in der Liste Kategorie auf Benutzerdefiniert.
  2. Geben Sie 0;-0;;@ im Feld Typ ein.

 Hinweise 

  • Die ausgeblendeten Werte werden nur in der Bearbeitungsleiste Bearbeitungsleiste (wenn Sie die Zelle bearbeiten, auch in der Zelle) angezeigt. Sie werden nicht gedruckt.
  • Klicken Sie auf der Registerkarte Start in der Gruppe Zellen auf Format und anschließend auf Zellen formatieren.
  • Wenn Sie ausgeblendete Werte erneut anzeigen möchten, wählen Sie die entsprechenden Zellen aus, zeigen Sie auf der Registerkarte Start in der Gruppe Zellen auf Format, und klicken Sie dann auf Zellen formatieren. Klicken Sie in der Liste Kategorie auf Standard, um das Standardzahlenformat zuzuweisen. Wenn Sie ein Datum oder eine Uhrzeit erneut anzeigen möchten, wählen Sie auf der Registerkarte Zahlen das entsprechende Datums- oder Uhrzeitformat aus.

Seitenanfang Seitenanfang

Verwenden eines bedingten Formats zum Ausblenden von Nullwerten, die von einer Formel zurückgegeben wurden

  1. Markieren Sie die Zelle, die den Nullwert (0) enthält.
  2. Klicken Sie auf der Registerkarte Start in der Gruppe Formatvorlage auf den Pfeil neben Bedingte Formatierung, zeigen Sie auf Zellenregeln hervorheben, und klicken Sie dann auf Gleich.
  1. Geben Sie in das linke Feld 0 ein.
  2. Wählen Sie im rechten Feld Benutzerdefiniertes Format.
  3. Klicken Sie im Dialogfeld Zellen formatieren auf die Registerkarte Schrift.
  4. Wählen Sie im Feld Farbe weiß aus.

Seitenanfang Seitenanfang

Verwenden einer Formel zum Anzeigen von Nullwerten als Leerzeichen oder Striche

Verwenden Sie für diese Aufgabe die WENN-Funktion.

Beispiel

Möglicherweise wird das Beispiel verständlicher, wenn Sie es in ein leeres Arbeitsblatt kopieren.

AnzeigenWie kopiere ich ein Beispiel?

  1. Markieren Sie das Beispiel in diesem Artikel. Falls Sie das Beispiel in Excel Web App kopieren möchten, müssen Sie es jeweils zellenweise kopieren und einfügen.

 Wichtig   Markieren Sie dabei nicht die Zeilen- oder Spaltenüberschriften.

Auswählen eines Beispiels aus der Hilfe

Auswählen eines Beispiels aus der Hilfe
  1. Drücken Sie STRG+C.
  2. Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.
  3. Markieren Sie im Arbeitsblatt Zelle A1, und drücken Sie STRG+V. Wenn Sie in Excel Web App arbeiten, wiederholen Sie das Kopieren und Einfügen bei jeder Zelle im Beispiel.

 Wichtig   Damit das Beispiel ordnungsgemäß funktioniert, müssen Sie es in Zelle A1 des Arbeitsblatts einfügen.

  1. Zum Wechseln zwischen der Anzeige der Ergebnisse und der Anzeige der Formeln, die das Ergebnis liefern, drücken Sie STRG+` (Graviszeichen), oder klicken Sie auf der Registerkarte Formeln in der Gruppe Formelüberwachung auf die Schaltfläche Formeln anzeigen.

Nachdem Sie das Beispiel in ein leeres Arbeitsblatt kopiert haben, können Sie es Ihren Anforderungen entsprechend anpassen.


 
1
2
3
4
5

6
7
A B
Daten
10
10
Formel Beschreibung (Ergebnis)
=A2-A3 Die zweite Zahl wird von der ersten (0) subtrahiert
=WENN(A2-A3=0;"";A2-A3) Gibt eine leere Zelle zurück, wenn der Wert Null ist (leere Zelle)
=WENN(A2-A3=0;"-";A2-A3) Gibt einen Strich zurück, wenn der Wert Null ist (-)

Weitere Informationen zum Verwenden dieser Funktion finden Sie unter Funktion WENN.

Seitenanfang Seitenanfang

Ausblenden von Nullwerten in einem PivotTable-Bericht

  1. Klicken Sie auf den PivotTable-Bericht.
  2. Klicken Sie auf der Registerkarte Optionen in der Gruppe PivotTable-Optionen auf den Pfeil neben Optionen, und klicken Sie dann auf Optionen.
  1. Klicken Sie auf die Registerkarte Layout & Format, und führen Sie dann eine oder mehrere der folgenden Aktionen aus:

Ändern der Fehleranzeige     Aktivieren Sie unter Format das Kontrollkästchen Fehlerwerte anzeigen als. Geben Sie in das Feld den Wert ein, der anstelle von Fehlern angezeigt werden soll. Wenn bei Fehlern kein Wert angezeigt werden soll, löschen Sie alle Zeichen aus dem Feld.

Ändern der Anzeige leerer Zellen     Aktivieren Sie das Kontrollkästchen Leere Zellen anzeigen als. Geben Sie in das Feld den Wert ein, der in leeren Zellen angezeigt werden soll. Wenn kein Wert angezeigt werden soll, löschen Sie alle Zeichen aus dem Feld. Wenn Nullen angezeigt werden sollen, deaktivieren Sie das Kontrollkästchen.

Seitenanfang Seitenanfang

 
 
Zutreffend für:
Excel 2007