TÆL.HVIS

Tæller antallet af ikke-tomme celler, som opfylder de givne kriterier, i et område.

Syntaks

TÆL.HVIS(område;kriterium)

Område    er det område af celler, hvorfra du vil tælle celler.

Kriterium    er kriterier i form af et tal, et udtryk, en cellereference eller tekst, der definerer, hvilke celler der skal tælles. F.eks. kan kriterier udtrykkes som 32, "32", ">32" eller "æbler" eller B4.

Bemærkninger

Microsoft Excel har yderligere funktioner, der kan bruges til at analysere data på basis af en betingelse.

  • Hvis du vil beregne en sum på basis af en tekststreng eller et tal i et område, skal du bruge regnearksfunktionen SUM.HVIS.
  • Hvis du vil have en formel til at returnere en af to værdier på basis af en betingelse, f.eks. en salgsbonus, der er baseret på et angivet salgsbeløb, skal du bruge regnearksfunktionen HVIS.
  • Hvis du vil tælle celler, der er tomme eller ikke er tomme, skal du bruge funktionerne TÆLV og ANTAL.BLANKE.

Eksempel 1: Almindelige TÆL.HVIS-formler

Det kan være lettere at forstå eksemplet, hvis du kopierer det til et tomt regneark.

VisSådan gør du

  1. Opret en tom projektmappe eller et tomt regneark.
  2. Marker eksemplet i Hjælp. Du må ikke markere række- eller kolonneoverskrifterne. 

Markere et eksempel i Hjælp

Markere et eksempel i Hjælp
  1. Tryk på CTRL+C.
  2. Marker celle A1 i regnearket, og tryk på CTRL+V.
  3. Hvis du vil skifte mellem visning af resultaterne og visning af de formler, der returnerer resultaterne, skal du trykke på CTRL+` (accent grave) eller pege på Formelrevision i menuen Funktioner. Klik derefter på Tilstand for formelrevision.
 
1
2
3
4
5
A B
Data Data
æbler 32
appelsiner 54
ferskner 75
æbler 86
Formel Beskrivelse (resultat)
=TÆL.HVIS(A2:A5;"æbler") Antallet af celler med æbler i den første kolonne ovenfor (2)
=TÆL.HVIS(A2:A5;A4) Antallet af celler med ferskner i den første kolonne ovenfor (2)
=TÆL.HVIS(A2:A5;A3)+TÆL.HVIS(A2:A5;A2) Antallet af celler med appelsiner og æbler i den første kolonne ovenfor (3)
=TÆL.HVIS(B2:B5;">55") Antallet af celler med en værdi højere end 55 i den anden kolonne ovenfor (2)
=TÆL.HVIS(B2:B5;"<>"&B4) Antallet af celler med en værdi, der er forskellig fra 75, i den anden kolonne ovenfor (2)
=TÆL.HVIS(B2:B5;">=32")-TÆL.HVIS(B2:B5;">85") Antallet af celler med en værdi, der er større end eller lig med 32 og mindre end eller lig med 85 i den anden kolonne ovenfor (3)

Eksempel 2: TÆL.HVIS-formler med jokertegn og håndtering af tomme værdier

Det kan være lettere at forstå eksemplet, hvis du kopierer det til et tomt regneark.

VisSådan gør du

  1. Opret en tom projektmappe eller et tomt regneark.
  2. Marker eksemplet i Hjælp. Du må ikke markere række- eller kolonneoverskrifterne. 

Markere et eksempel i Hjælp

Markere et eksempel i Hjælp
  1. Tryk på CTRL+C.
  2. Marker celle A1 i regnearket, og tryk på CTRL+V.
  3. Hvis du vil skifte mellem visning af resultaterne og visning af de formler, der returnerer resultaterne, skal du trykke på CTRL+` (accent grave) eller pege på Formelrevision i menuen Funktioner. Klik derefter på Tilstand for formelrevision.
 
1
2
3
4
5
6
7
A B
Data Data
æbler Ja
   
appelsiner NEJ
ferskner Nej
   
æbler JA
Formel Beskrivelse (resultat)
=TÆL.HVIS(A2:A7;"*er") Antallet af celler, der slutter med bogstaverne "er" i den første kolonne ovenfor (4)
=TÆL.HVIS(A2:A7;"???er") Antallet af celler, der slutter med bogstaverne "er" og har nøjagtigt fem bogstaver i første kolonne ovenfor (2)
=TÆL.HVIS(A2:A7;"*") Antallet af celler, der indeholder tekst i den første kolonne ovenfor (4)
=TÆL.HVIS(A2:A7;"<>"&"*") Antallet af celler, der ikke indeholder tekst i den første kolonne ovenfor (2)
=TÆL.HVIS(B2:B7;"Nej") / RÆKKER(B2:B7) Det gennemsnitlige antal Nej-stemmer inklusive tomme celler i den anden kolonne ovenfor formateret som procentsats uden decimaler (33%)
=TÆL.HVIS(B2:B7;"Ja") / (RÆKKER(B2:B7) -TÆL.HVIS(B2:B7;"<>"&"*")) Det gennemsnitlige antal Ja-stemmer eksklusive tomme celler i den anden kolonne ovenfor formateret som procentsats uden decimaler (50%)

 Bemærk!    Marker cellen, og klik på Celler i menuen Formater for at få vist tallet som en procentsats. Klik på fanen Tal, og klik på Procent i boksen Kategori.

 
 
Gælder for:
Excel 2003