SUMA

Sečte všechna čísla v oblasti buněk.

Syntaxe

SUMA(číslo1;číslo2;...)

Číslo1; číslo2; ...     je 1 až 30 argumentů, které chcete sečíst.

Komentář

  • Sečtou se čísla, logické hodnoty a čísla zapsaná v textové podobě přímo do seznamu argumentů funkce. Srovnejte výsledky prvních dvou příkladů.
  • V případě, že za argument funkce zadáte pole (matici) nebo odkaz, jsou sečtena pouze čísla obsažená v uvedeném poli (matici) nebo v odkazovaných buňkách. Prázdné buňky, logické hodnoty, texty či chybové hodnoty obsažené v oblasti buněk nebo v odkazované buňce jsou ignorovány. Výsledek takové funkce je ve třetím příkladu, uvedeném níže.
  • Pokud je argumentem chybová hodnota nebo text, který nelze převést na číslo, vrátí funkce chybovou hodnotu.

Příklad

Příklad snadněji pochopíte, pokud jej zkopírujete do prázdného listu.

ZobrazitJak?

  1. Vytvořte prázdný sešit nebo list.
  2. Vyberte příklad v tématu nápovědy. Nevybírejte řádek ani záhlaví sloupců. 

Výběr příkladu z nápovědy

Výběr příkladu z nápovědy
  1. Stiskněte klávesy CTRL+C.
  2. Vyberte v listu buňku A1 a stiskněte klávesy CTRL+V.
  3. Chcete-li přepnout mezi zobrazením výsledků a zobrazením vzorců, které vracejí tyto výsledky, stiskněte klávesy CTRL+` (čárka nad vlevo) nebo v nabídce Nástroje přejděte na příkaz Závislosti a klepněte na příkaz Režim závislostí vzorců.
 
1
2
3
4
5
6
A
Data
-5
15
30
'5
PRAVDA
Vzorec Popis (výsledek)
=SUMA(3;2) Sečte čísla 3 a 2. (5)
=SUMA("5";15;PRAVDA) Sečte čísla 5, 15 a 1, protože textové hodnoty jsou převáděny na čísla a logická hodnota PRAVDA je považována za číslo 1.
=SUMA(A2:A4) Sečte první tři čísla ve výše uvedeném sloupci. (40)
=SUMA(A2:A4;15) Sečte první tři čísla ve výše uvedeném sloupci a číslo 15. (55)
=SUMA(A5;A6;2) Sečte hodnoty v posledních dvou výše uvedených řádcích a číslo 2. Odkazy na buňky neobsahující číselné hodnoty nejsou převáděny, hodnoty ve výše uvedeném sloupci jsou ignorovány. (2)
 
 
Platí pro:
Excel 2003